Fairphone 4 - Account setting doesn't work

Hi all,
As per title, I have a Fairphone 4 and when I try to open the Account Setting it doens’t work.
I tried to enter account manager: settings > Password and accounts > add account.
It try to open but it remain blocked in a completely white screen. It is also impossible to swipe in order to close it.
I also checked all the autorizations and it seems everything set as needed.
I curently unable to add any accounts. In addition, during my tries I deleted my /e/ account and now I can not add it again.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Hi Aleisdone,

I’ve got the same issue as yours since I think version 1.5 (Android 11 and 12 now).
I also have FP4. As I look for some similar issue, i did not find exactly the same as ours but some people which are facing similar issues with their account manager (git hub - #6291, git hub - #5793).

Which version do you have ? Did the issue came after you updated your phone system ?

For me synchronization is ok as my mails are still up-to-date. How is it for you ?

Hi luc_pcm,
Thank for your reply.
The isue came after last os update.
Mail sync is working, the issue is with contacts and Calendar (also for google accont).

1 Like

In the last updates, some changes indeed happen to the Account Manager (uptate 1.5).
It is then possible that some changes in the configuration of the Account manager to the new DAVx5 version imply the current behaviour of our app (Account manager Git project, DAVx5 Git project).

So as it seems to be that the DAVx5 update raised no issue on this topic, may be downloading the app in the app Lounge is maybe one temporary solution to get your e account back on your phone (I am not sure). Then we can hope that next update 1.6. will solve the issue (as we can see on the git, the project edition is still active and the modification will probably be introduced with a newer version).

I am sorry, I am not very helpful, but I am also a bit lost about what can be the source of the issue :joy:

I had the same issue, but I could fix it that way:

  1. Remove DAVx5 (If already installed)
  2. Settings => search for “account manager” => open “account manager app info” => “storage and cache” => clear cache and user data.
  3. You can now add your /e/ account normally.

Hi stanwood.
I followed your steps and I worked, but now isn’t working again.
I think I will install DAVx5 again.
Thank you.

1 Like

Indeed, after those steps you are able to add a new account, but once done “account manager” freezes again. Hope it will be fixed in a future update.

1 Like

Thanks for the solution at least, for me it enabled me to change a password, even if when I ckick on “back” once done, I come back on the starting page tutorial of the updated Account manager version. Yes hope it will be fixed :pray: