Fairphone 4 :Camera-Problem after update

After the last update to e/OS v1.5, one of my three cameras on the back (Fairphone 4) does not work anymore. Any suggestions what I can do?

Hey, i get the same error and just havent noticed it yet.
A clue may be that the app trys to adress cameras with ids 0,2,3 and not 0,1,2 where 3 fails to open ?

@MariAnne I don’t have this phone; mine is Oneplus 9and I’ve been investigating cameras for that just recently. There are only two image cameras on the back of FP4 and as far as I can tell . the third lens is a light and color sensor for fast autofocus. So that’s probably why ID 3 doesn’t open.

You can obviously test camera by putting finger over the lens when switching.
Maybe you could test the TOF by taking pictures with the TOF lens covered and uncovered also. It would be interesting to hear the result.

In addition to @winkman 's post, Lens ID 1 is most likely the front/selfie camera.

If one goes into the camera settings, Camera Controls section and select On screen GUI…, then scroll down and toggle off the Multiple cameras icon this will enable scrolling through the lenses using the camera switcher instead and you will find ID 1 as the selfie cam.


Yes you are right,
by cycling through cameras i see that id 1 is the selfie cam

Oh my. I can confirm the bug as well, didn’t notice it since I do not much use the selfie camera.

Fairphone 4, 1.5.1-s stable.

Same error message when I try to open camera ID 3. Weird that this hasn’t be tested though…

Did you try to clear camera app cache and user data?

If still doesn’t work you might search if an issue is already opened on Gitlab, and if not open a new issue.

Edit: Clearing cache and user data does not help.
I moreover noticed that one can still use the selfie camera by using the double arrows icon just to the right of the photo capture button. So in reality all lenses are working well, but the ID:3 camera should be removed from the app to avoid the error message.

1 Like

Don’t think this is a problem but a workaround.
On my FP4, A12, 1.5.1 stable, ID0 is the main camera, ID2 is the wide camera, ID3 isn’t a camera lens (in a preevious veesion of the camera app, ID3 seems to works but when shot for a photo the app doesn’t respond no more).
The icon for the selfie camera is another (as @stanwood write).

1 Like

Camera ID 3 has been a “copy” of camera ID since the beginning of FP4 and /e/OS. So there was imho never any sense of this camera ID.
This means it’s more a “cosmetic issue” that there’s an error now if you select this ID (no camera function is missing).
Still I agree that raising an issue on gitlab may be helpful to remove this ID once and for all.


So I raised an issue in Gitlab:


Thanks for pointing this out! I was convinced that only the two back cameras work with OpenCamera on my FP4, but I just missed the extra switch button.

This is still the same in v1.6, but hopefully will get improved further in future updates :slight_smile: