Fairphone 4 GNSS time incorrect

Hi all!

Yesterday, I took a giant leap from iPhone to Fairphone 4, and installed /e/OS to be Apple/Google independent. The experience is all right so far, but location services are not working well. Mozilla is many kilometres off, but never mind that. I want GPS location first.

Two issues:

  1. The GPSTest app finds the GPS location, but it’s not used in the Magic Earth app, it only shows my super inaccurate Mozilla position. I just can’t find a way to enable accurate GPS position instead of just network location.
  2. GPSTest and Tower Collector both report the the GNSS time is incorrect, September 2002… Much searching has not revealed any way to set GNSS time, I think that’s a hardware specific thing where it gets the time from the GPS satellites.

Does anyone else have these issues on FP4? Are these settings configurable with another app? Do I need a gps.conf file that I’ve seen mentioned in some places?

Hi jswetzen,
I got my FP4 from the murena shop whith e preinstalled. Positioning worked well from the beginning.
So this seems not to be a general FP4 problem to me.

That’s comforting to hear at least. Maybe it will sort itself out over time… I’ve read that GPS can take a long time to get the position. Still, the “incorrect GNSS time” issue is strange

Actually @winkman it would be really helpful if you could download the GPSTest app, wait for a position lock and verify that it’s not showing any warning about incorrect time. I’ll post a screenshot for what it looks like for me as soon as the GPS has found my position, still waiting here.

@winkman no need to check GPSTest, I had a eureka moment. But not one of those where you feel clever…

Because I’m coming from iOS and the transition is anything but smooth I thought I’d get everything set up in /e/ before I make the switch. For future reference: location is not very accurate without a SIM card, and the GNSS time issue is gone after one connection to my mobile provider.


Glad to hear it works now … and weird it doesnt
so without sim

Not on FP4, but I’ve been experiencing this “Bad GNSS time” issue systematically, on a Galaxy S9+, since at least 3 weeks at least. With SIM OK, used every day.

I noticed it while investigating with SatStat and GPSTest, after the GPS location stopped working on 2 apps (TrackBook and Naturalist), whereas still working fine on others (OSMAnd, GeoPortail, …).

Seems to be related to e-OS 1.2 or 1.3, possibly an update around or in microG ?

See GPS no more working on S9+ for some apps since 1.2 (#5984) · Issues · e / Backlog · GitLab.