Fairphone 4 - stuck on recovery screen - need instructions for further action

i run into trouble with my fairphone 4, last /e/ installed.
After an accident where the phone became a little wet, the phone shut down at night (with approx 55% battery power).
I booted the phone without recognizable issues, except charging did not work any more.
Then i noticed water in one camera lense and powered the phone off.
I removed the battery and tried the phone using a hairdryer (mid temperature).
After reassambling the phone it starts in the recovery screen (version 1.20 (), Active Slot b) with the offer off:

  • Reboot System now (did not work - i get back to this screen)
  • Apply Update
  • Factory reset
  • Advanced, with this Options:
    – Enter fastboot
    – Reboot to bootloader
    – Reboot to recovery
    – Mount/unmount system
    – View recovery logs
    – Enable ADB
    – Power off

How should i proceed to get back to my working system with all the applications and settings?
Or at least, if this is not possible, how to get access to some files, especially the photos stored on the phone?

Thanks a lot in advance, best!

ps: i am new to alternative mobile operation systems, so please explain for “dummys” ; )

Download adb and fastboot: https://developer.android.com/tools/releases/platform-tools .Select enter fastboot on your phone. Type ‘cmd’ in the windows search. Enter this command:

fastboot --set-active=a

restart the phone.

1 Like

Thanks a lot!
I will do try this next weekend, when i am back from my holidays.

Am i right, the issue is the phone looks up at a wrong “slot” for start?

so I tried to send the command from the Mac via terminal to the USB-connected phone, but unfortunately got an error message:
fastboot --set-active=b
Setting current slot to ‘b’ FAILED (remote: ‘set_active command is not allowed on locked devices’)
fastboot: error: Command failed

My research showed that when I unlock the bootloader with adb, the phone does a factory reset. This is actually not desired on my part. How can I proceed without losing data/settings?

Also, to understand the problem (and what i propably did wrong) - why switched the phone to slot b?

How can i copy at least my photos and videos to my mac using adb? I found the pull command, but i cant find any folder with my photos. i assume ls -R / will show only files and folders from slot b, but not from slot a where the photos should be?

I don’t think slots affect your storage.

I like this manual https://adbshell.com/

I am not a Mac user, but here is a trace of my exploring a working device from Linux PC.

Finding /sdcard/DCIM
$ adb devices
* daemon not running; starting now at tcp:5037
* daemon started successfully
List of devices attached
5xxxxxx7	device

$ adb shell
bacon:/ $ ls
acct  bin         cache   d     data_mirror    default.prop  etc       init             init.recovery.bacon.rc  lost+found  odm  persist      proc     res     sepolicy  sys     system_ext
apex  bugreports  config  data  debug_ramdisk  dev           firmware  init.environ.rc  linkerconfig            mnt         oem  postinstall  product  sdcard  storage   system  vendor

bacon:/ $ cd sdcard/                                                                                                                                                                                                                        
bacon:/sdcard $ ls
Alarms  Android  Audiobooks  DCIM  Documents  Download  Movies  Music  Notifications  Pictures  Podcasts  Ringtones  SMSbackup  TWRP

bacon:/sdcard $ cd DCIM
bacon:/sdcard/DCIM $ ls
Camera  Camera_2021-10  FJCamera  OpenCamera  Readme.md
Explore with root

Not all / many devices will allow root.

$ adb root
ADB Root access is disabled by system setting - enable in Settings -> System -> Developer options

– I can do that.

$ adb root

$ adb shell
bacon:/ # cd data
bacon:/data # ls
app-ephemeral  lineageos_updates  preloads                   user

bacon:/data # cd user                                                                                                                                                                                                                       
bacon:/data/user # ls
bacon:/data/user # cd 0
bacon:/data/user/0 # ls

There might be things you want to copy from this long list if accessible

$ adb unroot
restarting adbd as non root

thanks a lot, but all folders like DCIM, Pictures etc. on the sdcard are empty. after removing the sdcard i inserted as additional storage, “adb devices” found no device nor emulator, ls found no directories at all.
i think, the system is dead, maybe with a hardware issue.
waiting for fairphone support reply, but im afraid, i have to send the phone to service.

Don’t misunderstood, we are talking about android file arboresence here : In the above demonstration "/sdcard" is the name for “internal storage” when "/external_sd" or "/sdcard1" is the name of additionnal “physical SDcard”

thats clear, but as i mentioned, after removing my additional micro sdcard, no device are found at all, nor directories by searching “adb shell ls /”.
so the “recovery” do not find/mount any device/partition at all.

This topic was automatically closed after 60 days. New replies are no longer allowed.