Fairphone FP4 failing SafetyNet CTS

Hi there,

I installed e on my FP4 following official instructions using the easy installer. I understand that the e team has worked very hard to pass SafetyNet on all devices (especially such a popular device as the FP4?) but when I download YASNAC SafetyNet checker it says basic integrity pass, but CTS profile match fail. Does anyone know the reason or any way I can fix it?

/e/ OS version: 1.12.3-s-20230615299639-stable-FP4
Build number: e_FP4-user 12 SQ3A.220705.004 eng.root.20230615.051601 dev-keys


  "apkCertificateDigestSha256": [
  "apkDigestSha256": "6eSwd6Ed+f4Pab9sXTvk+hqbA8VFtfdCnYlznf+zIbc=",
  "apkPackageName": "rikka.safetynetchecker",
  "basicIntegrity": true,
  "ctsProfileMatch": false,
  "evaluationType": "BASIC,HARDWARE_BACKED",
  "timestampMs": 1689779992740,
  "deprecationInformation": "The SafetyNet Attestation API is deprecated. It is recommended to use the Play Integrity API: https://g.co/play/safetynet-timeline."

I have already tried some stuff using Magisk (following this suggestion) but I think that may have messed me up even further. I now have a weird issue with Magisk where it says I need to install the full version and then hangs for ever. But since I am not even sure that using Magisk is the answer to pass SafetyNet attestation I decided to ask about this question first.

Thanks for any tips!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.