Fastboot: error: cannot generate image for userdata (SOLVED)

Hi all,

I am trying to install /eOS emerald on a 2021 Murena Teracube 2e and my computer OS is MX Linux, which is a Debian based distribution.

I downloaded adb and fastboot via the command line which seem to be working fine, and have the rom extracted to the platform tools folder, which I got from the android developer site.

Got through all the installation steps but when I run fastboot -w reboot I get “fastboot: error: cannot generate image for userdata”

Is this because of an issue with the adb and fastboot from the Linux repository? I removed them and tried running the adb command from the platform tools folder but it keeps saying permission denied, even as root.

Need help with next steps to get this installed correctly. Thanks

Edit: I restarted the phone and it booted into /e/OS. Everything seems to be running fine, I hope!

Hi @50watts welcome to the /e/ forum.

Just to clarify … are you saying that you ran though all the flashing commands shown;

then just

fastboot -w reboot


Please confirm you treble checked you have an emerald.

fastboot --version

would show you the version you have of “System” platform-tools.

SDK Platform Tools release notes  |  Android Developers

1 Like

Hi aidb, thank you

Yes, all the commands from start to finish went fine except for fastboot -w reboot which gives that error

I just ordered the phone new from Murena and the serial number starts with 2021, denoting emerald

Fastboot version is 28.0.2-debian

I did find a post which seems to refer to this issue, but I am not sure how to properly execute the command in step 3 of the Lineage OS wiki:

if [ -d "$HOME/adb-fastboot/platform-tools" ] ; then
 export PATH="$HOME/adb-fastboot/platform-tools:$PATH"

Tried editing ./profile and can’t find it, and I’m not experienced enough to know what the above means exactly. Not sure if that is even the issue, but it is mentioned as a solution in the forum post I linked.

This still is the fastboot command from your Linux distribution.

Try to run fastboot --version from the platform-tools folder. What does it say?
If it still says debian, then prefix the command with ./ while you operate in the platform-tools folder.

This part should add the platform-tools folder to the list of folders in which the OS looks for commands if you don’t specify the path for a command in the command line.
If this is absent, you will have to explicitly tell the command line that you want to run the command in the platform-tools folder either by always starting with whereveritis/platform-tools/fastboot or by operating in the platform-tools folder already and probably also prefixing the command with ./ (making it ./fastboot, explicitly pointing the OS to the fastboot command in the current folder you’re operating in).

Didn’t see this mentioned and not sure it applies here but oft times the adb tools require root.
Try the commands prefaced with sudo to see if it helps.

… and sometimes your PC will report an error … when there is no FAIL on the device !