Fastboot not working? need help!

Hi, I am trying to install e, but it seems to me that the “fastboot” is not working.

This is what it shows me, when I try adb and fastboot:

C:\Users\roman>C:\Android\platform-tools\adb devices
List of devices attached
GS290CTLC00119 device

C:\Users\roman>C:\Android\platform-tools\fastboot devices

C:\Users\roman>C:\Android\platform-tools\fastboot devices

fastboot: usage: no command


How do I know that “fastboot” is working as it should?

Thanks a lot!

It seems that you do not have the right drivers installed on your PC, so that your PC will correctly recognize your smartphone in fastboot mode.

Thank you for the fast response!

I got the drivers from the android website for windows 10.

For the “adb devices” it works.

Any suggestions on how to proceed? Should deinstall all and install them new?

Be aware that phones can not be accessed via adb and fastboot at the same time.

In order to test, if windows recognizes the device with fastboot, you need to get the device in fastboot-mode.

You can reboot most devices in fastboot-mode by issuing the command

adb reboot bootloader

This should take several seconds. Usually one of the lights on the phone indicates that the device is in fastboot-mode. Afterwards try

fastboot devices

If your device is not listed, the you should verify that the correct fastboot-driver is installed.


In general, the drivers for communicating with Android devices via ADB commands are different from the drivers for communicating via FASTBOOT commands.

So you should look for drivers for your device model, but to communicate in fastboot mode.

Thank you for the quick answers!

I tried “adb reboot bootloader” and know I see on the phone on the left side “fastboot mode…”

I am trying to follow the instruction for “”.

Now the phone is still on “fastboot mode…”. Not sure what to do next :frowning:

I wish there would be a step by step instruction.

Any advice?

I tired to follow the steps in the description:

download * Additional images:

What I get is this:

What should I do with this? :frowning:

Looks like your browser is configured to display this filetype directly.
Either configure your browser to download *.img files or use rightclick on link -> save link as

1 Like

Right click on the link you have placed, and choose the save as option.

1 Like

Thank you! it worked! :smiley:

Do I need to extract the zip file /e/OS build : dev?

Try to stay as close as possible to the installation instructions. Are there any instructions, that you should extract the zip?

Yes. I found it. It is said that it should be extracted. I did that.

I am trying to follow these steps: At Step 3 comes an error. (see below)

Install /e/

  1. Download and extract the /e/ ROM
  2. Download boot.img and recovery.img next to system.img file
    3. Reboot in bootloader with adb reboot bootloader
  3. Press volume up on the smartphone
  4. Run the following commands to install /e/

C:\Users\roman>C:\Android\platform-tools\adb reboot bootloader

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    error: no devices/emulators found


What is the problem?

I am trying to follow the decription, with this:

C:\Users\roman>C:\Android\platform-tools\fastboot flash --disable-verity --disable-verification boot boot.img
< waiting for any device >

Now wating for about an hour, and nothing happens…

The phone shows “fastboot mode”

What should I do?

You need to install the right USB-Drivers on your Windows-PC. I had the same problem a few days ago. Here’s the solution I found. Hope that helps.

1 Like

Thank you! Will try it!