Feedback for v1.12.3

I have no real insights to your issue but that battery graph is super strange. It says you are at 90% but with only 16 minutes left!? Wow. And then there are ups and downs. That should not be as you figured.
Once fully charged, and if ROM properly resets stats, it should be a steady (or drastic) decline but there should be no ups at all. Rises implies periodic charging. If you were not constantly charging your phone then something is definitely wrong.

It will also be hard to determine actual battery usage of apps.

Oops. Had to totally re-edit this. Mistakenly commented on Android OS and battery usage. :upside_down_face:

As far as memory usage of Android OS goes, that’s not a problem.
Android OS is always at the top of memory usage. In my case anyway.
crDroid A11, OnePlus 8T - 1.8GB.
/e/OS A11, Teracube emerald, 1.2GB.
Havoc OS A9, Moto G5 Plus, 0.96GB.
FireHound A8, Moto G5s Plus, 806MB.
/e/OS A10, Essential PH-1 mata, 1.0GB.
LeOS-R A11, Essential PH-1 mata, 0.97GB.

So your 1GB is not abnormal.

1 Like

Hi everybody. Thanks for all your feedback on this version as it has been very helpful.

One quick question to confirm something. Can I take a pass on this update and go from 1.11 to whatever is after 12.3 straight without having to update to 12.3?

1.11 has been the first time for me where I don’t have a battery drain some of the time and have had no other minor issues, so not in a hurry to leave 1.11

Plus I am seeing quite a bit of feedback in this thread that is making me nervous about moving to 12.3 when everything on my FP4 is working perfectly at the moment.

Really appreciate all the work form the e team and all your feedback!

Thanks in advance!

Yes you can, there is no need and you can update to any future version


Thanks! Appreciate the quick response.

As far as memory usage of Android OS goes, that’s not a problem.
Android OS is always at the top of memory usage. In my case anyway.
…So your 1GB is not abnormal.

That’s really interesting… Maybe I have to look elsewhere for the issue. I never paid much attention to how much memory my apps were eating in the previous update because I felt no need to, so maybe my Android OS was still using 1GB in 1.11.

And the bliss pbm of icons reorganization is back. Two reorganizations with no icons on the directt launching (bottom of the screen).
It seems that for the 2 last updates the bug is back.

1 Like

Yes, it’s true the launcher rearranges icons itself.

Wow - you put a lot of thought in this - long story short - at the bottom I listed non mint APN settings which is working.

May I please start off that the factory phone works was not a swipe - I was attempting (hard to tell in text only) to report the facts as I have in hand without a full understanding. I apologize if that was taken as a swipe. I learned years ago if you can have a phone backup, have it while you sort items out with flashing (learned on One plus one “bacon” days).

With the published “official” Mint Mobile USA APN settings: The factory Pixel 4a phone does work, I am not able to get MMS working on the /e/ Pixel 4a (or stock lineage, I tried that too… I did not test Pixel Experience, crDroid, etc as they are not the base of /e/)

I knew something was off. It makes complete sense Google is possibly working with carriers (I guess they have a script to change APN’s without showing it in a program “black box”?). This is exactly what stumps me (or was something broken on the specific build, I had/have no idea)

I Always manually program in my APN settings. With that said, I never even entertained the pre programmed APN’s. I had some time to play late last night, I did not want to post until I had some information. I do not want to clog this thread with too much chatter without an intelligent update
Background: Mint was recently purchased by T-Mobile, I do not know any official date of any transfer. With that said I found and APN that works (I did not call, I tested different APN’s). The one that DOES work with Wifi on and off and outside of my house is the T-Mobile one already in 1.12 S Dev. (even tough I am on Mint Mobile mvno of T-mobile)
Both use MCC 310, MNC 260.
NOTE; Pixel 4a does NOT have the modem for 5g, therefore I am unable to confirm if working.

For the setting that I can confirm working right now. Pixel 4a/sunfish. /e/ OS version 1.12.3-s-20230617300623-dev-sunfish on Mint Mobile as of today 10 July 2023

(options not listed below is left blank)
MCC: 310
MNC: 260
APN type: default, supl, ia, xcap
APN Protocol: IPv6
APN Roaming: IPv4
MVNO type: none

What do you use to display the used memory?
It is not a built-in feature of /e/OS, is it?

From the screenshots I took? That screen can be accessed from the system developer tools. For a quick glance at my usage, I use AIO Launcher which features a system stats widget (it also tracks internal storage, screen time and battery)

Exactly, the one from the screenshots.

Found it now.
Thank you!

To conclude my issue:
A couple of days after upgrading to 1.12.3 I was offered to upgrade to 1.13 (beta). That solved all my problems.


I have a Samsung galaxy s10+ with s version, and have a drain issue now with the s v1.12.3
the one service is a wakelock with 23%
and an app wish is use for a smartwatch that i don’t use since 3 month, and try every time to force to shutdown but is still remaining, and take 25%.
Normally it shall parks it to the unused apps which should be deactivated…
I don’t know how may i definitively stop it (without to uninstall it).

the drain because of media storage is disappeared, I had it with the older version. now the problem moves to an other one…

I have some trouble with the new GPS, too. If GPS is turned on, my apps crash right after the usage of a map. E.g. Tesla App - if you tap on “Location”, then it crashes.

I have found a workaround:
Turn GPS off, turn on the map function, turn on GPS again. For me this seems to help on my FP4.

1 Like

Samsung Galaxy A5
Don’t know previous version anymore but had the latest.

Only issue so far: i cannot hide my real IP address in Advanced Privacy anymore. When i toggle it to hide it, it switches back to exposed.

Murena Fairphone 4

I have a Murena FP4 and have never had a problem with the updates for 18 months (since /e/OS 0.21).

Now, with 1.12.3 however, that is over: There are temporary display problems: A strip keeps appearing at the bottom of the screen that cannot be used by apps or the Bliss Launcher. A row of icons also slides to the next page, since there is no more room for 4 apps.

If I switch from gesture control to 3 icon control and back again, the home screen is back to normal for some time.

I have already completely reset and restarted my FP4 three times. But that does not change anything.

Translated with (free version)

In case the problem is created by Bliss you might try

Settings > Apps and notifications > See all … apps > BlissLauncher > Storage & cache > Clear storage

If you have “organised” your app positions, this will be lost and your apps will return to the default positioning (alphabetical).

Sorry, that doesn’t help, after a reboot the screen changes from 7x4 icons to 6x4. And a gray space at the bottom of the screen appears in several apps.

I think I have seen a similar fault reported on this forum before, with a fix … but I cannot find mention of it so far.

It sounds like a fault in display size, ratio or resolution. I suggest you try Search feature of Settings, searching for Size, Display, Ratio. In each setting you find perhaps try each extreme to see if you get any clues.

Do you see just the same in Safe mode ?

Press Power button > long press on Power off.

Later Edit So do you prefer Gesture control ?

If you use the 3 icon Navigation bar does the phone work better ? Is the blank area which you report now occupied by Navigation bar ?

1 Like

Exact the same GPS issue on my wifes FP3. Seems ok at the start using it as navi in the car, but after a few minutes it gets unusable.