Feedback for v1.17

Updates come OTA for official dev and stable builds.

1 Like

Google Pixel 4a5g, bramble
from eOS 1.16t to this version
not rooted.
Update OTA

All is well except I seem to have lost emoji 's (they are not present as an option) in the stock SMS app, they are present in Signal.

Also hitting reply in SMS pop up window does not always open the reply dialog.

Not sure if this has to do with the update but it happen directly after the update to 1.17.

Yes I realize it emoji but I never realized how useful they can be until now :slight_smile:

  • Vendor Name : oneplus

  • Device name : nord avicii 2003 EU

  • Version of /e/OS or Stock which existed previously : 1.17S from android stock12

  • Is the device Rooted / Not rooted: Not rooted

trying the stable S
i can’t access the recovery. i think there is some issue with the recovery zip as if i switch to the lineage recovery, i can access the recovery but i can’t complete the OES1.17S install because of an SPL error - downgrade…
i believe because linage recovery 20 is on A13.
if i try a precedent lineage20, no SPL error but EOS1.17S can’t be installed due to a different vendor name… file expected for Oppo Nord while are for Nord only… this is the error reported more or less…

what a confusion…
other installed on Nord without any issue?
i had been able to put Eos 0.23 when i had Android 10 in the past…

That is right. But in the meantime I’ve installed 1.17t. I did a factory reset and made a clean installation. After this I had no more trouble with my phone calls. Volume control works like it should. I have no idea what was the reason to be honest. But its ok, problem is solved.

Thanks! But now it works for me.

I decided to leave the bootloader unlocked as I’m forced to. So I can install the next updates via ADB sideload and can change the slot if necessary.

But that was the second time among the last three updates I ran into that bootloop. I’m a little bit pissed off…

Perhaps you could expand … the recovery is now (and only recently started [1]) delivered as Recovery and boot img which is a “package” of required components as a .zip file. When extracted is found:

recovery-IMG-e-1.17-s-20231109350748-stable-avicii$ ls

As shown above each component has a checksum. Always best to check the sha256sum before use, or especially if there is suspected “some issue”. Or are you actually finding a checksum mismatch?

[1] Week 47 2023: Development and Testing Updates

Of course downgrade of Android 13 (T) Lineage 20 to Android 12 (S) is quite likely to be problematic.

The error SPL error however may simply be the result of the Lineage build having an Android Security Patch Level in advance of /e/OS 1.17; from release notes,,

This /e/OS v1.17 includes the Android security patches available until October.

  • Vendor name: FP3

  • upgrade from 1.16s to 1.17s

  • not rooted

I am not able to answer calls. The phone is ringing, but no screen to answer / accept the call is shown. The phone has multiple profiles of which one has no rights to answer phone calls. However, the other profiles have the rights. I am not able to answer calls on the main profile with all rights.

OTA … Ok … But I can only use wifi now …

  • Fairphone
  • FP4
  • 1.16-s-20231017342507-stable-FP4.
  • Not rooted…
    Tout est ok

New version: 1.17-s-20231109350748-stable-FP4

Vendor name: Fairphone
Device name: FP4
Device code name: FP4
Version of /e/OS or Stock which existed previously: 1.16-s-20231017342507-stable-FP4
Device not rooted

Until now no problems detected. Can confirm that sound intensity during calls is a problem.

Hello @Cabnedor, could you elaborate on your problems? I have had a bad experience myself today when I reconfigured a CalDAV calendar hosted on a Nextcloud instance. At first, I could not connect to it. It only worked when I first used my primary password to login and then the device-specific password for the account afterwards (see here where it is explained how to generate a device-specific password on NextCloud/
However, there was a timespan of several hours between my attempts, so it may have been a coincidence that it first did not work.

ok … I don’t install myself but buy phone with e-os.
2023-11-21 10:30 : perhaps say “Not rooted” in this case (I see now Manoj’ question “Is the device Rooted / Not rooted” … perhaps add a “?”).

Vendor Name: OnePlus
Device name: OnePlus 6
Device CodeName: Enchilada
Version of /e/OS or Stock which existed previously: /e/OS S 1.16
Is the device Rooted / Not rooted: Rooted (Magisk)

I first updated to /e/OS S 1.17 and then used the upgrade instructions (i.e., sideloading) to upgrade to /e/OS T 1.17. The upgrade went smoothly and was a pleasant experience. I only had to re-root my device (this was expected because of sideloading). Moreover, I had to reinstall my launcher (Neo Launcher) because it caused wakelock problems after the upgrade; this seems to have fixed the problem.

I am quite satisfied, but I have experienced strange CalDAV synchronization problems. I use Simple Calendar Pro as my primary calendar app.

  • When I use the synchronization option in Simple Calendar Pro, the synchronization does not happen. Adding or deleting appointments seems to work, however, they are synchronized.
  • The account information does not properly display the time of the last synchronization, but the time of an older synchronization. However, the Account Manager shows in the properties of the calendar that a synchronization has happened as expected.
  • After a restart, the address book synchronization is activated again although I had deactivated it. This problem may already have been there in /e/OS S 1.16.

I will investigate further and may open a bug ticket.

EDIT: I have noticed that the synchronization gets stuck/stops working after a couple (maybe two?) days. I will investigate and probably open a bug ticket. A restart resolves the problem for the next two (?) days.
EDIT 2: The corresponding bug ticket #7594 has been opened.

Gigaset GS-290
not rooted

Installed v1.17 today. Still the same issue - cannot send SMS!

This problem has persisted since installing v1.15 two months ago, and affects Murena One, Murena T2e and Gigaset GS-290 phones.

Vendor Name Fairphone
Device name : Fairphone 4 5G
Device CodeName FP4
Version of /e/OS or Stock which existed previously 1.16-s
Is the device Rooted / Not rooted : not rooted

This new version works well, thousands thanks to the team.

By reading 1.17 release notes, I understand that Fairphone 4 (FP4 5G) runs Android 13 while mine still runs Android 12 even after 1.17 installation. My question is : how can I get Android 13 under /e/OS Murena please ?

Best regards.


FP3+, previous was 1.16. Using the App Lounge to search I get this error continuously:

And refreshing makes no difference (closing and restarting the app store)

Do you use Advanced Privacy with Fake IP?

If you want OTA, you’ll have to wait. If you want to install (delete Android 12 and install Andeoid 13) it manually, you can do that asap.
1.17s is Android 12
1.17t is Andeoid 13

Thank you lapor for your answer. I do not know how to delete Android 12 through easyinstaller. So I think I will wait Android 13 OTA from /e/OS Murena, hoping it will arrive soon.

Best regards.

1 Like

I will also wait for OTA :slight_smile: