Feedback for v1.19.1

Just tried to upgrade my Fairphone 3+ (not rooted) through the /e/ recovery using ADB Sideload – from /e/OS 1.17-s-dev to e-1.19.1-t-20240113373116-dev-FP3 using the download from https://images.ecloud.global/dev/FP3/ I went this way going from Q to S before, but this time I’m stuck here (I chose to ignore the signature verification failure):

I downloaded the zip from https://images.ecloud.global/dev/FP3/ again on a different computer, but the error(s) remain identical. Am I using an all wrong download?

UPDATE: :white_check_mark: SOLVED by AnotherElk’s reply (see below) :+1:

3 Likes

Saludos:
Vendor Name: Xiaomi
Device name: Mi 10T Lite 5G
Device CodeName: gauguin
Version of /e/OS previously: e-1.18-s
Device not rooted
Updated OTA
Thanks

Vendor Name - Samsung 
Device name - S10
Device CodeName - beyondlte 
Version of /e/OS or Stock which existed previously
E18s
Is the device Rooted / Not rooted - Not Rooted

Updated OTA

Thanks again team for an outstanding build :+1:

Yes.

6 Likes
Thank you! I drew a picture just for you!

1 Like

Fairphone | FP3+ | FP3 | previously on /e/OS 1.17-s-20231111351092-dev-FP3 | not rooted

All data seems to have been taken over, cannot find any data loss in phone app, calendar nor messages. :slight_smile: Thank you folks! :slight_smile:

FP3 upgrade from 1.17-S to 1.19.1-T

Went through /e/ recovery and used ADB sideload to install the upgrade from the computer. (Eventually) Used the download link @AnotherElk suggested (direct download shortcut to save you having to sort out the back slashes size: 1.1 GB). Took just a single-digit number of minutes to install. A bit doubtful at the end when the FP3 recovery display’s bottom line just read (step) “2/2” and no (further) confirmation that install was completed. Just went back to the recovery home screen and rebooted into system, and there it was booting into Android 13. :+1:

P.S.: Unfortunately the Recovery still would not offer me any option other than installing through ADB Sideload. No SD card option (although portable storage SD card is in the device) shown, neither internal storage.

6 Likes

Only if you have compatible install file .ZIP stored into it, (perhaps at the root of the SDcard)

I’ve tried that now both with the internal storage and the SD (first at the top level of the file tree, then in the Downloads folder – with both IS and SD), but no difference. Now given that this is the installation file that is now already installed, it might not qualify as “compatible” anymore? Might try again with the next smaller update.

  • Vendor Name: Samsung
  • Device name: S10e
  • Code name: beyond0lte
  • Version of /e/OS which existed previously: 1.18-s
  • Not rooted

No issues so far. Thanks for good work to the team!

1 Like
  • vendor name : xiaomi
  • device name : MI10T
  • device code name : apollon
  • Previous version of /e/OS : 1.18S
  • Rooted

No issue so far. Everything OK :slight_smile: Happy new year to the team and congrats for the good work.

  • vendor name : Oneplus
  • device name : 8T
  • device code name : kebab
  • Previous version of /e/OS : 1.18T
  • Rooted

Impossible to upgrade. When download is finished, package verification starts and immediatly an installation error is issued.
I try that : Issues with the Updater and a solution without any success.

I’m on a Samsung Galaxy S7, herolte. We haven’t had an update since v.1.17. Just wondering, is this the end of the line for us?

The herolte will get an OTA OS upgrade from Q(Android 10) to R (Android 11) as mentioned here. Will share dates when it will be released.

3 Likes

Awesome, thanks Manoj!

FP2, not rooted, Open Launcher 1.18. → 1.19.1-r
All fine :+1:
Tested: MullvadVPN, Signal, Firefox, FreeOTP+, KeePassDX, Aurora, f-droid, easybank app
Especially the bug in the Emailclient (see feedback 1.18) is solved :100: - Cheers!

1 Like


Widget calendar in dark mode is unusable. Above is Agenda Todo opensource widget, below e/OS default calendar.

Vendor name : lenovo
Device name : yoga tab 3 plus wifi
Device code name : YXT703F
Previous version : e-1.18-r-20231209360969-dev-YTX703F.zip

No issue, everything OK so far.
Good job e-os team

But for my kekab daily device it’s not the same story, I try a manual update with adb sideload!
It was not a good idea…
I just download the e-os-T-1.19.1 release, verify the MD5 hash code, and flash the new release with adb sideload.
After rebooting from recovery to system, I am still in 1.18 version but it seems some apps have been updated. For example, Magic Earth is released to 7.1.23.49. More than that, apps which use location data don’t works in fake location mode.
In conclusion a bunch of discrepancies, I’m afraid of reinstalling the whole stuff (fresh install).

Today, my recomandation to kebab owners, is to wait for a fix before switching to 1.19.1 release.

Vendor name : Pixel
Device name : 6a
Device code name : bluejay
Previous version : e-1.18-T-dev

Everything worked smooth. Even after 24h no hickups observed.
Thanks.

Vendor name: Motorola
Device name: Moto One Action
Device code name: troika
Previous version: e-1.18-t
Not rooted

No issues since yesterday. Used apps are mainly Firefox, K9 Mail, Organic Maps, Signal, Öffi, Calendar/DAVx5, KeePassDX.

Thanks to the dev team.

:fr:
Hi,

Vendor Name : Fairphone
Device name : FP3
Device CodeName : IMG-e-1.17-s-20231111351092-dev-FP3.zip 
Migration : e-1.19.1-t-20240113373116-dev-FP3.zip 
Is the device Rooted / Not rooted : I don't know, it's stupid anyway. And I haven't found a reliable article to verify it. Given what I do on it, it must be rooted.

Thank you for all the sharing, it’s been very helpful.

I wanted to follow an old article to sideload the FP3, but the page no longer exists (here (not function of course)). It’s a good thing I wrote it all down in my documentation. There’s nothing in the docs and it took me at least 45 minutes to find the page with the info on FP3.

I had exactly the same problem as @urs_lesse (here) on the signature part of the .zip file. It’s due to a lack of knowledge on my part.

Apart from that, I only have one problem and the update was installed in less than 10 minutes.

The problem was that VLC was no longer reading my SD card. I uninstalled the application and reinstalled it. Since then, VLC has been reading my SD card just fine, with no problems.
And I’ve enlarged the display font by one notch. It was written slightly smaller

Here’s what I did:

  • First, add adb and fastboot. Follow the instructions here.

  • Find the right file here, thanks you @AnotherElk . It’s in JSON format, my file is on line 28.

  • Then activate the developer tools, plug the phone into USB: activate USB debugging (authorised by the PC) & unlock the OEM (see the start of the procedure here). At the end of the procedure, disable everything by doing the reverse.

  • Make sure you back up all your applications, photos, videos, OTP, etc.

  • Run the adb commands from the downloaded folder (I’m running Linux, Debian 12):

  • ./adb reboot sideload (the phone reboots and goes into sideload mode)

  • ./adb sideload
    /mnt/X/Save\ FP3\ 17012024/e-1.19.1-t-20240113373116-dev-FP3.zip

  • The phone reboots. Unplug everything and check that it works.

  • Keep the procedure in documentation if you wish, but above all share it here :).

The question I ask myself. Now that I’ve changed the way I upgrade, will I receive updates normally or should I always use sideload for updates and upgrades?

Thank you
Have a nice evening

4 Likes