Feedback for v1.21

so as you already have formated /data you can install previous version from recovery


No recovery possible without using adb sideload e-1.20-s-*.zip and a data formating, but my phone works again !

There is a bug in the update that they are aware of and currently working on it

Vendor Name : FP
Device name : FP3
Device CodeName : FP3
Version of /e/OS or Stock which existed previously :  1.20
Is the device Rooted / Not rooted Rooted

I have lost text message emojis (on all text message apps)
everything else seems to work fine yet


No Wifi on Motorola G5/cedric after update to e-1.21 from 1.20 via OTA. Device unloicked, not rooted.

1 Like

A regression issue with v1.21 of no wifi post upgrade has been detected on Murena One and Moto devices. The team is aware of this and working on a fix. Will update on the progress of the resolution.


Galaxy S7 (SM-G930F)
now: 1.21-r-20240322388914-stable-herolte
Not Rooted

No issues so far after 3 days of normal use.
Once more: Thanks a lot for keeping that hardware alive!


#citymapper still fails, the only one GPS-related app failing (has always been the case here)

Vendor Name : Fairphone
Device name : Fairphone 3+
Device CodeName : FP3
Version of /e/OS or Stock which existed previously :  1.20
Is the device Rooted / Not rooted: Not Rooted

Update went smoothly, as usual. All seems fine a few days after the update. A bit slower than under 1.20, but maybe that’s the way it will be with the new Android version now on that device.

Thanks for the good work! :smile:

Device “redfin”
Settings - Advanced Privacy - Real ip address
toggle bugged

To look for a solution, I activated a VPN app under “Settings” and restarted the device. After restarting the device, the toggle under ‘settings - advanced privacy’ was set to ‘REAL IP ADDRESS hidden’
The VPN app set before the restart was deactivated by the restart!

So I got this notification about new version of /e/. After reboot however it said
ERROR: recovery: failed to verify whole-file signature
Signature verification failed
error: 21

Is this something devs can fix or it’s a problem on my Galaxy S10?

Fairphone 3+
Upgrade from v1.20-s-stable to v1.21-t-stable
Not rooted

Update straightforward and completed in just 30 minutes, 5 minutes quicker than for a normal update despite download taking longer.

Initial testing of basic functions & apps shows these appearing to be working fine: wi-fi, mobile data, bluetooth, GPS, phone, message, mail, browser, camera, app lounge and various other apps.

The big improvement for me is that my long-standing issue of no automatic VPN re-connection appears to be resolved. Once I’ve done further testing I’ll update the GitLab issue I raised a year ago now!

Just two issues found so far:

  1. One app which I usually have force stopped (to stop it searching for wi-fi networks without my knowledge) is now restarting each reboot.

  2. I can’t play any audio or video on VLC at the moment, I’m getting a ‘Multiple media cannot be played’ message each time I try. Edit: I’ve now fixed this by enabling VLC access to all files in phone settings menu under: Privacy / Permission manager / Files / ‘See more apps that can access all files’. I assume this permission was lost in the upgrade.

Other than these it’s looking very good, thanks again for all the good work.


Just a guess: Were you installing it manually or OTA? If it was manually, I got an error: 21 myself a while ago (on a Fairphone 3) and my mistake back then was that I used a wrong file (wrong source: … right source: …):

Same with my S7, thanks again! :grinning:


Vendor Name : Fairphone
Device name : Fairphone 4
Device CodeName : FP4
Version of /e/OS or Stock which existed previously : 1.20-S (Stable)
Is the device Rooted / Not rooted: Not Rooted

For both devices (my wife and me), everything’s perfect after a few days.
Hope next time will be Android T (13) upgrade :wink:

Vendor Name : Gigaset
Device name : Gigaset 290
Device CodeName : GS290
Version of /e/OS or Stock which existed previously : 1.20-S (Stable)
Is the device Rooted / Not rooted: Not Rooted

It’s my daughter’s phone. Here also, all is good. No issue so far.

Thank you very much! :slight_smile:

  • Vendor: /e/
  • Device name Fairphone
  • Device CodeName Fairphone 3
  • Version of /e/OS or Stock which existed previously 1.20 (latest available)
  • device Not rooted

The update was smooth. The update was time wise as much as a non-version upgrade (about 30 min).

So far all seems to work as expected. Including fingerprint and authentication in banking apps (tested dkb and gls).

The screen resolution changed to smaller but I actually really like it.

Thank you for the great work!!


Thanks @piero, your solution worked for me, although with some detours I’d like to elaborate, because I’m not that familiar with Android debugging and spent quite some time learning all the steps and commands.


  • Updating from v1.20 to 1.21 crashed my wifi + bluetooth. After activating them, they were automatically deactivated a few seconds later. A simple “Factory reset” and restarting the smartphone did not fix the problem.
  • When I tried to flash back the v1.20 image the first time, I also got the “can’t load Android system. Your data may be corrupted…”. Then I fiddled around a bit and somehow it worked when I flashed it another time. Not sure what the fix was, but I tried to recall and summarize my steps below.

My Solution
On the Smartphone:

  • Open the “Recovery Menu” as described above. There was no “Install from internal storage” option in “Apply Update”, so I had to do it the “adb” way.
  • Factory Reset (not sure if this fixed anything, but since I did it this way and I somehow got it running, so I left it here)
    • Format data/factory reset
    • Format cache partition
  • Advanced > Enable ADB
  • Apply Update > Apply from ADB > Now “ADB Sideload” should be displayed

On PC:

  • Install the “adb” command line tool and download the murena installation image zip like pointed out by @piero.
  • Open a shell and run “adb devices” (you should see a “sideload” device).
  • Execute the command “adb sideload path/to/murena/” (strangely it only loaded to 47% and then printed an error, but it seems to have worked anyway)
    • As mentioned above, you may have to try the installation a second time to get it to work.

My device
Vendor Name: Murena
Device Name: MurenaOne
Previous Version of /e/OS: 1.20
Rooted: No

Hope this helps.

1 Like

even if you downloaded the file on the phone ?

this is expected displayed in the terminal followed by “adb: failed to read command: No error”
“No error” must be considered as a sucess

Same as @dfbrem : wifi won’t connect since the 1.21-r update (my G5 is rooted though).

I pushed the murena image via “adb” to the root folder of the internal storage, another time to the “Download” folder, but in both cases only the “adb” option appeared to “Apply Updates”. So, I did not download the image because my wifi was not working, but I think the way the image is obtained is not relevant.

1 Like