Feedback for v1.3

/e/OS Browser and WebView from March is still 5 major versions/20 stable versions behind with 186 known security issues, including 4 of which Google states are actively being exploited in the wild.

How is this not top priority for the team? Why are you leaving your users vulnerable @GaelDuval?


Thanks for keeping this browser issue up, it’s been noted at gitlab too…

And seems like 1.4 will finally come with update:

Just hope it will finally be long term solution, not just update now and forget again. But at least there seems to be some hope finally.


Thank you you two (@huuhaa and #SkewedZeppelin , I can only link two people :/) for relating the cause to my problem! I read most of the thread but just could not make a connection between internet only not working on 4G/3G/etc. and the WebView.

I am a developer myself but am not familiar with the Android stack. In the issues on gitlab they mention a work-around. That is probably to update WebView manually. Would it be possible for you to point me to directions?

If it is fixed in 1.4 with a long-term solution I would be happy. But since @Manoj states that 3 developers left the already small team, I consider switching back from e/os/ as I definitely need to reliable, secure phone. That’s basically why I chose e/os/, to have my data secure. I appreciate the project and acknowledge the work that has been done and last but not least the vision and its realization into an OS (!). That’s a lot of work!

Nevertheless I would be very curious if e/foundation has enough resources to onboard new developers. That would take time as everyone from IT understands. So I am asking myself is it a financial or a timely challenge that e/foundation and us users are facing? Maybe you could elaborate on that @Manoj .

You all have a good day! Good morning from Germany


@yiou your issue is likely something different and unrelated to what I was mentioning.

1 Like

We added 2 new developers to the team in the past week. Hiring is on for a number of additional posts. They should be starting work on a couple of pending issues ASAP. I have been sharing user concerns - not only the webview update, but some other open issues like the Oneplus 8 fingerprint issue. The team is also working on some interesting new applications. Hope to share some positive news soon :crossed_fingers:


If you wanted to get on before v1.4 you might try Bromite from which the /e/ Browser is forked, and as its companion consider Installing SystemWebView · bromite/bromite Wiki · GitHub, perhaps.

I have tried Bromite as it is more recently updated (it is reported by Advanced privacy to leak!) but I have not tried Webview.

Do note Bromite is also currently 5 stable versions behind with up to 36 known security issues.


After using 1.3 for two weeks on my FP3 I experienced issues as reported here: Fairphone 3 charges very slowly

1 Like

Down here, on /e/’ reconditioned S9 with 1.3 20220823, I still have to restart the system once every few days as Signal App stops retrieving messages & App Lounge fails to update apps.
Emptying Signal’s cache does not seem to have any effect.
Updating now to 20220905. Let’s see if that improves something…

1 Like

2 days after upgrade to 20220905 and emptying Signal App’s cache and no improvement: Signal App still shows notification “Vérification de la présence de messages - 2h”, ie 2 hours unable to retrieve messages.
Restarting phone: notification is gone and 1 message retrieved.

1 Like

Maybe that will help you:

But another thing very important is, if I want signal notification beside having microG and push notification ON, your phone must NOT be in safe power mode and/or data saver mode.
At least it’s work for me on S9 dev. v1.3

Hope that will solve your problem or help you find solution.

I also wonder at what point you did the Upgrade of an /e/shop Samsung from Oreo to Q … although under a different device, does this message apply to you, or did you already find you had to do that?

1 Like

I also get that when Advanced Privacy is on, especially the Hide my IP feature that still creates connection loss for the apps using it. Disabling Hide my IP for Signal does the trick.

Tks for suggesting this, but I do not use data connection, only Wifi and not in Save power mode.

I have no idea on this. My S9 comes from /e/ store end of last year and updated regularly since, once prompted by notifications. Not sure if that required a hidden upgrade from Oreo, Nougat, Q. I could not find /e/’s changelog. But, until recently, the problem was not only affecting Signal, but also FairEmail.

1 Like

This could be the reason as I also use Hidemyip which, sometimes, have difficulty finding a new IP. Problem started after upgrading to 1.0 (and using Hidemyip).
I will disable/enable it next time Signal gives me this notification.

The change from Oreo to Android 10, Q happened in the OTA Upgrade that took you from v0.23 to v1.0.

You can disable only Signal from Hide my IP if you want to use the feature for other apps.

Also what worked for me was to select a random country in Hide my IP and set the VPN for AP as always on. Still creates connection loss but a lot more rare.

1 Like

And this one is back since some days, after 18 days of expected behaviour of the GPS on all aps :frowning:

1 Like

@Manoj My issue with the broken 4G/data connection was indeed something else. My 1-year old SIM card died… I didn’t think of it because I never had one breaking even with an 8-year old one in the same phone (FP3 has dual-sim).

@Manoj you can tick that off the list and also thank you very much for your detailed information about the new dev team! As always with onboarding in tech it’ll probably take a month or so before the new developers are really productive :slight_smile: