Feedback for v2.0

https://gitlab.e.foundation/e/backlog/-/issues/7943

2 Likes
  • Fairphone
  • FP4
  • FP4
  • 1.21-s-20240325389527-stable-FP4
  • NOT rooted

V2.0 is very nice! But still no possibility to change widget position :disappointed_relieved:

EDIT:
Shortcuts from Browser have a worse color than before (here totally black, or yellow where it was white before).

Screenshot_20240516-115007_BlissLauncher_1

1 Like

Camera as QR code scanner?

In the release notes and during the live event, it is shown that the default camera app can now be used as the default QR code scanner.

I have e.os V2.0 installed and updated everything in App lounge. I now run foundation.e.camera Version 1.52, but I nowhere have the option to select a QR code icon.

Am I missing something?

1 Like

You need to tap on the video button on the bottom left. The qr code scanner icon appears.

5 Likes

I was indeed missing something… :sweat_smile:

I hope I will remember this. Thanks!

1 Like

I’m confused. The event showcased two features from version 1.x as though they were new features for 2.0. – The app tracker and the App Lounge. I heard only two new features, The camera app has QR abilities and Android Auto works now, maybe. Did I miss something?

Photos sync is still broken.

Vendor Name : Samsung
Device name : S9+
Device CodeName : SM-G965F
Version of /e/OS or Stock which existed previously : 1.21
Not rooted

After the upgrade, the location sometimes cannot be found and MicroG keeps crashing.

1 Like

Vendor Name : Fairphone
Device name : 4
Device CodeName : FP4
Version of /e/OS or Stock which existed previously : 1.21
Not rooted

All went well, but I have odd cut in bottom panel.

1 Like

Everything ran smooth! My impression is that the performance improved.
The icons now have the shape I selected. Probably due to Bliss launcher 3.0.

Thanks for your work!

Fairphone
FP3
FP3
e-1.21-t-20240323388918-stable-FP3
Not rooted

Update without problems. No issues so far.
Dear Team, thank you very much for your efforts!

1 Like
Vendor Name: Fairphone
Device name: FP3
Device CodeName: FP3
Version of /e/OS previously: 1.21 t stable
The device is: Not rooted

Update went through without problems. Runs smoothly. :slight_smile:

Some minor problems I noticed with the new QR code feature:

  • won’t register for QR scanner quick setting (says it’s “being updated”)
  • the button in the camera app is not there, it only appears when I tap the video mode button
  • when the device is held in landscape orientation, the placement field for the code to read is in the lower left corner, partially out of screen
2 Likes
  • Vendor Name: Google
  • Device name: Pixel 6a
  • Device CodeName: bluejay
  • Version of /e/OS or Stock which existed previously: eOS 1.21-t-dev
  • Not Rooted

Update was smooth. Seems no battery drain with this update.
Only little hickup: the weather widget had disappeared with the update, but could be reinstalled as usual.

Great work. Thanks a lot, dear team.

Update on a fairphone 3 worked fine.

However my Nextcloud APP says that it can’t connect to the server(Server isn’t avilable)
How can I fix it?

Pixel 4a 5g
e/os/ 1.21

Hello
I’ve tried 3 times but nothing changes

For me, I used the OTA updater in the System Settings GUI.

@Zac You can probably fix your phone by following what I mentioned in my post. If you managed to follow the install procedure for /e/, you can probably manage this. It’s all from memory, so some details might differ, and I should preface this by saying that I probably don’t know what I am doing:

  • Connect to a computer and let the phone boot into Fastboot mode
  • Download the recovery and main image for version 1.21 from the normal /e/ download page (thankfully, it will offer you old versions)
  • Flash the recovery for 1.21 by using fastboot flash recovery <name of 1.21 recovery image on your PC> in your PC’s Terminal
  • Once this is done, reboot your phone into the /e/ recovery, which should now start (I think the command is fastboot reboot recovery)
  • At this point, I may have extracted and flashed boot.img from the /e/ 1.21 image, but maybe that’s not necessary
  • In my case, it complained about not being able to mount /cache, so in Fastboot mode, I wiped that and formatted it and rebooted into /e/ recovery
  • Then I selected the option to flash a system image in the /e/ recovery and used adb sideload to upload and install the image to the phone
  • I rebooted the phone and it booted into the GUI
  • I had to reset network settings from the Settings app to be able to enable WiFi again

If you don’t want to lose user data that’s on your phone, make sure if you follow any guides online that you don’t wipe /data (called a dirty flash). And of course, once get into the system, immediately make a backup if you don’t have one already – the built-in Seedvault backup, which you can find in Settings, can do this for you.

Fairphone | FP3+ | 2.0-t-20240506399547-stable-FP3

After downloading, I tried updating but the window disappeared instantly. I tried a second time, same thing. I thought nothing happened, so I rebooted my phone, and it this seems it’s now in fact updated… But I’m not sure it’s completly finished (and I had a few apps crash).

Can I force the re-install ?

Is there an install log I can consult ?

Check out the release notes.

I saw the quick settings issue already with 1.21 but wasn’t sure which app it uses.

The button is only there when taping(switching) modes, works as intended.

Vendor Name : Murena
Device name : FP4
Device CodeName : FP4
Version of /e/OS or Stock which existed previously : 1.21-s
Not rooted

Update to V2.0 took 1 hour. Reboot - uncomplicate :upside_down_face:
So far :+1::ok_hand:. Thank you for your excellent work!

3 Likes
  • Vendor Name -Murena
  • Device name -Murena 2
  • Device CodeName - Murena 2
  • Version of /e/OS or Stock which existed previously - v1.20?
  • Is the device Rooted / Not rooted - do not know

Update took about 30 minutes, with no problems.

My only comment is that I could not find an explanation of the “Wall of shame” in Advanced Privacy. Also the heading was in English, even though my system language is French, as I live in France. Should that not be “Le mur de la honte”?

With thanks

1 Like