File access issues with multiple apps


File access seems broken somehow with /e/OS 1 on Fairphone 4. I don’t know the problem was the same before I upgraded, but I think so. I’m pretty new to the phone/system but now I have two clear cases where I can describe my issue.

1: Importing a settings backup to AnySoftKeyboard

I can import and export settings to/from the storage for the specific app “Android/data/com.menny.anysoftkeyboard/files”, but if I try to export to any other folder it fails. The really strange thing is when I go to import, I can browse to the file I want, but when AnySoftKeyboard tries to import it says “file not found”. This app has access to media files, so I’ve tried putting the backup file under “Android/media” but with no luck.

  1. Photo upload from OwnCloud

I have activated sync, and when selecting the DCIM folder I granted permission. It says it’s synced, but nothing has been uploaded. I suspect it’s the same issue: OwnCloud simply has no access to see the files!

For further debugging I might try to open files from other apps. But is the permission system specific to /e or would this be the same for AOSP/LineageOS?

Actually, what does access to media files mean? I’ve just tried to save that backup to every location I can think of, but nothing works. I even connected a microSD card hoping that it could count as a “media files” directory, but no.

OK, one more piece of the puzzle: ProtonMail, which also has access to media files, can attach the backup file located in / to an email. So maybe AnySoftKeyboard is doing something wrong when writing/reading? Still doesn’t answer anything about OwnCsoud though.