Fingerprint reader on Mi Mix2s is not there/working

Hello everybody.

I installed the unofficial polaris builld 20200511 on my Mi Mix2s.

When done it booted smoothly into “e” and went through all the configs including the fingerprint.
However, after reboot the fingerprint hardware/setting is not there.
Also I am missig the “Face Unlock” feature. Is that usually implemented?

Thank you very much.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @16locke !

I think you can forget Face Unlock, usually this is an online-only feature with lots of trackers (like speech recognition).

As for your fingerprint reader this is surprising if it worked at setup !
Was your phone at latest Pie Miui level before installing /e/ ?
It’s V10.3.6.0.PDGMIXM (

As far as I know, fingerprint software / driver is not from xiaomi and that’s why CDMA has closed the xiaomi sources.

All my Xiaomi devices, Mi5s, Mi5sPlus, MiMax2 and MiMax3 don’t have fingerprint available on eOS (and LOS)

I’m surprised, my 2 Xiaomi devices (MiMix2 and Redmi4X) have full functional fingerprint reader !
16locke reports a functional fingerprint setup … Is the driver/software used during setup different ?
I’ll try a new build ASAP and carefully check logs about missing driver/software …

1 Like

Good morning and thank you for your replies.
@smu44: Yes I had tha latest version of MIUI installed.
Which version do you use? Finger unlock is a need thing and I do miss it.
On the other side … I can also live without it.
@hervey186: Makes sense to not have face unlock under these circimstances.

Thank you guys.

Both my devices are running a build produced the same manner as yours, just a few days before or after.
And I don’t think it’s SoC related.
Very strange … As promised I’ll rebuild and check logs, probably next week-end.

I flashed the image again yesterday.
No more Fingerprint set-up … strange.

But no sound from Media like NewTube or videos in Telegram plus the videos run very slow … any suggestions?

Thank you

Fingerprint problem solved by reverting back a LOS “patch” (tested), see here : [UNOFFICIAL BUILD] Pi/e/ test ROM for Xiaomi Mi MIX 2S - "polaris"
Media playing problems solved by flashing back Pie official ROM, then /e/.

Thanks @16locke for your feedback and for your time with testing :blush:

you can also try this Unofficial Build for mido fingerprint zip from @Chimpthepimp

Hi @smu44, thank you :slight_smile:

Is it possible to have more details about what modifications you made (and how) please ? (I have no skill in debugging). In case somebody else wants to make an update for instance.
This device is officially supported by LineageOS on Pie so normally everything should work out of the box, no ?

LineageOS support requirements :

All devices with a Fingerprint Sensor MUST support the Fingerprint Sensor if the stock OS supports it with Marshmallow or higher Android versions.

I m not sure how device specific the zip file is didn’t look into it, just got it from a mido telegram group :slight_smile:

Hi @Anonyme !

Sure :slight_smile:

Searching about PF support in LOS16 sources, I’ve found that LOS devs encountered a problem with Pie FP software on this device, as stated here :
Comment :

palaych polaris: Return oreo fingerprint
Tnx Google, now pie fingerprint failed cts, now it check yet date security patch. But old oreo prop pass normal without change security patch date. This reverts commit dca6244.

So they decided to use the Oreo FP software in Pie builds.

I tried to have it working by reverting this change, diff here :

I just forked the LOS repo to my account, then added a commit for with LOS’s #dca6244 content.
Then used my account repo (android_device_xiaomi_polaris) for building.

@16locke reported to have FP reader working well with LOS16 and LOS17 but not /e/ Pie, even after reverting firmware with Pie MiUi.
I agree that, as it was working with LOS16, it should have worked also with /e/ Pie.
But the use of Oreo FP software in LOS16 was surprising to me, I thought it might be a possible cause of our problem.

If other users are willing to test and post back, they are very welcome :slight_smile:

1 Like

Okay thank you !

After 15 minutes of thinking, it’s a quite simple fix. You just used LineageOS sources available before the October, 2019 commit.

Nice that it worked, but weird that there is a difference between /e/ and LineageOS…

Is your github repo where you forked accessible to everyone ?

Yes, it was very simple … after hours digging into LOS repos :wink:

And you’re right, there’s no reason to hide my repo. I just forgot to mention it, my bad.

To keep things sorted, I updated [UNOFFICIAL BUILD] Pi/e/ test ROM for Xiaomi Mi MIX 2S - "polaris" with all necessary info

I was too lazy to publish such info for my builds, I’ll add it from now. :slight_smile:

1 Like

Is someone already checking out the official build for Pie testing on Polaris?