Fingerprint scanner not working on Galaxy S9+

Hello all,

I have installed /e/ on a S9+ ( SM-G965F) to test the feasability of fully transitionning to this OS. I am quite satisfied so far!

However, the fingerprint scanner does not seem to work at all. During the setup stage, nothing happens when I put my finger on the scanner.

Any lead or fix?

FWIW, I had installed lineageos as an intermediate step before /e/ (the installation process has been quite difficult for me…), and it did not seem to work either.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello, welcome in the forum :slight_smile:

Was it working on the stock ROM ? On which Android version were you ?

PS : don’t install a version of the stock rom from this year, you wouldn’t be able to come back to Pie.

Hello! Thanks for your reply.

I can’t say with 100% certainty that it was working before, as this is a used phone I have bought (specifically for the purpose of installing /e/ :smiley:). However, everything else is working perfectly, and the phone is supposed to have been tested as it is sold with a warantee. I have not verified it myself. Maybe is there a software way to check that?

The phone came with Android 10. I imagine that the seller flashed one of the latest stock ROM.

The installation of /e/ was pretty difficult, and I have tried flashing it a first time, had then to update the vendor (27_ARI9), could not flash it anymore… instead tried LineageOS, then tried to reflash a stock ROM which failed… then back to TWRP, and finally /e/ installation worked.

This was pretty much all my fault as I had to learn basically from scratch the android world, what the download and recovery modes were, how to use Odin and TWRP…

Anyway, /e/ is working fine now, with the exception of the fingerprint scanner. I don’t know if it could be related to a wrong step I took somewhere.

If it helps I now have Android 8.1.0, baseband G965FXXSBETH2, kernel 4.9.133+.