Firefox autostart

Hi, yesterday I installed Firefox 91.4.0 and all was ok.
But each time I want to use my phone (not specially for firefox), firefox always start. I wake my phone with the power button and firefox start.
How can I remove this autostart.

I have an S9+ with /e/ buyed online.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

That is a first for me. Never heard of that issue before.
Hmm, maybe try this. My /e/ only goes up to Pie so not sure if the info will apply.

Go to Settings → Trust → Privacy Guard.
Find Firefox and long-press on it. You’ll see a list of permissions(?) or appops. See if there’s anything there that may relate. Is there a “Start at power up” entry. If so it probably doesn’t have a toggle. Long-press on it and you may see options similar to…

Always Ask

Select “Ignored” and see what happens.

Otherwise, have no clue about this one.

1 Like

Never seen that, either …

Where did you get it from ?
As this is a new Firefox install, I assume you don’t have much data.
So, what gives a un/re-install using official source ?

I got it from apps hub, it was a new install, nothing before.
I tried to unsinstall/reinstall and till now, no effect.
I remembered that all began after I used it to read a QR code. Perhaps it is a side effect.


You can try to enable Developer Mode, then “Kill app back button”.
Then use is against Firefox (long-press on back virtual button).

What Android and /e/ version are you running ?

1 Like

it is the 0.18 version stable for S9+.

Unfortunately, Oreo is quite old and I don’t have such device :frowning:

I installed Firefox on a 0.18.2 Q device, couldn’t reproduce your problem …

BTW, how do you usually exit Firefox ?

sometimes with the square button and the cross (up and right of Firefox when it’s reduced) but more often with the square button and swiping the app onto the left (or right).

That’s the right way :slight_smile:
Please also check that there isn’t any Firefox notification awaiting.

Searching the web didn’t return anything of interest :frowning:

Does it open the standard home page, or any web site ?
Did you set it as default browser ?

I have no home site : I have to let the last web page otherwise it try to open google search
and it’s not my default browser.

This morning I had a notification classified as marketing (??) by the notification board (long press on the notification) and I removed it. It was the only “pbm” since I reinstalled Firefox.

There is a setting in Firefox about:config for ‘application restart’, recommended is false. I wonder if true would cause this behaviour?

nothing such as about:config in the android version
or I did not found it !

You’ll have to install a Beta or Nightly release : about:config | Firefox for Android Support Forum | Mozilla Support

I do not like unstable versions. I prefer to uninstall it.
thanks for answers.