First experience and beginner-trouble with installing /e/ on S7 and Upgrading to (unofficial) Pie

Hi /e/ Community,

I’m new here and these are my first experiences the last few days with /e/, which I like very much now:

4 Days ago I read about /e/ the first time. It was because since more than 4 years I am very happy with my Samsung Galaxy S7 that is no longer supported by Samsung.
I was thinking about some new Phone, but they are too big. I want it to fit in my Jacket, Bike-Bag etc…

So I was searching for options, and though I never installed a custom ROM and never rooted a phone I wanted to try /e/. I read about /e/ here:

Worst thing that could happen was, to have to buy a new phone :-((
(I still have a tablet as Emergency-Backup.)

I’m not an IT-professional but have spent more than 30 years with computers (some of them as developer, but long ago). And when I started, there was no Internet, so I’m used to the feeling, that I have the power to decide what the machines do. Well, meanwhile I gave up a little bit…

The Idea to get rid of Google and so on is of course also attractive, but not so easy for everybody, I will see…

I tried to install the official nougat via this howto:

After that my phone was heating up, loosing power and stuck in a boot-circle… I thought it was broken.
Through some websearch I managed to get into TWRP again and installed the original ROM using SamFirm and even could install a backup of my data. I was relieved and had to go to work.

Meanwhile I thought, I should try again and root my device prior installing a custom rom (advise somehere on YouTube hm…).

That worked!!!

I tested some features, was glad, that bluetooth worked, even in my car and with my Polar-Watch (I only use it for sports) and managed to install the dirty things I still need (Whatsapp, Google Calender etc).
But I try to search for alternatives or at least to not get more dependent from the Monopolists.

The only thing I then noticed, was that the Camera-App crashed somtetimes (e.g. with hdr on) and found topics discussing this in this forum. And I was wondering, why I moved from Android 8 back to 7. But I was still exploring… and so far really surprised and excited.

Today I found the entry in the UnofficialBuild-Section with a link to a Android9-Version that seemed quite interesting.

I installed it and am really happy, hope that gets official soon. Camera is now satisfying and even hdr-images are ok (hard to compare to the original app now), but for me they are quite good now.

Still fiddling around (and because I am used to smaller Icons) I tried Nova-Launcher (I read about the privacy-Thing), I was just trying… And after some testing, I got stuck in the Lock-Screen.
Then got help by that Link:

After that I deinstalled Nova, too see if I get that problem again, Bliss Launcher is ok for me too.
Most important thing is, that everything works…
I should stop installing and start testing now.

I’m really curios, if I miss something, or if I get rid of some more Apps and how everything works in the next time.

Many Thanks to the Developers and the /e/-Foundation, we need more of this, especially in Europe.

Greetings from Germany,
Peace.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

4 Likes

Hi, welcome in the community :slight_smile:

Thank you for sharing your experience.

You probably made something else different this time because root is definitely not needed :yum:

But at least it worked :+1:

I suppose that you know that you can install those from-Google apps through Aurora Store, which works as a bridge to Google Play.

About Google Calendar, you do not need to install the app. You can just add the Google account into Calendar :slight_smile:

Thanks for writing about your experience!

I’m glad that the version sounds ok for you :slight_smile:
I will build newer version as soon as security patch will be available.
But keep in mind that it’s an unofficial build, devs are working hard to port pie on S7 in an official way :slight_smile:
And, also, I’m just a builder, I use scripts made by @harvey186 , I simply run those scripts (and automatize tasks :stuck_out_tongue: ), so, unfortunately I do not have abilities to modify files :frowning:

Thank you for welcoming,

the problems started as TRWP got problems with encryption, I tried the recommended “Change Filesystem”, and then got stuck.
But you are right, most important is, that it works :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.