Fix no sound in calls with LeEco S2

I changed from Lineage 17 to /e/ lastest version (1.5) and noticed the same problem that I faced long time ago with Lineage 15 or 16: There is no sound in calls. So I cannot hear the partners voice and the partner cannot hear my voice.

With Lineage 15 and 16, I fixed this issue by changing system/build.prop entry “” to “”
(see for more details:

With Lineage 17 there was no problem.

Now with /e/ the problem is back. But the old solution does not work: I cannot edit build.prop because I have no editing rights despite root. No Android root explorer app will work.

I heard this is an issue with Android 10 (Q) and newer (system is read only).

Here is what helped me and I hope it can help you too, if you are facing the same problem:

1 Like

good tips! let me add…

I cannot edit build.prop because I have no editing rights despite root

usually you just need to remount with rw (read/write) options if you have a root shell already

mount -o remount,rw /system

I see adb even has a dedicated command (adb remount) for it if you’ve go the adb root going -

Thanks for your kind reply. It works well. Also tried it within twrp and works also (although twrp file editor is much more comlicated to use).

I wonder why build.prop settings are resetted when doing system update? Is there a possibility to keep settings even after system update?

And why “” is not disabled for Leeco S2 by default? What is the advantage of “fluence.voicecall=true”?

Thanks and kind regards

because the system partition is overwritten on update

maybe there is something in this thread

wasn’t intimate with that buildprop setting, user ninjasinabag in xda thread says it is enabled…

… for the audio decoder relating to noise cancelation. Fluence and fluence pro are both noise cancelation technology relating to specific hardware. Fluence is preferred for low end devices to avoid battery drain.

how come you think this is the solution, because of ?

Thanks again.
I must admit that my Android knowledge is just basic. But my aim is to acquire new knowledge and also try to contribute to this great ROM that keeps my device running since many years. That is why I use much time for research when facing any problem with my device or also look for new features and settings.
The link according build.prop from an other forum is indeed the result of my research.
I just tried to apply the suggestion to edit fluence voice call and voilà, it worked for me :slight_smile: (despite not knowing what the setting was good for until you told me).
I even do not know if this problem concerns just a few Leeco s2 users or the most users. Which would be interesting when thinking about providing updates with this setting being already a preset.

1 Like

you can take it up with lineage or e/OS on why it is enabled - android_device_leeco_s2/system.prop at f54cd7f286290e235d43f1bf29f0ff5e3f4c30dd · LineageOS/android_device_leeco_s2 · GitHub and advocate for flipping the boolean

last change is going back to 2018 with a larger refactor. Could be anything - if fluence is proprietary and the library got removed or is not included in the flashed vendor but thought to be present or copied over from device local partition… many reasons, I don’t know the s2