Flashing script does not recognize FP5 in Ubuntu

Following the steps I was able to unlock OEM mode en USB debugging on the phone as well as performing the listed commands using the terminal of my Macbook (after installing adb) with expected results.

adb reboot bootloader
fastboot flashing unblock
fastboot flashing unlock_critical

When commencing with the flashing script on my mac a warning occurred that this script can only be run on linux or windows.

Connecting the phone to two different Ubuntu systems (Imac with budgie, old laptop with Mate) installing the android tools and running the script resulted in a failure to detect the device as an actual Fairphone on both systems.

Citing line 40 of the script: Access denied

WARNING: No Fairphone 5 found in fastboot mode.
WARNING: Make sure tha a Fairphone 5 is connected.

All systems were manually approved for USB debugging after booting up the (reset) stock system.

When in bootloader menu fastboot devices -l results in

serial device usb 2-2

Rerunning the fastboot flashing unlock command results in a failure stating that the device is already unlocked. As does the bootloader menu on the phone.

Any suggestions to get the flashing script working would be greatly appreciated.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

What version fastboot do you use?

$ fastboot --version

download new version here:

Does it make a difference when you use sudo?

With a recent release device well updated Linux may be necessary.

Thank you for your replies.

I was indeed working on outdated systems. However after a fresh 23.10 Ubuntu budgie install on the old laptop the problem persisted.

ADB/fastboot version from the deb repository = 33.0.3
Manual install of 34.0.5 at first didn’t work due to a fault in .bashrc. but afterwords resulted in the same error. The shell suggested an alternate source for installation from the google repositories running 34.0.3 with same results.

fastboot devices -l results in

“no permissions (missing udev rules? user is in the plugdev group)”

Made udev rules as shown on: Stack overflow

Removing cable restarting phone in bootloader and plugging in resulted in fastboot devices -l showing the serial and device again.

Script still same error.

lsusb showed the phone in fastboot mode as 18d1:d00d Google Inc Xiaomi/Redmi2 (fastboot)

While in stock rom with usb debugging as 18d1:4ee7 Google Inc. Nexus/Pixel device (charging + debug).

Adding sudo didn’t make a difference at any of the steps.

Thanks again for your suggestions.

As all systems are up to date and the device is detected with the proper serial in fastboot, I opened the flashing script to check what is required. It seems it checks ProductID in fastboot, which should be FP5 and the script stops if it is not.

In the meantime i checked the phone (an unlocked otherwise brand new FP5) properties when plugged into my Macbook. In fastboot/bootloader mode (after unlocking) the device presents itself as 18d1:d00d Google Inc. as well. (just as in ubuntu)

In summary fastboot is working on phone and laptop. Vendor ID/ProductID are not properly presented by the phone in fastboot/bootloader mode but this is a prerequisite for running the script. I was not able to solve this by switching ports, devices or cables nor by installing udev rules. I am not aware of drivers for linux as are suggested for this problem in windows.

I am considering altering the script removing the product ID question and manually inserting the phone serial as the variable sn. However I am not an experienced coder. Do you have any other suggestions as I see no options going forward or should I wait for the development team for changes in the script?

The problem ended up being much simpler.

I didn’t realize there was a separate fastboot instance in the bin-linux-x86 subdirectory. It turned out that it needed permission to be executed as well as read/write.
After granting executable permissons to the scripts in the bin-linux-x86 subdirectory the script worked.

1 Like