FM radio app not find after installing /e/OS on Teracube 2e 2021 emerald

Where can I found the icon to start listening FM radio with my Tercube 2e ?
With the stock rom it worked fine …

As I understand it the FM Radio can be added at the build stage as it appears here e / os / android_packages_apps_FMRadio · GitLab but it does not seem to be installed by default in Official builds.

There is the opportunity to sideload the Lineage OS FM Radio available for instance here. FM Radio 10 (Android 10+) APK Download by LineageOS - APKMirror

I wonder if you are able to find evidence that the Radio hardware is present in the device, then ask for it to be added to the build by means of a Improvement request issue.

However this very old issue is still open, Improvement- Add Radio FM Support Application (#387) · Issues · e / Backlog · GitLab

… and this one is closed GS290 missing the FM App in /e/ ROM (#2795) · Issues · e / Backlog · GitLab


I tried to see if that and FM Radio 11 could be installed normally but they failed.
Using a root-enabled file manager I put one in /system/app/ where it shows up in the launcher. After permissions are set it, like others I’ve tried in the past, fail to run. Just crashes.
Tried to put it in priv-app but that didn’t work. Read-only system and whatnot.
Remembered that I had the Magisk overlayfs module so made attempts there, too. Regardless, it was a no go. Not to mention some strange thing where my modules are all turned off on some reboots.

In the past I’ve tried various radio apk files, all failing to run in some way. Makes me wonder if there’s a certain blob/library/permission that’s in the stock ROM but not available in /e/OS.
Plus we’re talking MediaTek vs Qualcomm chipsets. Not sure if the apk files I’ve tried are chipset agnostic or expect one or the other.