FM radio works but no audio playing YouTube, Podcast or Scribd app

on my Sony Xperia XA2 I have no audio on speaker or headphones while playing YouTube, Podcast or Scribd apps.

If I play the same YouTube video while connected to a Bluetooth speaker it works just fine.

FM radio works, phone calls work and OS sounds work on headphones or phone speakers but no audio when playing any media from these apps.

I hear some clicks but it seems to have trouble playing the audio.

It was working well before on 0.19-q but then I ran into another problem, see here:

Now I got that working on 0.18-r but now I have this audio problem.
Should I revert to 0.19-q or from -r to -q?
Is a re-install the only option or can I try something else?

I went to e-0.21-r today and same problem.
I will flash the phone again to see if it solves this problem.

Hi e.ov5w9

I once had this Problem with XA2 with Sailfish OS on it (no Problems with audio here), and then flashed to /e/ 0.19 Q.
Android App-Support for SFOS (Sailfish OS) relies on Android 8.
After flashing with /e/ 0.19 Q all worked, but no audio when playing media, as you described.

My solution was:
Flash your XA2 with EMMA-Tool from Sony (Stock ROM, which is Android 9)
Restart your Phone, don´t do any Updates!
Enable developer mode, enable USB-debugging.
Now flash /e/ on your XA2, in my case i flashed to 0.20 Q, from there to 0.20R.
It works like a charm.
Hope this helps.

Regards, Maschinengeist

PS: Stock ROM should be 50.2.A…

My problem clearly isn’t related to /e/ OS but to the stock ROM provided with Sony.

I installed 50.2.A stock rom with Emma and used /e/OS for a while just using WIFI. When I placed a SIM Card it had no cellphone network service posted about below:

When I re-flashed stock rom all seemed to be working fine till I discovered I had no audio on headphones and phone speaker while playing streaming services. Bluetooth it worked fine.

I re-flashed the phone again with 50.2.A where after WIFI did not work. The camera did not work either.

I re-flashed again using another Windows PC to be sure it wasn’t the USB port or Windows machine with the same issues.

I re-flashed now to 50.1.A and cellphone network, calls, camera, video streaming, wifi all seems to work fine on stock Android. Now going ahead and install latest /e/ OS.

Then I installed 0.21-r and the issue with the audio on videos occurred again. So the problem is the same with the 50.1.A. Could it be just related to my phone? I wonder what could cause such an issue with the ROM and drivers to malfunction in this way.

When I flash I always get Android 8 on my stock ROM.

Goodness, i answered with a whole step by step list to work through, but it crashed just now, all gone.
Please be patient, answer follows, stay tunded…

Hi e.ov5w9

Here is how i got the solution, step by step:
Know your hardware code, XA2 single sim is “H3113”, dual sim is “H4113” if i remeber right.
Start EMMA, in menu “help” search for “show product info”, click it, type in your hardware code, single sim is “H3113”. There is no autodetect for this.
Now push an hold volume DOWN, plug in USB cable, wait until LED turns green, now release volume knob.
In the right side of EMMA windows should appear 4 versions of stock roms.
Read these carefully, there are versions with erase of userdata and some without it.
I chose “50.2.A.xxxwith erase. LED still green? Good, now in EMMA click “apply service”, XA2 gets flashed now, takes about 10 min. or so.
When finished, unplug USB cable, wait approx 30s, then turn on.
Your XA2 should now run Android 9. Now you can proceed as above mentioned.

I hope this helps, please try.
In the meantime im looking for a screenshot for the exact version i flashed in EMMA, so stay tuned…

Regards, Maschinengeist

have a look here

this is the version i flashed also
( versions seem to be gone…)

Hi e.ov5w9

Any news on this?


My phone is the H3123 and EMMA does not offer the 50.2.A but I can select the 50.1.A.4.102 and the 50.1.A.5.59 I have tried it again but the audio issue remains. Is there a log file I can look into? I am pretty sure it has to do something with a driver.

I installed Lineage OS and the issue is the same. The problem seems to be the driver but Emma does not show me 50.2.A and Sony does not allow me to upgrade to Android 9 now because the device is OEM unlocked.

Sony Emma shows me I flashed the device 17 times so I think it is time for me to give up.

What I believe I need to do is to bring back the device to a factory Relock like described here:

Then update to Android 9 obtaining the current drivers. Then try again.

Or try flashing the device not using Emma. I tried it on Linux but could not get it to work.

Hi e.ov5w9

This is strange, why doesn’t it show…? Maybe geolocation issue…?
Well, i never relocked my XA2, i have no experience here.
I can’t help any further i’m afraid, sorry. :pensive:

Please let me know if the relocking worked.
Good luck :+1:


Yes I got the phone from the US and before I could see but then after I placed the foreign sim-card I could no longer access it.

What is the best alternative besides Sony EMMA to flash a Sony Xperia XA2 device?

I donwloaded another app but it did not recognize the Xperia XA2.

Hi e.ov5w9

As last measure try this:
Try with “Xperifirm” (Windows or Linux, to download stock ROM) and “newflasher” (Windows or Linux, to flash Stock ROM onto phone), both Linux. Download worked, but flashing did not work (was my fault, have not unpacked it before flashing).

When successful please try:

  • flash twrp-3.6.0_9-0-pioneer.img on your XA2
  • reboot in TWRP, and from there
  • flash /e/ OS, from SD-card or as adb sideload