FP 3 won't boot after Magisk uninstall

Hello Everyone,

I’ve got into trouble with my FP3 after install/ uninstall of Magisk.
Now the phone cannot even boot into the system, just into recovery (TWRP) or the Fairphone logo.

Here is a summary of the steps that led to here.

  1. Booted into and subsequently installed TWRP (not by flashing, but with the installer). All was fine. Made a back up.

  2. Installed Magisk and tried to flash the patched boot image. Worked on slot A, but not on B where I’ve got repeatedly an error.

  3. After installing Magisk TWRP suddenly vanished and the e-Recovery took over.

  4. Uninstalled Magisk successfully, but after I couldn’t boot into system-slot A.

  5. Did factory reset - nothing.

  6. Via ADB managed to boot into the B s!ot.

  7. Tried restoring boot/system/vendor from the backup via TWRP and then ended nowhere - boot neither in A nor in B, just TWRP or the Fairphone logo (bizarrely the /e/ Recovery has vanished and TWRP reappeared).

Any ideas if, and how, I could get out of here?

Do I have to revert in install the FP OS? If yes, any suggestion of a recent and non buggy download?

Or can I install afresh via ADB the /e/? Will that resolve whatever mess is now in the boot partition?

Thank you in advance for any help.

P.S. Turned out TWRP is only in slot B, on slot A is still the /e/ Recovery

Just reinstall the OS instead of restoring it with TWRP.

I never successfully restored either Fairphone OS or /e/OS with TWRP when I tried initially, always got a bootloop. Only restoring the data partition with TWRP worked, which is good enough for me.


1 Like

Hi and thanks for reply.

Well well… In the end I simply got locked out of the stupid phone and could neither install the FP OS nor e/ since both require ADB sideload in fastboot. But as soon as you do a factory reset the USB debugging gets revoked and you can’t use it…

We must thank to all technocrats who rule our lives down even to the smallest gadgets and make our lives hell - we are spending countless hours on forums trying to fix stuff designed to be deliberately user unfriendly.

In the end, in desperation with the useless piece of plastic for 400 peanuts, I found an unexpected solution.

Since on slot B TWRP was still working - in fact the ONLY thing that was still functioning! - I remembered that Lineage, in contrast to /e/, was installed from Recovery and not from fastboot.
So I downloaded Lineage and much to my disbelief it installed via TWRP+sideload to slot B; after I was prompted to switch slots and the Lineage Recovery installed on A. And a miracle, the phone came back from the dead!

1 Like

Glad you could make it work somehow :+1: .

I’m not sure what you mean.
ADB doesn’t work in fastboot mode, only the fastboot command does.

To install FP or /e/ OS one needs fastboot on the phone and adb/command from the PC.
But after performing a factory reset USB debug get revoked from the Dev. settings and the phone is no longer recognised from the command line.
If booting into the system to enable again USB debug is not available anymore one has no more chance to install any of the above OS.

Awful indeed!

If you mean the adb reboot bootloader command given in some guides at a point when an OS is running, this is not needed, you can instead just keep Vol - pressed while starting or rebooting the phone to get into fastboot mode (aka bootloader) without ADB.

No no, whatever command you want to execute via PC while in fastboot has a prerequisite the phone to be recognised after you check with adb devices.
With USB debugging off the phone is not and when you get down to the nitty gritty - i.g. fastboot flash … blah blah.img - you get in return boot partition does not exist or something of that sort.

Are you sure you are not talking about unlocking the bootloader? This would be needed for certain fastboot operations.

I don’t see how ADB would affect fastboot operations. It’s the Android Debug Bridge, it can do things once Android is running (or at least an ADB-capable recovery). It can’t do anything with the phone in fastboot mode, and I fail to find a source confirming the connection between fastboot mode and the USB debugging/Android debugging setting you assume. Can you give one?

Sorry, cleaned the browser history and cannot recall where in my frantical searches with the brick in my hands I saw it Black On White why the phone could not be recognised in fastboot.

But you don’t need any links - just read elsewhere online what USB debugging is. If it is a fact that enabling it is one of the preconditions for communication between the PC and Android for executing commands from the command line then it logically follows that disabling USB debugging, as it always happens during Factory Reset, will cut off the said communication, i.e. say Goodbye to using fastboot.

Bwt, I came across a terrific app I have never read about on the e/ or the FP forums.

It it called Migrate and do terrific job in backing up and transferring apps, APKs and data between devices (assuming the apps work on the resp. Android versions).
I can attest it personally as yesterday I literally re-enacted all my apps and settings from a Lenovo tab with /e/ to FP 3 with Lineage, both Android 11. From 55 apps only (!)2 banking lost their settings. Not bad I would say… Kudos to the developer!

It needs, however, root, preferably with Magisk; and preferably TWRP installed.

ADB and fastboot operate seperately from each other, that’s my point, it’s this you can find everywhere. Fastboot mode is not dependent on Android and thus not on ADB either.
(Only allowing OEM unlock is mostly done in Android due to smartphone vendor policy, it could be done with fastboot alone, too, if the smartphone vendor wanted. Might even be down to Google requirements.)

That the adb executable as well as the fastboot executable are command line commands is just the way they are being built. It doesn’t mean one needs to do something to make the other work.

You can operate fastboot just fine with USB debugging (= ADB access to the phone) in Android off.
I would have been interested in a source saying otherwise.

Well, whatever works.