FP3 auto-update 0.15 "Cant load Android system..."


I tried to update my FP3 from /e/OS 0.13-2020121490323 to 0.14-2021012999010 last month, however, on reboot got the “Can’t load Android system …” message. I can boot back into the old version 0.13 which I think is in slot B, so it wasn’t too much of an issue. I tried to repeat the install but the same thing happened, so I stuck with 0.13 for the mean time.

However, when trying to update to 0.15-20210317106351, I get the same “Can’t load Android system…” message. (I can still boot back into the 0.13 in slot B for now)

As far as I can tell both 0.14 and 0.15 is installing for other people ok, so I’m not sure if I’ve done something wrong somewhere? If anyone has any advice on how to fix/debug this, that would be great. (Ideally without having to wipe and start again)

This also happened for me with the 0.12 update last year, although I think this happened to some others at the time as well. At that point I did a reset and used the easy-installer for Q 0.12.

Thanks in advance.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I have exactly the same issue with my Fairphone 3, not managed to find a solution yet, thinking of just doing a fresh install but really dont want to lose all my apps and settings etc…

I’ve also had exactly the same issue. I would like to get the 0.15 update working without doing a factory reset.

Same issue here. No pissibility to install the OTA on the Fairphone 3.


Everything is working great, but I’m still having this problem with the OTA updates, is there anyone who has found a solution?

I wiped the device and reinstalled 0.15-20210317106351 using the easy-installer a few weeks ago.

When installing the OTA update for 0.16-20210422111920 I get the same error.

“Cant load android system …” with the choice to try again or factory reset.

I can just try again until it boots from slot b into 0.15 and everything is fine. Is this something wrong with my device or could I be doing something wrong in the install process?


Evening, I had same behaviour with FP3. @Manoj something wrong with OTA?

Got the same problem with my FP3 & the V16 update, I was hoping this would be solved by now but this is now the third update to fail. Anyone got any advice on how to update without wiping my app & user data?

At least not in general.
OTA updates work fine for me …

… but I’m on the dev channel. Easy Installer installations (and preinstalled phones bought from the e foundation) are on the stable channel … which should mostly get the same updates, though, only later.

Else … 0.15 or 0.16 doesn’t say anything about the Android version. Currently Android 9 and Android 10 are both supported with updates and could be 0.15 or 0.16.

So, for troubleshooting it would be helpful to know what you all have in Settings - About phone - Android version (tap on it) - /e/ version, as this contains all the important info about an /e/ version. (Yeah, it would be nice to have this consistently displayed everywhere, which is not the case right now, there’s always room for improvement.)

Example: I’m currently on 0.16-q-20210415110657-dev-FP3.

I got 0.15-q-20210317106531-stable-FP3. From 0.14 to 0.15 it worked smoothly.

1 Like

My OTA update worked coming from 0.15-q-20210316105636-dev-FP3, your stable build supposedly is from a day later, could be the same build then relabelled as stable.

At the moment I have 0.15-q-20210317106351-stable-FP3 which I got via the easy-installer.

And the update I’m trying links to: https://ota.ecloud.global//builds/full/stable/FP3/e-0.16-q-20210422111920-stable-FP3.zip

Which fails at reboot.

Same here :slight_smile:


This has never been updated, it was the version that was installed via the installer and stuck ever since.

Ok, so far all failing OTAs on the stable channel, all Android 10 (q).
It doesn’t seem to be a difference resulting from Android 9/10 then.

Would be concerning to have dev working and stable failing, in case of failure it is planned the other way around :slight_smile: .
It might be good to raise an issue at /e/'s GitLab to make /e/ developers aware …

I’ve created an issue here: https://gitlab.e.foundation/e/backlog/-/issues/3062


@jeos I don’t expect it started working for you? Looks like not many have this issue.

@mihi No luck as of yet unfortunately.

I have tried installing both with and without using the easy-installer as well, following these instructions (https://doc.e.foundation/devices/FP3/install) for both the stable and the dev build and the same problem persists.
It seems to install ok every time, and starts with slot a active. When I then use the system updater it updates fine and boots into slot b which also seems ok.

However if I repeat the process with the next version (i.e. with slot b is active) then the same “cant load android system” screen appears when it boots back to slot a.
If I hit “Factory reset” it seems to successfully install the update (just without any of my data).

I’m not sure what else I can try.

So you get 0.15-q with the Easy Installer?

The issue is marked with Easy Installer but I uesd it with 0.13-q since then OTA’s worked flawless.

Once you reach the working state before the failing update, perhaps it would be worth a shot to copy that state of the partitions over to the other slot before attempting the update.
LineageOS has a script that does this at https://wiki.lineageos.org/devices/FP3/install under “Pre-install instructions”.

1 Like

@mihi I initially tried with the easy-installer, but now I’ve been getting it from the stable builds linked on this page: https://doc.e.foundation/devices/FP3/install

Yeah that’s a good point, I think I’ll update the gitlab issue as the problem seems to be more linked to my device (or how I’m installing it) rather than the easy installer.

@AnotherElk Thanks for the advice, I really appreciate it.
I tried using that script to copy from one slot b to slot a, it run ok, but unfortunately it got stuck at the fairphone load screen when booting from slot a. (still booted ok from slot b)

Since then, I have just tried wiping and flashing again and it seems to be working ok this time. I flashed 0.13-q stable build following the usual instructions (as I did before) and updated to 0.14 then 0.15, 0.16 from the system updater and it switched slots each time as expected.

The only difference I can think that I made was running the command:
fastboot -w
when both slots were active, i.e.
fastboot --set-active=a
fastboot -w
fastboot --set-active=b
fastboot -w
before flashing system etc.
As far as I understand fastboot -w wipes userdata and cache so I’m not really sure how this affects the A/B slots as I thought they are separate partitions. (but bear in mind I don’t really know what I’m talking about :smiley:)

So I’m not 100% if this is what fixed the issue or if something else changed in the process. Whilst that’s not a particularly satisfying conclusion, the OTA updates appear to be working ok for now and will hopefully stay working, so thanks all for your help.

1 Like