FP3: Camera may be in use by another application? ID:0

Hi! My Fairphone 3+ running latest e/os had some moderate water exposure.
Around the same time, the cameras stopped working across all apps.
The built-in camera app provides the following error:

Failed to open camera. Camera may be in use by another application? ID:0

Both front and rear camera are unavailable across all apps.

I have tried, to no avail:

  • thoroughly dried the phone; everything else works fine
  • reboot
  • clear Camera app cache and data
  • reboot into safe mode
  • replace the back camera module with a known good copy
  • access the front camera only (selfie app)

How can I establish whether this is a software or hardware issue? Initially I thought it’s likely hardware, but replacing the camera didn’t help and both cameras (front and back module) are affected.

Thanks in advance!

Witch OS version is this?

Have another app open? A messenger like Signal or an app like PeakLens or a QR-code scanner?

It’s eOS 1.14, 15th August 2023.

The issue persists straight after reboot and in safe mode, so I doubt it is caused by another app. How else can I check that?

There was an issue with apps reporting another app uses the camera again and again. But this was a year ago. Never had this since then.

You could try to clear the cache of all apps for the case that any other app or OS component kept using the camera in mind. You can use the Cache Cleaner app from F-Droid for doing this automated for all apps. I think if you dismounted already a camera and both are still affected it’s rather a software problem, the device still “thinks” the cameras are in use. (OK, you could still try to dismount also the other camera for the case that the reason is there.)

You could also try another camera app like a GCam port or FreeDCam just to see if the camera app you normally use has a damage in it’s settings. If another camera app is working you should clear the entire memory of your camera app. This means that you lose all your settings but it could work again after that.

Thanks irrlicht!

I’ve installed Cache Cleaner and removed cache for all system and user apps. The problem persists.

I have previously physically detached the rear camera module, replaced with a new copy of the module and then swapped back. I’ve checked at each step and the camera never worked.

I’ve tried multiple other apps (Telegram, Whatsapp, NatWest) and none of them work; neither front or back camera.