FP3: manually upgrade from 1.5. q dev to 1.4. r

Hey fellows,

though I researched through the forum I still feel stuck so Im trying to get some answers by asking you.

First: is it possible or not to change the branch from dev to stable, maybe even without data loss? If so, what is exactly the criteria to change it?

Second: as I didnt find a clear answer to my first message I decided to manually upgrade via adb sideload with the e/ recovery. I get the message that signature verification failed, do I want to install anyways, I choose yes and then run into ‘error 21’ and ‘E:Failed to find update binary META-INF/com/google/android/update-binary’. I dont get what the problem is, I also tried the next higher version, same error.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Why from 1.5-q to 1.4-r?
Anyway …



You do a new install including a data wipe.

Most likely you are using an install file which is not for installing via ADB sideload.
The install files from the download pages currently match the instructions given here … https://doc.e.foundation/devices/FP3/install.

You can get download links for install files suitable for ADB sideload from https://ota.ecloud.global/api/v1/FP3/stable or https://ota.ecloud.global/api/v1/FP3/dev (see the “url:” lines respectively).

Note that both Q and R are no longer being further developed for FP3, only S.


1 Like

Through this guide I followed this, needed to set the active slots through the process like he did but when trying to start the system it goes into a short bootloop and then into recovery mode. I tried to set the active slot back to a (first I started with active b slot) but this wouldnt change the outcome. Do I need to set the slot to something different to get the OS started? Maybe Im missing a little command at the end? Through the installation process the only error occured when flashing the boot.img: I solved it by adapating the command from

fastboot flash boot boot.img


fastboot flash:raw boot boot.img

but only with this step I added the raw.

Can you help me, please?

Edit: FP3 installation : stuck in fastboot mode: this doesnt helped.
Edit2: also this, step 3, didnt helped. Getting lost, I dont understand what went wrong :cry:

… with the emphasis on current … I have noticed that the /e/OS ROMs for FP3 have been though an process of evolution; going back to old methods may not be helping you.

Have you tried avoiding any deviation from the current instructions ?

If yes, what was the very first point this goes wrong ?

1 Like

If I understand your question right, I tried to avoid deviation. The first error occured, like I said, here:

I dont know what this means.

May you have an idea which instruction to follow or what to do? My phone is out for hours now and I need it back today :frowning:

Please correct me if I am wrong but it looks as if you are working from the excellent guide [HOW-TO] Flash /e/-OS on Fairphone 3 using Debian based GNU/Linux which was sadly last updated in June 2021.

On this current page https://doc.e.foundation/devices/FP3/install the fastboot flashing of the various downloaded .img files is carried out by


Yes, that was the main/first guide I followed, then tried to do

Im on Windows, using the CMD-terminal, so this command and

chmod +x flash_FP3_factory.sh

are not executable. Also, I was confused about step 4, because isnt step 5 the how-to step 4? Thats when I turned to the excellent guide from June 2021.

ahh, ok, I think that is easily fixed. I do not use Windows but here is a link describing How to run .sh on Windows Command Prompt?.

Explanation of the Linux command

 chmod +x flash_FP3_factory.sh && ./flash_FP3_factory.sh

chmod +x → means “make executable the script” flash_FP3_factory.sh

&& → “and when that is done”

“run the script” flash_FP3_factory.sh

Also mentioned on the /e/OS install page:

Tip: For Windows users, we advise to use Git Bash. For more info about Downloads and Installation see Official Documentation

You may find an alternative method by searching “How to enable Windows Subsystem for Linux (WSL) on the system" – https://linuxhint.com/run-sh-file-windows/ X Edit, this will involve much more work :slight_smile:

Yes, I agree it is awkwardly worded.

Oh, I had such high hopes now. I installed Git and followed the instruction. The script was run in seconds BUT: same result as before. Tries to boot and then goes into recovery mode saying ‘cant load android system, your data may be corrupt.’
What now?

edit: there was an error in the terminal that a command failed. I try to run the script again now

My dear fellow, eOS started! Well, it seems the data wipe wasnt avoidable, but it started, thats great. Thank you sooo much for your help, I hug you virtually!

1 Like