FP3+ ota update IMG-e-0.13-q-2020120789006-dev-FP3

Hi there,

I’ve updated OTA my FP3+ with the latest firmware from IMG-e-0.12-q-2020111084008-dev-FP3 to IMG-e-0.13-q-2020120789006-dev-FP3.
Everything is ok except LTE or 4G mobile data.
Indeed there is no more LTE or 4G icon and no more mobile data connection.
I tried to modify APN (Bouygues french provider)but the issue belong the same.
Anyone has noticed the same issue?

Je viens de faire la derniere mise à jour OTA sur mon FP3+ depuis la version IMG-e-0.12-q-2020111084008-dev-FP3 to IMG-e-0.13-q-2020120789006-dev-FP3.
Tout fonctionne bien à part la connection 4G.
En effet il n’y a plus d’icone 4G et la connection mobile ne fonctionne plus.
J’ai essayé de modifier les paramètres de L’APN Bouygues, sans succès.
Quelqu’un d’autres à relevé ce problème?

Edit: tried with another sim card=> same issue

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Did you already switch off the phone (not just reboot, real power down) and switch it on again?

What was the carrier of this other SIM card?

If you are interested in helping us solve the 4G problem, it would be interesting to have a bug report please.

You can see how to generate a bug report here. In our case, it would also be interesting to use this command line: adb logcat -b radio > logcatRadio.txt.

Then, you can upload the generated files here, I will submit them to the development team.

1 Like

The other SIM card carrier is Prixtel, Orange’s MVNO

I will bug reporting asap :wink:

1 Like

In addition (it’s not an obligation), it would be interesting for the development team if you could:

  1. Try your SIM card on another 4G/LTE phone. (You already tried another SIM card in your FP3+ so there is a good chance it has nothing to do with the SIM card, but still.)

  2. Roll back to the previous version (e-0.12-q-2020111084008-dev-FP3) to check if it works. (You will have to erase your data)

  3. If it doesn’t, go back to to FairphoneOS to check if it works. (You will have to erase your data)

The point 2 and 3 are quite time consuming so if you don’t want to do them that’s completely fine.

Thank you anyway :slight_smile:


Bug report ok and file updloaded, the right command was adb logcat -d radio > logcatRadio.txt instead of adb logcat -b radio > logcatRadio.txt :wink:

  1. Sim card was tested on another 4G/LTE phone without issue

  2. Don’t want to Roll back to the previous version or FaiphoneOs and lost all my datas

I have already noticed the same bug with this previous release IMG-e-0.12-q-2020110883452-dev-FP3.zip fixed for me with this version IMG-e-0.12-q-2020111083843-dev-FP3.zip.

1 Like

Hello @argos, sorry to bother you again, but would you be okay with flashing (in the recovery mode thanks to the adb sideload command) an update in order to test if the dev team succeeded to locate the problem and fix it please?

You wouldn’t loose any data (because it’s just an update) and I would test this myself on my FP3 before to make sure the update process works correctly. I would also share detailed instructions on how to do this.

Hi @Anonyme, you don’t bother me. I will be glad to test this update.
Thx all the dev team for their fantastic job :slight_smile:

I have the same problem as @argos. I have 0.12 - 2020110582882 version of the system preinstalled on my FP3+. There’s no cellular data. Mobile network state is being shown as disconnected if I check “about phone” tab in settings. Cellular data works perfectly on this sim on all other devices. If I put another SIM to FP, it mobile data doesn’t work as well so it has to be something about the OS itself. @Anonyme can you help me with solving this too? The carrier of the SIM card is Orange.

1 Like

@Asti1992, i think the issue comes with APN settings.
Did you try to reset the network settings or modify APN?

After more exploration on this issue, it’s seems that the problem is known, with Bouygues and orange carrier .
I have just tried an another French carrier sim card (Free Telecom) and the data connection (4G) works with this carrier.

So this issue comes with Orange and Bouygues Telecom, hope it will help. Tried this solution with that thread on Fairphone forum
Same here:


I have modified Bouygues APN according Fairphone’s forum explanation
New Apn appears, 4G icon is back but still no data connection…

1 Like

Sorry for double post, but i can no more edit previous post.
So, In fact i’ve checked in the first sim card slot with my Pixtel sim card and the LTE data connection works.(i did mistake first time when i tried pixtel’s sim card on the second sim slot which don’t provide 4G connection)

I’ve have noticed that the 4G icon appears when i change the Bouygues APN setting from IPV4 to IPV6.
With IPV4 no 4G icon and with IPV6 4G icon appear in status bar:

@Anonyme any chance to test an update in recovery mode via adb?
Waiting for feed back from my carrier, but i’m not optimist.
I will reset my device in last resort.

Last OTA MG-e-0.14-q-2021012698290-dev-FP3.zip fix the data connection issue i had with Bouygues carrier => https://gitlab.e.foundation/e/os/releases/-/releases/v0.14-q =>user on Bouygues Telecom carrier will be able to get data connection by default

1 Like

Did the update last night, no issue so far!