FP3 update 0.12-2020102981459 works well? Please tell

i’m also affected by this issue, although i use a different kind of mobile phone.

i think, it’s caused by a wrong server certificate, because the letsencrypt server certificate is only valid for images.ecloud.global but the update process tries to open an https connection to ota.ecloud.global. that’s why it will stop on a 403 error. :frowning:


I downloaded a new image about 12 hours ago but it took nearly 2 hours to download, which strikes me as a bit excessive. It installed OK.

1 Like

update from 0.12-2020093076095 to 0.12-2020102981459 went fine.
The status bar issue from the previous version has been solved (Go to System > Status bar > System Icons)

Some default apps like phone, contacts, tasks are not yet adjusted for dark style, others (Calendar, Message, Files, calculator) are okay in Dark theme.

Trying to verify for a new update results in an error about the internet connection (which is actually OK)


In this post there’s another positive result of the update (from 0.12-2020093076095 it seems):

Obviously, OTA-servers are shut-down.


Now I was able to download 0.12-2020102981459 from the OTA update server. I’ll give it a go and report back.

Update now I’m on this version, all looks good so far.


For me it worked out well, too. Could download the update this morning and installed it without problems, now on 0.12-2020102981459 and came from 0.12-20200930…


Dear all,

I have made the automatic update on my FP3 when I received the notification.

However, after the restart, I got the normal fairphone screen loading and then black screen message with “recovery” written and also “Can’t load Android system. You continue to get this message factory data reset and erase a device”

Do you have any advices for me?

Do I really have to reinstall everything?

Thank you for your help

I checked my phone manually and the update to 0.12-2020102981459. It went very smoothly and everything is working oke at the moment.


And it’s very nice to see that almost every icon on the top of screen is back at the right.


Please read this answer, and if you don’t know how to use fastboot, read what follows on this Topic, and especially:

  • put your device in Fastboot mode by holding Power+Volume -, until you see “Fast boot mode” on the screen, and then ↓
  • And after that, run the fastboot commands above to change the slot.

Just upgraded from 0.12-2020093076095 to 0.12-2020102981459 without issues. :ok_hand:


And with the majority of feedback being positive, I just took the plunge, upgraded from 0.12-2020093076095 to 0.12-2020102981459 without issues. :ok_hand:


Hi, no update found on my FP3… any idea ? I’m still on 0.11-2020083170821

From your build date (0831 = August 31) I assume you bought your Fairphone 3 with /e/ preinstalled and with that would be on the “stable” channel of OS updates, because there’s a “dev” channel build from August 28 and the “stable” channel gets updates some days later with more testing by the “dev” channel users, who have installed /e/ on their phones themselves.

The latest update just got rolled out to “dev” channel users.
If my assumption is correct, you’ll just have to wait a bit.

1 Like

Did the update a few hours ago. All went fine. Thanks a lot!

Im excited to see Android 10!

Thanks for the hint! I thought you always have to flash magisk again with adb. I forgot to uninstall Magisk before the update but it still worked just fine.

1 Like

You don’t need to uninstall Magisk. It does need to be installed into the new slot but MagiskManager can do that for you by copying it over. I also have a rooted FP3+ with the development version of /e/ q and I am waiting to see if the same thing works on that.

Updated yesterday night from 0.11-20200828etc via OTA, worked just fine. Thanks!

1 Like