FP3 update 0.12-2020102981459 works well? Please tell

Being no hero, I’m hoping that the latest FP3 Pie update (0.12-2020102981459) will be checked by some of the more adventurous here… and I thank you in advance for leaving your result here!

Please report:

  1. build you’re on when starting the update
  2. any update-related observation you would like to share
  3. whether your FP3 boots OK after the update

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone



I just did the 0.12-2020102981459. It worked without issue !
Just saw your post so cannot tell which build I was on before. But it was the last one as the phone was hard reseted after the update from 03/10.

It seems that nothing changed. The changelog mentions the new status bar that I cannot find in the settings and also a UI change in the base apps to match the system style. I use the dark style and the apps are still light.

And yes my FP3 boots no problem.

Hope this helps and have nice day

1 Like

I am also looking for someone to succesfully update to 0.12-2020102981459 coming from the “first” 0.12 from September, so 0.12-20200930. I tried to update to the one from last Friday/Saturday and had to factory reset my phone :confused:

On my phone I have 0.12-2020093076095 installed without a problem.

Updated this morning, no problems thus far.

1 Like

Yes, me too but since this morning there is an update to 0.12-2020102981459 which I and @fidelious are not brave enough to try out :smiley: So we wait for someone to succesfully try it.

No problems! I updated my rooted FP3 using Magisk and the procedure here: https://topjohnwu.github.io/Magisk/ota.html#devices-with-ab-partitions


I updated from the other 0.12 previous version. No problems but % on battery disapeared. How can I reenable it please?


1 Like

Ok, I was going to download it now and to update from 0.12-20200930… to 0.12-20201029… but Whenever I try to download the message appears: “The download failed. Please check your internet connection and try again later.”
Strange thing is the internet connection works perfectly fine …


I’m getting that error message too


Yes, no Problems with update. :slightly_smiling_face:

1 Like

I got the same issue. Are the servers down maybe?

I do have the same problem: Suddenly I got 5 updates (looking before there has been no update at all): October 3rd, October 22th (2 time)s, October 23th 0.12-2020102380357, October 29th 0.12-2020102981459. Trying the newest I got the same message “Das Herunterladen ist fehlgeschlagen. Bitte überprüfen sie die Internetverbindung und…”. My internet connection works perfectly, too.
Trying with the update of October 23th I get the same message.

  1. the date of the last backup of your important data
    (in case of regular syncing to the internet: the date of the last check whether that actually works)
1 Like

Appears this message when I check again for updates. The rest just OK

i’m also affected by this issue, although i use a different kind of mobile phone.

i think, it’s caused by a wrong server certificate, because the letsencrypt server certificate is only valid for images.ecloud.global but the update process tries to open an https connection to ota.ecloud.global. that’s why it will stop on a 403 error. :frowning:


I downloaded a new image about 12 hours ago but it took nearly 2 hours to download, which strikes me as a bit excessive. It installed OK.

1 Like

update from 0.12-2020093076095 to 0.12-2020102981459 went fine.
The status bar issue from the previous version has been solved (Go to System > Status bar > System Icons)

Some default apps like phone, contacts, tasks are not yet adjusted for dark style, others (Calendar, Message, Files, calculator) are okay in Dark theme.

Trying to verify for a new update results in an error about the internet connection (which is actually OK)


In this post there’s another positive result of the update (from 0.12-2020093076095 it seems):