FP3 upgrade to camera3+ on android12 (S) not recognized

Hey @all,

I just today installed the camera3+ module on my FP3 (which runs on e1.9 S). After several reboots it is still not recognizing the new camera module.
Officially, the FP3 supports the new camera module with Android > 10 but now I am not sure if it might be an issue with /e/os.

Anyone else having this issue or encountered something similar? Any help would be highly appreciated!!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Welcome to the community.

Is the camera completely unresponsive?

Or is it that you don’t get 48 MP pictures out of it? Bear in mind that while the camera+ module has a 48 MP sensor, it still puts out 12 MP photos (calculated from the 48 MP sensor information).

1 Like

thanks for your reply and the comment. I was actually not aware of this mentioned fact.

Nevertheless, at this moment it is completely unresponsive. In any camera app, it does not even provide the option to use this (front) camera.

Well, I remember when the upgrade became available, a few FP3 users who installed it had the problem that the connector that connects the camera+ module to the core module became disconnected on the other (“invisible”) end, i.e. the one under the core module’s metal shield – roughly where the camera symbol can be seen in the photo in step 11 here:

Or, without the metal shield, see the two photos in step 10 here:

P.S.: The term “front camera” would usually mean the “selfie” camera. What I have been talking about so far only refers to the main (rear) camera.


Well…THANK YOU so much for this tip / hint! I dismounted the display and checked the connection of the “invisible” ribbon connector and it was clearly this issue! After fixing this, all worked fine!
And yes: you are completely fight about the “camera naming”. I mean the main (rear) camera, not the selfie one.

Thanks again! :slight_smile:

1 Like

Just for others reading this, I wanted to highlight that: The hint from @urs_lesse about the invisible part of the camera ribbon connector getting disconnected completely resolved this issue! Just make sure on physically installing the camera module that this does not happen! Then all is fine!

Besides this, the additional information about how the camera resolution gets you “better images” is still a super valuable information! Thanks @urs_lesse (also for your fix help!)

[I marked the original post with the help as “the solution”]

1 Like