FP3 upgraded camera V.0.13 still not working

Hey, when I upgraded my camera modules, it was said they would work when the new version of the OS is released. I now installed v.0.13 but it is still not working. Does anyone know any solutions?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Here is how it works:
The /e/ project develops their stuff and numbers it 0.11, 0.12, 0.13, …
Additionaly there are the base Android versions which are labeled nougat, oreo, pie, Q. These are not developed by /e/.

/e/ publishes their system on different base android versions, so you could have 0.11-pie or 0.13-q or 0.10-oreo, etc…

While updates to the /e/ parts are done with the system updater, there ist currently no way to automatically update the base android version.

This is your Problem. The new camera modules for FP3 do not need a newer /e/ but a newer Android version. You have to manually upgrade to /e/ on Android Q if you want the camera working.

Instruction.s can be found here https://doc.e.foundation/q-upgrade-fp3


Oh okay, this looks very difficult and is going to take me hours, if I am lucky enough to get it working… but thank you.
Are there German instructions somewhere as well?

I have exactly the same problem ! It’s look like very complicated =S

1 Like

They are supposedly working on the possibility to do an OTA upgrade, but there’s no timeline yet.

@ljahn correctly explained already that there’s no real correlation between the Android version and the /e/ version, but just to be sure that this really is the problem here … what does Settings - About phone - Android version tell you? Android 9 or 10?

1 Like

Android 9, unfortunately. I guess I have to try to somehow manage to do it as described in this instruction that ljahn sent

where can I see if my bootloader is locked or unlocked?

When you boot the phone into Fastboot Mode, it will list the device state as locked or unlocked.
Here’s an example picture from [HOW-TO] Flash /e/-OS on Fairphone 3 using Debian based GNU/Linux … displayed data may vary …

thank you! It seems to be locked. I think I know how to unlock it, but first I tried to activate developer options, but I could not find it anymore in the settings :confused:

Developer options need to be enabled first to be visible.
It’s part of the unlocking guide …

Thanks again for your help, but it just does not want to work. When I enter the commands it tells me that the command could not be found.

Which guide are you following currently, and can you post a screenshot of your command line where we can see the command and the message?

In general, either your OS has to know where to find the commands you want to execute (an installation procedure usually takes care of this), or you would have to point the OS to the location of the commands or navigate to the folder in which to find the commands and execute them there (which would be the case e.g. for the current Android SDK platform tools, which just get extracted to wherever you want).

Hello Julian,

have you looked at the easy installer? This program will enable you to install the latest version for your phone following simple instructions on screen. For the FP3, you will have the Android 10 version by default.



[quote=“AnotherElk, post:11, topic:24675”]
It’s part of the unlocking guide …


Manage the bootloader of your FP3/FP3+

A friend of mine did it now, thank you. The problem was that some steps are just not in the manual, it seems like it is assumed that people just already know certain kinds of things. Thanks a lot for your help, really!

I did install the latest update via the easy installer (so cool that you finally made that possible, when I first downloaded /e/ it took me six hours…), but this only updated /e/ and did not install the latest version of Android. I still had Android 9 installed, not 10. If the easy installer is supposed to also update the Android part, then something must have went wrong…

Would your friend be willing to share what is missing in the docs? “some steps are just not in the manual” leaves no real hint how to improve the install instructions.

1 Like

Hi Julian,
when did you use the easy installer? It is normally the Android 10 version that would be downloaded if you were to use it today. It has been the case for the past few weeks.

So, maybe that is just us, not knowing much about programming and so on, but for us, there where just some things that we had to just try out and see if it works that way (with the help of Youtube Videos to even just install adb or to unlock the bootloader, for example).
So she said, the main thing she was missing was the information about how and whereto to unzip the downloaded /e/, so it was not clear for us that we have to put it into the adb file.

The rest were just small detail, we don’t remember sorry… Most people who install /e/ that way are, I guess, more familiar with using the command line and so on, so they maybe have less of a problem.

1 Like

I used it on last Thursday or so, I think. Definitely not more than a week ago.

My FP3 was still in the state it was after I had installed the corrupt update, so I then did the factory reset and reinstalled it over the easy installer… It definitely had Android 9 on it after that.


I tried again yesterday and it installs Android 10. Please uninstall and install again the Easy Installer. Maybe you used it when it was still Android 9 and for some reasons it installs it instead of downloading the new version.