FP4 Device corrupted and won't boot in locked mode after fresh /e/OS install

Hi, I need some help with my Fairphone4 and the installation of /e/OS.

I followed the installation guide at Install /e/ on a Fairphone FP4 - “FP4” with my Windows 10 computer.
The installation went fine and the OS looks good when starting it in unlocked mode.
BUT, when I want to lock the device/ bootloader again, I get some problems.

I did the following to lock the device:

Step 1: In the bootloader menu I used fastboot flashing lock_critical.
Outcome: The phone reboots, but will not boot the /e/OS correctly. At that point I am stuck on the loading screen with the jumping “e”. The only way to shut down the phone is by removing the battery.

Step 2: Back in the bootloader menu, I used fastboot flashing lock.
Outcome: The device is rebooting, but the message is displayed, that the device is corrupted and cannot be boot. At that point I am stuck in some kind of boot loader loop. I cannot shut down the phone (except by removing the battery) and I cannot boot the OS. It will always come back to the boot loader screen.

Some background info:

  • Device: Fairphone 4
  • /e/OS Image used: IMG-e-0.21-r-20220123158735-stable-FP4.zip (latest stable)
  • Installation guide used: Install /e/ on a Fairphone FP4 - “FP4” (all requirements set and everything done as described)
  • Windows 10 PC
  • stable USB cable

After discovering this, I tried out a few things I found online.
For example, I unlocked the device again, used fastboot --set-active=b and locked it again (no difference, turned it back to set-active=a now).

I now re-unlocked the phone (unlock & unlock_critical) in order to be able to boot the device.
But of course I want it to be locked in the long run, as I don’t know which risks I would take by leaving it unlocked.

Can anybody tell me
(1) what I can try to lock and still boot the device successfully?
(2) what risks there are if I leave the phone unlocked?

I appreciate any help.
Thanks in advance!

1 Like

Hi Jacky,

Sorry i cannot help just right now, but i tried the installation a few minutes back and had almost the same problem. For me: I can boot into /e/ and everything seems to work as expected after issuing the fastboot flashing lock_critical command.
When i try to lock the bootloader completely by fastboot flashing lock , than i am also getting the message “your OS is corrupt” and get stuck in fastboot.
Is there anybody, who can help and got this resolved?

Update: seems to be related to Android verified boot, aka avb. Maybe it is only an issue of that stable build and the DEV build works OK.
Is it maybe an option to install the latest DEV build?

I have the exact same problem as you have described. I used the newest available stable version IMG-e-0.22-r-20220224165878-stable-FP4.zip

I don’t have a Fairphone but this thread reminded me of relocking bootloader on an Essential PH-1. I discovered that just the one locking command was required: fastboot flashing lock

This is despite having previously unlocked critical as well.

I saw on Fairphone support page that they suggest the same method.

EDIT (a bit late, sorry!):

Revisiting the Fairphone support page I see that I made a mistake and must have not read the article properly. Fairphone do indeed specify two stage locking; just the other way around from e’s install instructions

Fairphone: fastboot flashing lock followed by fastboot flashing lock_critical

eOS: fastboot flashing lock_critical followed by fastboot flashing lock

Begs the question: Which is right or does it even make a difference?

1 Like

Hi, I have exactly the same problem:

I have installed /e/OS following the official guide.
When at the end of the process I type fastboot flashing lock_critical, the phone reboots, I get a warning that the bootloader is still unlocked, but the phone eventually boots in /e/OS.
Next, when I type fastboot flashing lock, the phone reboots and I get the warning that ‘The device is corrupted’. It enters into a bootloader loop. No way of booting in /e/OS anymore.

I have tried with both IMG-e-0.22-r-20220224165878-stable-FP4.zip and IMG-e-0.21-r-20220112156786-stable-FP4.zip but it did not make any difference.

I have tried the solution proposed by @chrisrg but it did not make a difference.

The result is that I am currently using /e/OS but the phone is still unlocked and I get a warning every time I restart my phone. How to solve this without going through the entire installation again?

I noticed on Fairphone support page they also say

If you installed a 3rd-party OS, locking your bootloader might prevent your device from booting correctly


By the way, even if you can relock you will still get a splash screen warning. Something like: “your device is loading a different operating system”

I can also confirm that none of these images boot anymore after you run fastboot flashing lock

This issue needs attention from the e-developers.
Can anyone here raise an issue on gitlsb?

1 Like

Three things might be pertinent to these reports.


Are users experiencing this on stable only?


Many of the /e/ documentation install pages include the following:

Caution: Before following these instructions please ensure that the device is on the latest Android Stock firmware same as the version of the /e/OS you are planning to install.

FP4 however reads as if the author had just received a brand new Fairphone and describes the proces including 2 stage unlocking and relocking before and after:

Unlock with fastboot flashing unlock
… Unlock critical with fastboot flashing unlock_critical
… … Install /e/ …
Lock critical partitition with fastboot flashing lock_critical
… Lock the device with fastboot flashing lock

Have the devices been used for any other third party OS since the first / original unlock?


OS and platform-tools version.

cd platform-tools/
./fastboot --version

Someone has posted a bug report.

1 Like

I have the exact same issue. Happens with both iodéOS and /e/OS.

I also experienced this whilst attempting to flash the /e/ OS on a friend’s FP4. I attempted to roll back to the FP4 factory OS using the ROM and instructions on the FP site - but having done this & locked the bootloader I got the same “Your phone is corrupt and will not boot”. The OS booted up OK before I locked the bootloader.

I don’t know if this is a separate problem or if the /e/ install borked the phone for the FP4 OS ROM too, but the OS install has disabled remote unlock from fastboot so I seem to be in a hard brick situation. I think probably the solution would have been to have re-enabled OEM unlocking as soon as I had a bootable OS? (even though this wasn’t in the instructions!) Hope someone can learn from my experience!

There doesn’t seem to be any unbricking hacks out there for the FP4 yet so I think I’m at the mercy of FP support, unless anyone here has any ideas.

1 Like

Same exact boat here. Let’s hope FP support can help us without having to send the device back.

Same here. And I hope that there will be a solution in future.

1 Like

I suppose you’ve seen that currently the only “solution” seems to be to send the device back and get it repaired for about 30€:

So I just bought an FP4 and did what I did on other phones countless times before:

  1. Boot FPOS, unlock OEM unlocking
  2. Boot fastboot and unlock the bootloader (normal and critical)
  3. Flash /e/OS following their guide
  4. Close the bootloader
    Then I got the screen everybody else was complaining about (system corrupted and so on). I assumed that I had done something wrong, so I flashed FPOS again which worked perfectly. Then, powering down again I flashed /e/OS again, this time not locking the bootloader.
    It booted up like a charm, so I took a look at all the features. Then, to finish it I put it in to fastboot again and locked the bootloader. Now the phone won’t boot again (corrupted system), but aditionally I can’t unlock the bootloader in fastboot anymore, it just says locking is disabled. Could that be because I didn’t enable OEM in /e/OS?

So now I’m stuck with an unbootable phone with locked bootloader. The Fairphone support said they’d look into it, but meanwhile I should check for a solution on /e/.

Is there any way to get back into the system or open the bootloader?

I think the only solution currently is to contact Fairphone support about it, send the phone back and pay 30€ for a repair fee.

Same issue for me! I used this image: IMG-e-0.22-r-20220224165878-stable-FP4.zipand got stuck. Any way of solving except sending back?

Hi all,
i got the update e-0.23 release as OTA, having 5.March security patch level. With that release, i was able to lock the bootloader again!

For me this is solved now. Was just painful that the phone was wiped because of locking the bootloader.

Should be the same for @Jacky


Hi @Maximilian - Could you please elaborate a bit on your post? Did you simply update your phone to the e-0.23 release, after which you were able to lock bootloader again, without getting stuck in the bootloader loop? In other words, you did not erase you phone and installed e-0.23 afresh?

And what exactly was wiped when you locked the bootloader?

What about the others: @Jacky , Pferdli , yeoldegrove , andri , ulf-martinschmidt , MatteoV . Has any of you resolved the problem (without sending back the phone for repair)?