FP4 + EOS: Phone doesn't boot after locking - HELP!

Hi all,

Today I finally installed E/OS 1.19.1 on my FP4 with easy-installer on Ubuntu Linux. It worked well and E/OS was starting but the bootloader was still unlocked. Because I tried to do the manual install I already installed fastboot on my other computer and after reading some on the forums I was sure I could use fastboot flashing lock_critical and fastboot flashing lock to lock the bootloader. But after that I got the message ’ your device is corrupt. It can’t be trusted and will not boot’.

I literally checked a 1000 times if the OS that was installed had newer security patches then January 5 2024. And on the forums people claimed to have done it. But now my device won’t start, I can’t do recovery mode and I think I just threw away hundreds of euros.

Can anyone please help on how to recover my device?

I used fastboot flashing get_unlock_ability which returned 1. Next, I unloaded the bootloader again and then used fastboot --set-active. This made the E/OS go into recovery mode. Now I have an OS, but I have yet to decide if I want to have a phone with the bootloader unlocked.

Have you tried to apply a factory reset ?

1 Like

Unlocking the bootloader, which was done here, forces a factory reset for security reasons.

What does “that was installed” mean?
Fairphone OS that was installed before you installed /e/OS?
Or /e/OS that was installed by you?

/e/OS 1.19.1 has a security patch level of December 2023 according to https://gitlab.e.foundation/e/os/releases/-/releases … and if Fairphone OS present before had January 2024 (which would correspond to Fairphone OS version C.0101), that would be the situation to avoid according to https://doc.e.foundation/devices/FP4/install.

1 Like

Thanks for your response!

With “that was installed” I meant the OS that was installed on my phone before I started installing E/OS. This was Android 13 (T) with the security patch of 05-01-2024, so indeed, 1.91.1 has a security patch that is before this date…

Where it went wrong is that I looked at https://images.ecloud.global/stable/FP4/ and assumed that a release with a release date older then the security patch meant that it would be fine. The easy-installer doesn’t give any warning about this either and just installs the latest one.

Stupid mistake but since it’s so important that this is done right (and I saw I’m not the only one) I’m going to ask if they can be more descriptive about this on the download page.