FP4: No calls possible, but SMS and mobile data are working

Hi community!

Me and my wife are each using a Fairphone 4 since July 2022. I flashed both devices with /e/OS right after receiving the phones. So far we’ve been very happy with this setup!
But since August 2023, the phone of my wife suddenly cannot make or take phone calls anymore.
When dialing, her phone just stays silent, and after 30 seconds or so, it says something like “Mobile network not available”.
When trying to call her, her mailbox answers instantly. She then gets an SMS that there is a new mailbox message, and the caller gets an SMS that her number is available again.
She can still send and receive SMS and use Mobile Data.
We are both on the same mobile network (WinSIM/Drillisch, O2).
First it helped a few times to alter her settings regarding 4G calls, but that was just a short-term aid.
She also tried ordering a replacement SIM card and factory resetting her /e/OS, but none of this helped.
After resetting, she was able to make one single random phonecall, which made us think that it works again, but that was just an exception.
We also tried the following combinations:

  • her SIM in her phone: no calls possible
  • my SIM in her phone: no calls possible
  • her SIM in my phone: no calls possible
  • my SIM in my phone: everything works normally
  • her SIM in a different Android phone: full functionality

Both FP4 are on the newest available /e/OS release (currently 1.17-s).
Does anyone have an idea what could be the problem here?
Could it even be a hardware problem?
I would like to avoid having to go back to stock Fairphone OS.
As I’m not running Fairphone OS, I think this /e/OS forum is the correct place to start my problem solving journey instead of the Fairphone community.

Thanks in advance for any advice! :slight_smile:

Maybe you start having a look at the INFO menu *#*#4636#*#* (*#*#INFO#*#*) and IMS status (found in the dots menu) there. You might note some relevant or enlighting difference there between your two phones?

1 Like

Thank you! I didn’t know this INFO menu yet.

The information displayed on the INFO screen looks quite similar on both devices.
Interestingly, when doing a ping test, the defective FP4 fails on IPv6, while the working one doesn’t.
But the IMS menu is more interesting.

It seems like I’m only allowed to attach one image per post, so here you find a screenshot of the IMS menu on the non-working FP4:


It shows that none of the listed services is registered or available.
On the working phone, IMS is registered and voice over LTE and video calls are available.

Had something similar once, solved by choosing bands starting with LTE and not containing NR.

1 Like

Thanks for sharing your experience. I’ve tried different band settings in the Info menu as well as in the Android settings menu. So far, none of these efforts were effective yet.
IMS didn’t change from “not registered”, and no calls can be made.

Does anyone know if it makes sense to do something with the IMS service, like clearing its cache? I’m not sure which item in the system apps would be the correct one here on /e/OS…

So although your phones are near identical do the two SIM cards have similar history ?

The internet suggests that phones becoming IMS unregistered is not so uncommon, and often associated with a carrier problem – one comment I noticed: SIM card dropped support – too old.

Another user noted that carrier offered an APN reset and this was successful.

Good luck.

1 Like

A few days after her SIM card started having these issues, my provider informed me that my SIM card was old and I could order a new one for free. But this was not the case for her SIM card.
My thought was that maybe hers was old, too. So we ordered a replacement SIM for her as well (paying 15 bucks), but it did not help. Then she called our provider, they first recommended to reset the phone, and then agreed to send her another replacement SIM, this time for free.
After this newest SIM didn’t help, I factory reset her FP4. Since then, it still did not work, with the exception of one random call that came through :smiley:

I wondered if it would make a difference to try an eSIM instead, but didn’t order one, because I have no experience with these yet.

Just tried to reset the APN settings, but it had no effect.

If you can persuade them to do it a carrier APN reset OTA may have a better result as I do not think IMS registration is actually directly part of APN, but as I understand may be part of their OTA ability.

(If you paid for a SIM, it is reasonable to expect it to work !)

Good idea. And yes, I agree with you - I’m paying for their sevice, so they should help making it run.
So far, I wasn’t sure where exactly the problem is located. My Carrier, Fairphone hardware or /e/OS software.

Meanwhile I’ve found a more attractive mobile tariff at a different carrier, so I spontaneously ordered new mobile contracts for us both. It will be on a different network (Vodafone) and we’ll be using eSIMs instead of physical SIMs. Next tuesday we will see if this works with her phone… I’m optimistic so far.

This topic was automatically closed after 60 days. New replies are no longer allowed.