FP4 update program shows "/e/OS v.1.17 Aktualisierung verfügbar" and crashes when opening the program

The FP4 shows that there is an update. When you try to open the update program to start the update it crashs so that there is no chance to execute the update.
The FP4 with /e/ has been bought from Murena.
Somebody who has an idea how to get the update program work again?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Try if clearing the storage and cache of the updater app is solving the problem.


Can you tell me how/where to do the clearing of storage and cache of updater app? Opening the app it crashes. With my own FP3 with /e/OS I could not find the facility to do that.

On the Fairphone 3 it’s
Go to the app Settings
Go to Apps
tab on > See all … apps
tab on the three vertical dots in the right upper corner of the screen
tab on Show system
scroll down and tab on Updater
tab on Storage and cache
tab on Clear storage.


Thousand thanks - would not have found it myself :pray:
Suppose I will find it on Mum’s FP4, too (that’s the reason I bought a FP4 with /e/OS for her - my visionary power is narrow :wink: )

It worked: After having cleared the storage the update app started without problems. :smile:
I suppose the problems have been caused by 3 announced updates from the last 3 months :see_no_evil: - very difficult to explain her an OS update and to tell her that it is wise to install it - I tried more than on time in the past …

This topic was automatically closed after 60 days. New replies are no longer allowed.