FP5 stuck in fastboot mode, unable to boot OS or recovery, or flash new image - is it bricked?

After a botched root attempt on a brand new Fairphone 5 with an /e/OS dev build, I’m now left with a phone that cannot boot the OS anymore and, when turned on, simply gets stuck on the fastboot screen.

Selecting any of “Start”, “Restart bootloader” or “Recovery mode” just reboots the phone into fastboot mode.

I was able to unlock the bootloader with fastboot flash unlock and fastboot flash unlock_critical[1], but I when I tried flashing the /e/OS dev build again with the ./flash_FP5_factory.sh shell script, it got stuck at sending the first image (bluetooth_a) and I had to kill it after at least 1h w/o progress.

I also tried flashing a custom recovery (TWRP), but fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img got stuck in the exact same way.

Is the phone bricked now, or is there anything else I can try to get it out of this state?

  1. I had relocked the bootloader after flashing an /e/OS dev build. Maybe that was (part of) the problem and what led to the OS becoming corrupted when I sideloaded Magisk with adb. Or maybe I should have flash a custom recovery, like TWRP, first? Or both? Oh well, too late now… ↩︎

1 Like