FTP server: can't start?

Yesterday I tried to start primitive-ftp, I use this for years. The new version 7 seems not to work at all, the server can’t be started whatever I do (including complete deletion of all app data). OK, installed the previous version, does also not work (but I’m sure it did). Then I tried two other FTP server apps and both did also not come up, I didn’t get any server running, neither FTP nor SFTP.

What’s going on? Does /e/ 1.18 block FTP servers somehow? Does anyone currently have an FTP server app working? Which one?

Just tested https://mixplorer.com/ integrated FTP server, works fine. But only when started on port 2121 (default) …

1 Like

I still don’t get it. I checked now a 4th app on my device: FTP server says it’s running, but I can’t connect a client.

I checked also the client side now: several clients (filezilla, gftp, lftp, tnftp) do all work as expected with other FTP servers but never with any on my FP3. Instead already attempting a connection hangs until a timeout comes.

I checked also Advanced Privacy. There’s only the tracker blocking active, nothing else. This should not be a reason.

Mysterious. This did work for years without any problem. But I’m not sure if I ever had a working connection on 1.18, I guess the last one was on 1.17.

Maybe Google/LineageOS/Murena changed something, hard to tell…
A logcat may be of help here.

I think it’s related to firewall background actions. Most FTP server apps use a none standard port like 12345 or 8022 for a normal FTP connection and still another port for SFTP (and then even more none standard ports for the file transmissions).

When I start an FTP server on such a none standard port and I tell a client to connect the client gets never an answer. That’s why nearly all clients hang attempting a connection. Some have timeouts, others haven’t, you can only kill them.

When I start an FTP server on port 21 it’s a bit different. The clients get an answer and react on it by saying “connection refused”. Not clear why, the specified credentials should be OK. Most of them get then into a loop and try it again after some seconds which produces still “connection refused” on and on.

My conclusion is that none standard ports are not opened at all anymore for the outside world. At least on my device.

Update: my conclusion explains also why other web server apps (HTTP, HTTPS, WebDav) started on none standard ports like 8080 are also not visible for the client.

1 Like