G32 adb sideload no devices/emulators

I bought a Moto g32. Now I am trying to install e os with these instructions: https://doc.e.foundation/devices/devon/install
At the point “Ensuring all firmware partitions are consistent” I am currently failing. I have done that:

  • started the bootloader
  • selected recovery mode
  • selected Apply update
  • selected Apply from adb

On the PC I then tried to transfer the file with
adb sideload copy-partitions-20220613-signed.zip
Unfortunately, I then received the error message:

adb: sideload connection failed: no devices/emulators found
adb: trying pre-KitKat sideload method...
adb: pre-KitKat sideload connection failed: no devices/emulators found

My PC is running Linux Mint. Do you have any idea what I am doing wrong?

I have already tried the following:
restart adb with adb kill-server and adb start-server. → no success
on the mobile phone I have selected in recovery mode under advanced → Enable ADB → no success.
When I restart the mobile phone, the phone is back in the wizard where it asks for the language. However, since I have applied the changes from the previous steps in the instructions, the touch screen no longer works. So I don’t know how I can select a language again without the touch screen and then set the debug mode in the settings again.
As you have probably already realised, I am a complete beginner.
Many thanks for your help

Newly purchased Moto G32s are usually delivered with Android 12. Therefore my recommendation: Upgrade to stock Android 13 via OTA upgrade.

The command adb sideload copy-partitions-20220613-signed.zip must only be executed with a custom recovery such as e-Recovery ( recovery-e-1.20-t-20240222382228-dev-devon.img ); under no circumstances install with Android Recovery (!)

A working USB cable connection between Linux Mint host machine and Moto G32 is mandatory.

Which recovery mode did you use? Android Recovery or e-Recovery?

Thank you very much for the quick reply.

Do you know how I do an OTA upgrade if the touch on the screen no longer works?

I got the file copy-partitions-20220613-signed.zip from the instructions under “Ensuring all firmware partitions are consistent” under point 1, so I assumed that I was on the right track. I used the file recovery-e-1.20-t-20240222382228-dev-devon.img described by you under “Temporarily booting a custom recovery using”. Have I got something mixed up?

I believe that the USB cable is ok. I believe this because I can do fastboot devices in the bootloader and a device is listed there. But I can try another one, I’ll also change the USB port once.

I use the e recovery mode and not the Android recovery mode

If it is not already too late - try a factory reset in recovery using the volume buttons (select) + power button (confirm) instead of the touch screen.

did you enable usb debugging while in developer options and accept RSA fingerprint.?

Please check if there is a further step like

Advanced > Enable ADB > Allow, Slide or Press to Start sideload.

It may be at this point you simply see a response Cancel. That is ok, ready to start sideload.

Thank you very much for your support. I think I wasn’t clear at the beginning. I apologise for this. I will now explain step by step what I have done. This is for the following reason. I have now installed LineageOS instead of e os and these instructions etc. have worked. I strongly suspect that I made a mistake in following the e os instructions. Maybe you can point me to the mistake if I describe in more detail what I did.

I have tried to follow these instructions: https://doc.e.foundation/devices/devon/install

Since the instructions say that fastboot must not be older than version 31.0.2. and the version of Linux Mint is significantly older, I first installed fastboot etc. according to these instructions https://wiki.lineageos.org/adb_fastboot_guide.

Then I switched on USB debugging on the phone

Then I downloaded the zip and img from here https://images.ecloud.global/dev/devon/.

Unlocking the bootloader
Next I switched to the bootloader with adb reboot bootloader. With fastboot devices I could see the device in the console. With the help of fastboot oem get_unlock_data and the Motorola support page the bootloader could be unlocked.

Flashing additional partitions
Now you should unpack the zip file you downloaded before, in my case the e-1.20-t-20240222382228-dev-devon.zip. It should contain two files: dtbo.img and vendor_boot.img, but they are not included. In this case you should get these files from LineageOS. So I downloaded them from here: https://download.lineageos.org/devices/devon/builds

Now I have put my phone into bootloader mode and then flash the two files with this command:

fastboot flash dtbo dtbo.img
fastboot flash vendor_boot vendor_boot.img

Temporarily Booting a custom recovery using
Start the phone in bootloader mode. Then I transferred the image with fastboot flash boot recovery-e-1.20-t-20240222382228-dev-devon.img

Steps to install /e/OS from recovery
I formatted the device in e os recovery mode.
Factory rest → Format data/factory reset → Format data

In the main menu of e os Recovery I then selected Advanced → Enable ADB to make sure that adb is active.
In the main menu of e os Recovery I then selected Apply update → Apply from ADB.
On the PC I then used the command adb sideload e-1.20-t-20240222382228-dev-devon.zip
And now I get the error message

adb: sideload connection failed: no devices/emulators found
adb: trying pre-KitKat sideload method...
adb: pre-KitKat sideload connection failed: no devices/emulators found

Regarding adb problems, I have read that you should run adb kill-server and adb start-server and then it should work again. Unfortunately, this did not help me.

As I said, I’m a newbie. I therefore assume that I have probably done something wrong. I just can’t find my mistake. I find it interesting that I was able to follow the LineageOS instructions and everything worked. So I believe that my hardware USB cables etc. are working. Does anyone have any tips?

A stupid question. Can I also use the recovery from LineageOS and then install the OS from e os over it. Is that possible?
Thank you very much for your help

I would

  1. download the /e/ package to internal storage
  2. Flash twrp
  3. Format
  4. Install the internal /e/ zip

No adb needed

If the /e/ recovery is lacking then it would be a good idea to open an issue on the /e/ gitlab

The installation instructions of LineageOS and /e/OS are identical, but - LineageOS 21.0 is based on Android 14, /e/OS-T on the other hand is based on Android 13 and are therefore not one and the same.

The LOS 21.0 files dtbo.img + vendor_boot.img are provided by LineageOS for download.

The two files dtbo.img + vendor_boot.img from /e/OS-T are contained in e-1.20-t-20240222382228-dev-devon.zip, and here again in payload.bin. /e/OS-T payload.bin must therefore first be unpacked in order to obtain the two original /e/OS-T files for dtbo.img + vendor_boot.img.

My recommendation: /e/ should offer the two /e/OS-T files dtbo.img + vendor_boot.img for direct download and / or add a how-to unpacking payload to its installation instructions.

Payload Dumper Tutorial for windows users

For linux look for payload-dumper-go in your application/manager then install.

Hey guys you are the heroes!!! The problem was that I didn’t unpack the payload.bin. After unpacking, adb sideload worked immediately. slight_smile:

Thanks a lot for the help