G7 Plus XT1965-T Hard Brick

I previously installed to G4 Play (harpia) without incident.

I followed instructions for XT1965-T and everything went as expected until flashing recovery. There was no recovery partition so I booted into the recovery image and attempted to sideload the e/OS zip.

Half way through it just quit. No real error message. I did this 3 times with the same result. Then I stupidly rebooted hoping for the best.

Now I have a hard brick. Any hope or suggestions?

I had bricked a moto e5 and this Moto software restored it to original. Might work with the G7? The software troubleshoots the phone through a usb connection.


I appreciate the reply but the Motorola tool only works for a “soft” brick.

It wants you to boot the device into Fast Boot mode and then connect. My device won’t even turn on (“hard” brick).

Did you hold the power button down for an extra long period of time, usually around 30 seconds. Works with some of the Moto’s. Usually will boot to bootloader.

Yes, nothing.

But I do have good news — I was able to recover from the “hard brick” by following instructions here:

Now for the bad news. The latest zip package for this device still won’t sideload properly. It gets to 47% on the PC (step 2 of 2 on the device) and just hangs.

I am going to try and earlier package and see if that works any better.

1 Like

Hi @efdsys, if you are following /e/ installation instructions you may need to be careful when choosing fastboot command to flash your recovery. As we are trying to “temporarily boot” a recovery here the fastboot flash recovery command should not imo be used, as this is the command to install, rather than temporary boot. Further explanation here

As for the 47%, that sound like you completed. Don’t know about Windows installs, but on Linux, in terminal, you would only ever get to 47% and that would be it. Here are a couple of pictures completing sideload on an Xperia XA2

I really appreciate the reply.

I’ve been there, seen that and done that — more than once.

It gets to where the sideload says “Successful” but when I go to reboot, it says “No OS Installed?”. If I continue anyway, I get a “hard brick”. Thankfully, I now know how to recover from a “hard brick” but I am still having no luck.

LineageOS instructions include an additional step for XT1945-T that they say is mandatory.

In some cases slot b can be unpopulated or contain much older firmware than slot a , leading to various issues including a potential hard-brick. We can ensure none of that will happen by copying the contents of slot a to slot b . This step is NOT optional.

This is my next effort.

Understood. “No OS Installed” message is practically always there at that point and nothing to worry about.

Coming from stock it would be wise to flash the copy partitions zip.

Another safety measure (only my opinion) is to reboot to recovery after sideloading /e/. Reboot to system from there. It gives you the reassurance that you have a recovery safely installed and also if there are any problems booting system it can throw you error messages/advice.

Good luck!


The e/OS installation instructions for this device are lacking/incomplete.

See LineageOS instructions for NOT Optional copy partitions step. Otherwise, in my experience, you will get a “hard brick”.

Well done, glad you got it sorted! Happy days :grinning:

Not just this device my friend. Myself and many others have pointed out issues in the install docs endlessly. Every time I see a post like yours popping up here I wonder how many people have tried and failed that we never hear about?

I can feel a new topic coming on :wink:

Edit: I should add that the docs have been adjusted once or twice by admin after my comments but soon after they revert to previous or something else. It might be complicated.

All: If you see points missing in the Documentation pl share them on your device specific pages
Also let us know in case documentation changes have been reverted. The changes would have been overwritten by mistake and it would be helpful if we know what has changed. Also pl put these comments in the document specific pages to make it easier to track.

OK @Manoj, but it’s like deja dejaj deja vu!

Hi @efdsys, I guess I will need to go through the Unbrick process, but the link posted on the xda-developers page to download Blankflash file is not working. Can you upload the file somewhere?

Thanks for your help!


On the XDA page, use the link for “Stock ROM”.

Scroll down and look for “firmware/moto/lake/blankflash”.

@efdsys, found it, Thanks!

Nice work getting your XT1965-T up and running! I went through the same experience and finally came out the other side before seeing your post. I think flashing e to both A and B did the trick but i had another issue as well.

One thing I and at least one other user encountered was a problem where the phone would loop shortly after being unplugged from the USB cable (from computer). Phone would boot into e just fine and work perfectly until the USB cable was disconnected then it would loop and end up at a recovery screen saying that a factory reset (or similar) was needed and it couldn’t boot into the operating system.

Did you encounter this?

After two days of this, mine magically “fixed” itself and has been fine ever since. I’m looking for clues to prevent this if/when I flash a newer version of e.

My guess is that there was some communication going on between the phone and the computer via USB that, when broken (unplugged), would cause the loop. But I really can’t back up that idea at the moment.

I hope your phone is working well and good luck out there.

Well I was in the same boat; hard bricked my XT1965-T trying to install /e/ os. Finally was able to get it to fastboot with the blankflash on a Debian VM!

Now, are there any guides to get /e/ os working on this thing? Can I follow the Lineage OS instructions or should I just install Lineage or the stock rom? I already have Lineage on my other phone but I really want to get /e on the Moto G7

I am experiencing the boot loop exactly as you described it now. Should I wait 2 days to see if it will ‘fix’ itself. Is there any more information about what is going on?

Same boat. Hard brick. No response to any physical input. I’ll try blankflash tomorrow. I think the instructions are quite bad, sorry to say.

I think this command below might be one of the problems, because on the twrp page it says if you flash instead of boot the image, then you break your phone and have to reflash the factory rom. Which I actually haven’t found yet… sigh
“fastboot flash boot <recovery_filename>.img”

I do appreciate all the hard work that goes into this rom. Hopfully I can save my phone and get it booting.

Got it resurrected by reading here.

Once I got fastboot running, I got it into /e/ recovery and from there I was able to flash and boot into /e/.