Galaxy A3 2017 (Treble) SM-A320FL

Hey all,

I was finally able to perform the installation!

First, grab all the files. I uploaded everything here:

Here is the procedure:

  • Make sure the phone is unlocked and you can install custom recovery
  • Install TWRP recovery
  • Wipe data system cache and dalvik
  • Flash repartioner
  • Reboot in recovery
  • Flash
  • Flash e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img (switch to image flash in TWRP)
  • Flash
  • Reboot and enjoy!

And you are done!
If you need root, you can:

  • Download magisk manager from Aurora store
  • Download magisk from magisk manager
  • Reboot in recovery
  • Flash magisk
  • Reboot and enjoy!

One note, as you may know opencamera on samsung devices is not working correctly.
The only way to have a working camera for me was to install footej.
This is, I think, the only closed-source application that I have installed on my phone as of today.

Hi there, my phone keeps booting in loop after doing this… anyone had the issue?

This variant worked for me without a bootloop. However, I was shown a device other than my SM-A320FL. My installation variant works with eOS-Q-20201225

Thank you!
Whay is there two versions of the rom?

I thought it is only one that needs to be flashed?

I notice that I am not clear of the process with these ROM’s. Some instructions mention to install some other repartitioner and treble also… not sure if you need that and what they are for?

Would love some clarity here so that I am sure that I am doing the correct thing.

What I did with these is that I unzipped them and in the TWR I Installed the Image - got 3 choices (Boot, Recovery, System Image and Vendor Image) I chose the “System Image”. I did both of them and sometimes I get that there is no operating system installed… and sometimes I get that it is and asks me to install TWR again where I choose No to as per the original instructions.

When booking the phone is still going in a loop… what am I missing here?

The two ROM versions are the most commonly used. However, GSI has more to offer: six ROM variants, depending on the system architecture. See also “Why should I use GSI for A/B devices to some A-only devices?”.

The GSI idea was well-intentioned, but in practice various shortcomings become apparent. Bootloops are constant companions during installation. That is why it is important to know what you are doing when you want to install GSI ROMs.

The SM-A320FL is curious. The ROM e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img is the so-called A-only variant and worked on my treblezied A3 2017. On the other hand, I had to install the A/B variant of the eOS-Q-20201225 because the A-only variant ended in a bootloop. (???!)

Something else: Besides GSI ROM, have you tried the device-specific build ROM e-0.14-q-20201220-UNOFFICIAL-a3y17lte from @itsclarence?

Hi there, this got me further than I have ever gotten. Now instead of it looping it is stuck showing the e with the bouncing ball underneath it…

I have also installed the eOS-Q-20201225-UNOFFICIAL-treble_arm64_bvS.img.xz on the system and I got also the bouncing e from that… but it doesn’t continue anywhere…

Is there anything I have missed?

oh my side, I was not able to boot the Q version, so I stayed on the P.
I was coming from Stock Rom (Android 8 IIRC).
If you are not sure, you can rollback your phone to stock rom using ODIN (you can find the rom on samdevices or other website like this).
Then, apply my procedure and it should be ok.

This looks promising. How is development for the A3 2017 progressing?
Can I wait for this or should I get A3 2016, which has /e/?


I need to install my A3 2017 (back to stock 8.0.0)

Édith : one more time, I’m completely lost in a lot of threads and not sure I will use the right set of tools. @SuzieQ : how did you made your a3y17lte treble-capable, please ?
I’m downloading eOS-Q-20210124-UNOFFICIAL-treble_arm64_bvS.img.xz, needing more than an hour, here :roll_eyes:

Thanks a lot.
PS: download links for unofficial /e/a3y17lte (non-GSI) are dead…
PS2: bootloop, 4x :unamused:

PS3: I tried to install TWRP-3.3.1, then flash Repartitioner, flash OrangeFox, flash LOS17.1 from xda and it worked :face_with_raised_eyebrow:
Then, back to OrangeFox, flash eOS-Q-20210124, flash GSI-patch and this … device boots on /e/ :crazy_face:

PS4 : surprised by a ‘straight’ boot in French + right hour… I tried a clean flash after wiping > recovery loop. So I have to install LOS-17.1 first, config locales and then flash eOS-Q.img and GSI-patch without wipe.

So based on your PS, I imagine you finally boot eOS successfully, right?

Which image did you use?


Yes, device had boot on e, the one I downloaded above : eOS-Q-20210124-UNOFFICIAL_treble_etc.

But I 'm not sure it’s now fully treble capable. Works with GSI patch, but with little bugs here and there…


Unfortunately, open camera doesn’t work in video mode : catches sound but stays on the first picture. Device specific issue ?

It runs eOS-Q-20210124…

Issue solved in last build ? Or a mod to install ?

Edith : with a lot of different config settings, Simple Camera doesn’t solve this, nor FreeDcam (both from F-Droid).
Video call works, with ‘sheltered’ W.A. and Messenger Lite :rage:

The only camera app that I was able to use was footej

Hi all.

In fact video mode works, gallery is buggy. While reading an OpenCamera’s video, a touch in the middle of the time-lime launch the reading as normal, but time index stays on end.

Even though I am used to tinkering and searching hours in forums I am completely lost here.
First of all before continuing :
Is e os usable as a daily driver on this device (a3 2017) ? I want to run away from google, but given how hard the install and flash look like, I don’t want to end up with an unstable/not fully feature install. Also I don’t want to replace my perfectly working phone, so I don’t have the choice of the device.
Concerning the install :
As far as I understand, there is no official version of e os working for it, but I can use the ‘generic’ treble version. First I have to flash twrp (I can manage that), but after that it is unclear.

  • When using getprop ro.treble.enabled it return false. Does this mean I have to do something before flashing the new ROM ? Or perhaps I just have to flash it like with any tutorial on the internet ?
  • This might sound like a silly question but I can’t find on the internet if I need to be root or not (I am not).
  • How can I make a backup of my current official rom (or can I trust the one I can find on the internet) ?
    I really don’t want to end up in a boot loop since it is my main and only phone. I can afford to only use my computer for something like a week, but it would be better if I could do it in first/second try. That’s why I need to be as prepared as I can.
    Thanks in advance for replies.

Hi @Twisty welcome to /e/ land.

Is critical - @OneThumb provided this clue recently: [GSI] Q-GSI --- new version download location. See post 73 - #109 by OneThumb

Please be aware that anything which involves “a backup of your EFS partition” requires careful thought, reading and preparation.

This is the /e/ documentation page

Bon chance

You don’t have to root your device to flash a rom or a GSI. You just need to have a custom recovery like TWRP. TWRP has to be flashed using Odin. Then in TWRP you can make a backup of your official rom (Save it on your SD card, not on the internal memory of the phone. By default it’s on the internal memory, so change it because maybe you will wipe it by accident, and make a copy on your computer). But you also can download an official rom on websites like sammobile (.com) (you can trust this site) and then (re)flash the official rom you’ve downloaded, using Odin, if anything goes wrong.
I’ve said “do a back up of your EFS partition” because this is always the first thing to do just after you’ve flashed a custom recovery. Sometimes, losing EFS partition can happen, and then your phone won’t connect to network. I didn’t have this issue with my A320FL although I flashed it several times with different roms and GSI, but I had this problem with several S4 Mini (i9195), so now I do a back up immediately after flashing a custom recovery before doing anything on the device.
As a beginner, myself, I suggest you what I’ve done : buy a second A3 2017 in poor condition (with front glass broken for example, but touch screen ok, and be sure that the usb port is not faulty/loosy, because it’s important when flashing from your computer), it doesn’t cost a lot, and then make your experimentations on it. When you will be successful, you can do the same on your daily device. Yes, e0s on A3 2017 seems to be good for daily use. Just be aware that you will lose quality with your camera with every roms which are not official (I mean every rom which is not a Samsung official rom or your Telephony Provider rom). I don’t do a lot of things with mine (just calls, sms/mms, photos, listening podcasts, I tried internet with a web browser and it works). My battery lasts 12 days and listening podcast 1 hour everyday takes 30% of the battery, so the autonomy is very good.
Concerning your “getprop ro.treble.enabled = false”, I don’t understand what you mean exactly by that. You have to flash a repartitioner script (with TWRP or OrangeFox) to treblize you device, before flashing a GSI. The ro.treble.enabled options is in the build.prop file which is in the system partition of a rom, it will be “= true” in every treble rom you will install. The official images of eOs GSI are now in a zip, (there is also an .xz format, that’s why aibd talked about .xz file). But, it’s not a flashable zip, you have to extract the .img file, but before you have to do some things to prepare your phone.
As I am not an expert at all, I don’t know if it’s possible to keep the original vendor files of the original official rom of an A3 2017 and treblize the phone and just flash the GSI of eOs and have it working like that.
There is LeOS (a GSI of an ungoogled LineageOs which is developed by harvey186 and with his GSI he recommends an OEM vendor. But I don’t know if it’s possible with a no real treble device like A3 2017 which is artificially trebled).
If it’s not possible to keep your official vendor, I suggest you first to flash a treble custom rom found on the forum of xda-developers, follow the tutorials you can find on the pages where are located the different custom roms to learn to treblize your device, etc… but there are some things to know : you also have to flash other things. I can write what i’ve done (I’ve first flashed a treble custom rom found on xda-developers, before I found an eOs for A3 2017). You seem to already have TWRP because you say to try to flash zip, but here is what I’ve done to flash TWRP and then a treble custom rom :
Back up photos and other things on a computer.
Activate Developer Options on the phone
activate OEM unlock
enable USB debogging enabled

restart in download mode : volume down + home + power
Open Odin on the computer.
load the twrp file in the AP area of Odin
Untick auto reboot ! That’s important.
plug the phone
click start

when it’s done : don’t restart the phone ! but restart in recovery mode by doing this : volume down + home + power and when the screen is black release quickly the buttons and then repush immediatly these 3 buttons : volume UP + home + power, this will open the recovery mode (in TWRP)
Now in TWRP :
back up the EFS partition
format data
flash noverity script (found on xda-developers)
flash rmm bypass by corsicanu (found on xda-developers)
back up the official rom if wanted (on the SD card and be aware that it will take time and space)
restart TWRP (available in menu)
format data and then wipe everything except external (sd card) and usb otg
To treblize the phone : flash a repartitioner script (found on xda-developers)
reboot TWRP again
format data and wipe everything except sd card and usb otg
flash a treble rom (crDroid in my case, found on xda-developers).
when flashing is done, wipe cache/dalvik as suggested by TWRP
reboot the phone
see if the phone boots
if it’s ok, reboot in recovery mode (TWRP), try to wipe data and if there is an error, then format data and then rewipe data. I’ve got this error, and if you too, it will persist everytime you will go in recovery mode and won’t allow you to make a back up of your data, so I personnaly use OrangeFox (which is flashable with TWRP). But OrangeFox doesn’t permit to flash a .img on specific partition (maybe I’m wrong) whereas TWRP do. So, to flash an .img on the system partition, you will have to use TWRP.
But, as I said in the post mentionned by aibd, I don’t use a conventional way to flash the official GSI of eOs.

This is what I’ve done, I’m not responsible if you brick your phone, this is just what I’ve done, not what I’m telling you to do ! But I’m telling you to make your experimentations on a second phone !
And, please, read a lot of topics about flashing treble roms on A3 2017 on the forum of xda-developers, here you will find lot of informations :
Be careful to use what is aimed to be used with A320, not a different phone. All the A series phones are in the same section of the forum.
Please someone correct me if I’ve said something wrong. This was just a beginner post.

Thank you a lot for your quick and super detailed answer, it is exactly what I needed to sort all the informations I had and get started.
I don’t use my phone much, so I am ok with something that is as fast as the stock rom and that can read my medias (no problem on this side).
I am still hesitating whether I do it or not, if I do I will update my progression here.
Have a good day !

I installed e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img as it is explained above by mangerduchien :

*Here is the procedure:*
  •    Make sure the phone is unlocked and you can install custom recovery*
  •    Install TWRP recovery*
  •    Wipe data system cache and dalvik*
  •    Flash repartioner*
  •    Reboot in recovery*
  •    Flash*
  •    Flash e-pie-20200416-UNOFFICIAL-treble_arm64_aeN.img (switch to image flash in TWRP)*
  •    Flash*
  •    Reboot and enjoy!*

about 1 year ago. It is very fine and I am very happy with it.

Now, I would like to update for security. I tried to flash all eOS-Q-xxxxxxxx-UNOFFICIAL-treble_arm64_avS.img I found here but the result is alway loop-boot.

Could anyone help me ?

1 Like