Galaxy A5 2017 bootloop after OTA update to 1.16

After downloading the update, TWRP loaded, but the installation did not go.
When I reboot, the icon “e” appears, then it stops moving, and again it loads in TWRP.
Tried to manually install from TWRP and adb.
Same effect.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Yu can probably work around it by formatting yourr data partition. Backup your data before you do so. See this post for details. [CUSTOM BUILD] Sony Xperia XZ1 Compact `lilac` (Android Q) - #21 by petefoth

1 Like

I tried it, a clean system came on, but after restoring “data” from a backup, it automatically encrypted the partition at startup, and then the same problem appeared.

I disabled forceencrypt, the partition is not encrypted, but the bootloop remains.

Maybe you have to backup a non encrypted /data partition…

I don’t, but I don’t think encryption is the problem.

Deleting /data/system/packages.xml file causes the system to boot normally, but shuts down after 5-10 seconds.