Galaxy S7 echo during calls with speaker

You may add a comment and thus give the gitlab issue some support: #6210


another place to post grievances. While my problem is the same as Sebastian and no answer has been given to him in 3 months…
Laziness wins.

That issue hasn’t been on for months, but for years ! I’m afraid the only workaround is to buy a new phone or use a different ROM… but not LineageOS, as /e/ is based on LineageOS ! When I bought my phone from /e/ shop, it didn’t occur to me that I wouldn’t be able to use it to make phone calls ! Very annoying…

I have this issue, is their a way to ‘up vote’ the git lab issue, I could comment, but I have nothing to add.

Someone suggested simply putting tape over the 2nd microphone ! to blank it off, but that seems a crude work around.

I have done the 1.8 update. Still the same problem.
There is one thing I don’t understand.
When the developers chose to offer for sale /e/ OS on the S7, they must have realized at some point before the marketing that there were problems of echoes during phone calls. I guess the “phone call” part is one of the first tested feature? It’s the basis of a phone.
As far as I’m concerned, I installed /e/ OS after. But I put myself in the shoes of the people who bought this phone on the /e/OS Store and had this problem. They were cheated.
Unless the problem didn’t exist at that time, therefore it’s that the problem is fixable

Callers report an echo of their voice with speaker off, as well as with speaker on, there is no echo when using ear buds or head phones.

Does this issue exist on the Galaxy S8 or S9 ? I like the S7 for its smaller size, and really have no need to change, I see back in 2019 it was raised with the Dev Team …

I have the echo problem since installation of nougat on my S7 but this was only with speaker on.
Today with 1.8.1 installed, I have the echo problem even when speaker is off.
That makes the S7 pretty unusable …

I have the echo problem since installation of nougat on my S7 but this was only with speaker on.
Today with 1.8.1 installed, I have the echo problem even when speaker is off.

At least when the phone only had the echo issue on speaker, you could live with it, but now with echo with speaker off, its a bit of a problem …

So the 1.8.1 update has introduced a problem that was not there before.

There appears two ‘issues’ on Gitlab:

I have read about USSD “secret codes” allowing to launch a test on a smartphone.
In this case an audio test. But it is also stated that it can blow everything up !?
Anybody already tried that ?

Not sure what the loopback test will prove, never tried it, here’s what a quick DuckDuck dug up:

Am I looking in the right place:

List of Samsung Codes for Samsung One UI

*#0283# Check Audio loopback control

Doesn’t list S7, does say ‘etc’ though at the end:
‘you can try the following secret codes on your device. Samsung Galaxy S8, S9, S10, S20, Galaxy Note 9, Note 10, Note 20, Galaxy A and M series, Galaxy Tab S series, etc’

and …

and …

the Samsung-specific USSD-codes that I tried so far did nothing at all (saying: “connection problem or invalid MMI-code”) , can´t say if not working because of “S7” or due to eOS instead of stock-ROM … my intuition says it´s the latter, but might be wrong of course :slight_smile:

Je suppose qu’à l’installation, le système d’origine Samsung ou FloydQ met à jour /boot et /system mais aussi les partitions qui contiennent les pilotes propriétaires Samsung (les blobs si j’ai compris).
Ce que ne fait pas /e/Os qui ne touche pas aux trucs propriètaires.
Est ce que vous avez essayé de re-installer /e/Os après les essais avec la ROM Samsung ? Si ça marche, c’est que les pilotes propriétaires sont trop anciens (ils datent de nougat sur la plupart des S7).

I guess that Samsung/FloyQ install performs an update of /boot & /system partitions but also of /vendors partitions containing proprietary stuff (so called blobs).
/e/Os doesn’t update vendors stuff.
Did you try to re-install /e/Os after the full update with Samsung ROM ?
Could it be a problem with too old proprietary drivers ?

I see this old topic about updating baseband Baseband updates? - #8 by heartshapedbox
And I wonder if this is not related to our echo during call problem.

Proprietary Samsung stuff does not get updated while the android system does. And they slowly become incompatible.

I have two S7, one with the official rom and the other with /e/ OS that I installed myself.
I tested the secret code: *#0283#
it works with the S7 with the official rom
it does not work with the S7 /e/OS.

If you need, I can do some tests or manipulations to compare, but I would need assistance, because I am not a computer expert

Still the same with a Galaxy S7 (de-googled on my own) and /e/ 1.9.

Covering the top micro did not help. Any solution would be appreciated.

Possibly worth reading this thread

… a fix was reported successful in this post in that thread

I activated the option “Mono audio” in the settings, as suggested there.

Thank you for your suggestions. this encouraged me to watch the video (what is not my preferred medium, I admit). It contains three suggestions:

  1. Enter “safe mode” - but this mode is not available on /e/OS, as I presume.
  2. Activate “Mono Audio” in the settings. Done, but without effect.
  3. Do a factory reset, if #2 does not help, and /hope/, this will do the trick. I did not in lack of hope.

All in all, I do not consider these suggestions to be a general fix. It might help in some cases, though.

alrite guys well i am not from EOS but i have face this issue on my s7 herolte on lineageOS microG edition
And i kinda fix this issue…
here is what i did ( require Root permission to edit file or adbshell might work as well )
File location [ “/vendor/etc/audio_effects.xml” ] Change file permision allow yourself to edit it using chmod or properties using any root file explorere

Inside audio_effects.xml
Change Voice communication tab code ( i remove AGC and saved )

  <stream type="voice_communication">
    <apply effect="agc"/>  (remove this line )
    <apply effect="aec"/>
    <apply effect="ns"/>

this is how it should look like

  <stream type="voice_communication">
    <apply effect="aec"/>
    <apply effect="ns"/>

It still make sound but now it has reduce kinda lot its hard to hear ..!! Try it.. all the best
1 Like

Hi, this is new for me.
Did you test this hack with or without speaker on ?

1 Like

Hi just modify the file, hope it will work I will done a feedback. Thxitzsushant!