Galaxy S8 with the easy installer

I’m considering to install /e/ on a S8 for a friend with the easy installer. I’d like to know if someone already did it and if it went well or if he has encountered some problems.
Also what are the prerequisites in order to install with the easy installer? Is it a problem if the S8 is locked by a network carrier?
I’d be really thankful for your help

1 Like

Hi - I recently installed e on a Samsung Galaxy S8 using easy installer on Ubuntu, pretty straight forward. Make sure your phone version is compatible (US snapdragon is not) and yes you need it to be carrier unlocked to my knowledge.

I only encountered two small issues using the easy installer, one was after initial reboot into “download mode” where I had to press / hold different psychical buttons on the phone to reboot it again, then the easy installer wrote, the correct buttons was displayed on the phone.

Right now I can not remember the other one, however I send back the information regarding the issues so hopefully they will / are corrected.

EDIT. I remember the other minor issue I encountered, when the guide states “activate MTP” MTP is simple “file transfer” in the USB menu, had me confused :slight_smile:

1 Like

Yes, a huge problem even.

Without “OEM Unlock” the flashing of CustomROM à la /e/ OS or LineageOS is not possible!

2 Likes

Thanks a lot for your feedback! When you say small issues, does that mean that it’s nothing of concern for the succes of the installation even for someone without any specific knowledge?

1 Like

Thank you for your answer! That’s really too bad, I thought that flashing another OS would get over it… Some really do their best to lock us up. I’ve bought an unlocked one then and I’ll be trying the easy installer when I’ll receive it