Galaxy S9 'starlte' + /e/OS 'Q' dev AOSP Android 10

That is one method. It disables at the User-level. On my phone, I disable package names and apps at the System-level. This does not require rooting the device with e.g. Magsik, /e/OS ‘Q’ and ADB commands are sufficient. Also, I generally don’t use /e/OS with rooted devices.

The thread “Uninstall default apps” has been closed by /e/ support. From this I can see what the /e/Officials think of this whole theme: The package foundation.e.apps should work as intended.

The uninstall default apps topics was closed as it was very old. The concept is very much active.
Only problem is like a lot of other tasks there are not enough developers to work on it. We had done a bit on research on it and understand it requires comprehensive changes across all apps and to system level code.
This idea of having uninstallable default apps is on the top of my list of features I would like to see on /e/ and keep reminding the dev team to restart work on it.

Well, a thread was opened in October 2019. This also shows how long the “uninstall default apps” issue has been bothering users. With recent activity in August, September and October 2020, I don’t feel the topic is “very old”. But that is a matter of opinion and a question of definition.

Closing threads has the disadvantage of encouraging the fragmentation of a topic. Continuous updating allows for a quicker overview. Finding one’s way around the forum is not everyone’s cup of tea, as is clear here:

1 Like

I think a big part of users request about removing default system applications is due by the fact that Bliss Launcher don’t allow to hide an application icon.

In many cases, when you don’t want to use a default application, you simply don’t use it.
You can install a replacement one to use it if you need the service.
But having its icon every minutes in front of your face could be extremely annoying !

In some case of conflict between applications or desire of absolute control, uninstalling could be a necessity…

Please give us a clue as to which adb commands? :slight_smile:

Pete, I assume you’re an advanced user. Your activities here, if nothing else, show that.

What I do is not witchcraft. Everything I know I’ve learned by researching the WWW and trying it out on devices. My maxim is: theory is important, practice is life. So what I can do, anyone else can learn. I’m also learning every day. And that gives me much more pleasure than “100 years ago” at school :))

I only advise those users who know what they are doing to act on a system level. Please do not misunderstand this statement. It is not meant to discriminate against anyone. However, working at system level involves various risks from which the normal user should remain protected.

You will receive a PM from me today.
Kind regards and stay healthy and safe.

Thank you @petefoth for the disable command. The calendar notification constantly blinking in my face is gone.

Is your serious thought of flashing back gone now too?

For the time being :wink:

My recent posts have been a little salty, and I apologize if anyone has taken offense. After trying out some launcher voodoo, etc. things are a bit more liveable.

So, is the S9 not fully upgraded to the official 0.14 build yet? Just asking for clarification.

Your anger and disappointment I clearly perceived. That’s why I’ve been covertly cynical in echoing it.

I had also expected the /e/OS ‘Q’ upgrade to be more up to date. The Android security patch status 5 November 2020 gives me the impression that the upgrade was pushed because of the great pressure of expectation. Well, at least the S9 / S9+ is now at ‘Q’ level and thus suitable for significantly more new users than with the 8-Oreo release.

My new test system is up and running: Numerous pre-installed apps are disabled for now, especially & openweathermapprovider and, because weather apps generally have a reputation for being chatty. For me, chatting all day is enough :))


Use the open-source Android firewall NetGuard Pro version (paid version), because only the Pro version unlocks those functions that are essential for monitoring and controlling outgoing (app) data connections even without root rights.

The update from microG to microG (with the option ‘Exposure Notifications’ OFF, which I like) was successful with my tried and tested method.

Well little Miss @SuzieQ, down the rabbit hole I go. :slight_smile:

I just downloaded and installed NetGuard Pro. I tried TrackerControl via F-Droid, but it was a bit wonky for me. Anything I should be aware of?

Hi, I got /e/OS ‘Q’ up an running on my S9 and I’m liking it so far. However, I can’t get Netflix / Prime Video etc. to stream content. It worked on the /e/ Oreo build but not on Q. After some looking around it seems to be a DRM issue, but I can’t find much more info on it and no solution so far.

Is anyone else having this issue? Or know a fix?
Any help / suggestions would be appreciated.

If you knew what my natural height was, you would be careful not to call me ‘little miss’ … :))

I don’t understand what that means “a bit wonky”.

I apologize. This was meant as a term of endearment, no offense was meant!

It refers to something that is supposed to work, should work but doesn’t work as expected and there’s no specific reason or explanation why- a gremlin, a ghost in the machine…

For example, even when TC was set to “off”, ProtonMail would complain that it could not connect and /e/ services (mail, contacts, etc.) would fail with an I/O error.

I didn’t misunderstand your wording. I still enjoy listening to SuzieQ in the long version from 1968 by CCR.

Well, apps like Netguard and TrackerControl are tricky tools. Take your time to learn how to use them.

Hello SuzieQ,

Thanks a lot for sharing your experience!
Why did you choose the older firmware release of April 2020? Is a newer one problematic?
Maybe you can give me a hint :slight_smile: . Thank you!

Hello @whoknows,
the Aril 2020 firmware was present on the S9. I deliberately did not update it to test the behaviour of the S9 when I install AOSP 10 like LOS 17.1 and /e/OS ‘Q’.

I was inspired to do this test by the note on the LineageOS Wiki website »Warning: Before following these instructions please ensure that the device is on the latest Android 10 firmware.» I took it very seriously and literally “latest Android 10 firmware”. The buzzword ‘latest’ was the definitive reason to ask me: what happens if I use the stock Android firmware from April instead of December 2020 as a baseline. Well, absolutely nothing ‘problematic’ happens. LOS 17.1 and /e/OS ‘Q’ could be installed completely stress-free.

1 Like

A new release for AOSP Android 9 but not for AOSP Android 10? Why would TeamWin do such a thing? Please let the following TeamWin statement roll off your tongue:

TWRP 3.5.0 is out now for most currently supported devices.

For this release we are breaking down new support for devices based on android trees and device compatibility. For Pie and earlier devices, they will be built out of the android-9.0 branch. For devices that are released with Android Version 10, they will be supported under the android-10 branch.

Please give us a link to that statement.

My interpretation is this: There are two versions of TWRP 3.5.0_9.

TWRP 3.5.0_9 for ‘9-Pie’ and earlier devices they will be built from the android-9.0 branch.
TWRP 3.5.0_9 for ‘10-Q’ they will be created from the android-10.0 branch.

Warning: The Samsung Galaxy S9 is no longer maintained. is not joyful ews. So is S9+ 'star2lte’. It is likely that the Galaxy S9 / S9+ will sooner or later suffer the same fate as the S7 / S7 Edge … :((

But - Galaxy S9 / S9+ are Project Treble supported device and with /e/ GSI ROM 10 and custom 11 both devices can be used as degoogled smartphones for quite some time.