Galaxy S9 'starlte' + /e/OS 'Q' dev AOSP Android 10

Please try this first:

I’ve tried to upgrade my /e/ S9 device to Q but run into a problem. As suggested I’ve first upgraded the firmware to Q using the firmware from sammobile (build 22 jan 2021) This was successful. After that I’ve followed the instructions from Patching the device failed however since this wasn’t mentioned in the I thought this might not be needed. Upgrading twpr was successful however when I want to sideload /e/ using adb sideload I get the next error:
serving: ‘’ (~0%) adb: failed to read command: Success
What am I doing wrong? thanks in advance.
Edit after re-reading the instructions it seems I missed the Vendor updates. Currently downloading continues fails for the vendor but will give that a try first.
Edit2. vendor sideload gives the same error.
serving: ‘’ (~0%) adb: failed to read command: Success
Is this due to the fact patching failed or is there something else wrong?

The message 'failed to read' is an indication that adb sideload cannot find the file ''.

For simplicity, try the following (there is more than one possibility): copy the file ‘’ to the same /directory folder where the adb.exe tool is located.

Installing is no longer necessary under Stock Android 10-Q. It comes from /e/OS 'O’reo 8.1.2 times.

With the Stock Android 10 upgrade, the /Vendor partition is also updated and harmonizes perfectly with /e/ OS ‘Q’. The manual installation of /eOS ‘Q’ works flawlessly, the one with the /e/ays installer (v0.12-beta) is currently still massively buggy.

First of all many thanks for all the support you provide here in this ticket SuzieQ. It’s much appreciated. I’ve got one additional question about the instructions before giving it another try. Since patching the device failed by me is that also an old instruction or is that still needed.

Edit. It seemed the culprit was using adb in linux using a virtual machine. Although adb logcat etc. works apparently adb sideload failed. After installing adb in windows sideloading was successful. Thanks again for your support.

Hi, I’m trying to flash twrp on a friend’s s9+ but for some reason, I keep getting an error saying “only official released binaries are allowed to be flashed(recovery)” in Odin 3.13.1 to 3.14.1.
I think the phone was upgraded to Android 10 over-the-air. I am currently downloading the XSG-G965FXXSEFUA1 firmware from Sammobile 8hrs more to wait to try and re-flash Android 10 on the phone.

However, just wondering if anyone had had this issue and if there was anything I could do to try and fix the issue while the firmware is still downloading? Or if it is even a firmware issue rather than hardware?

For me this means: OEM UNLOCK is not yet activated.

Tip: Check the device status.

Strange, it says OEM unlocking is activated. Though I’m now wondering if it truly is activated. When I first factory reset the phone, and enabled developer mode the OEM unlocking option didn’t show up at all (not even greyed out) until I inserted my sim card into the phone. And now even after re-flashing the Android 10 firmware it is still doing the same thing.

I’ll re-flash again and possibly try to downgrade to 8 or 9 if that is even possible

According to Samsung’s will, this will no longer be possible …

That sucks.

I wonder if it is the security patch that was released February 1, 2021 that’s causing the issues with the flashing of twrp


This operation fails with message on your S9 display:

What are the numbers for °° and ¹¹ ?

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Ignore this…complete waste of time or at least doesn’t apply to this Android 10. One odd thing I just noticed is that enabling or disabling OEM unlocking forces a data wipe of the phone but keeps the developer options enabled. I don’t remember this happening when I did the install on my phone

Sorry,my replay was fagged because I posted a link to something I was reading about Samsung’s Vaultkeeper that I thought was the issue but it was a waste of time.
Anyway when I tried to install the SBETH2 version of the firmware that my phone uses rather than the SEFAU1 firmware for this phone, the SW REV. CHECK FAIL (BOOTLOADER) DEVICE: °° . BINARY: ¹ says

Been going through a few sites of the past few hours, and I just noticed while watching a video posted on xda-devs that the Bootloader on the phone has a Prenormal RMM State and the KS State says checking while on my phone there is no RMM State. On both phones OEM Lock and FRP Lock are off. I’ll presumably have to wait 7 days with my sim card in the phone to get rid of the prenomal. I guess

There is a lot of nonsense or guidance for older OS versions on the WWW. Samsung in particular has made a lot of changes with each version release, and with Android 10 in particular, so the old tricks no longer work these days.

This means that the stock Android ROM you want to flash has a binary 11, while the S9 has a binary 14. Samsung usually doesn’t allow you to flash to a lower binary than the one present in your device.

If your S9 had the firmware G960FXXSEFUA1 installed, a doengrade to Android 10 is G960FXXSBETH2 is no longer possible. Samsung has deliberately installed a bootloader lock here. Only the SEFAU1 version can be flashed again.

Tip: First install a completely new Stock Sndroid 10 G960FXXSEFUA1 and reboot the system with it.

1 Like


Thanks for this very informative thread. I’ve attempted the process myself, however I am having issues with heimdall. I’ve downloaded rom files from samfrew as recommended, however when flashing them with heimdall the process always gets stuck on odm.img . Any idea what I could do?

@pierrel, problems are so that they are solved. So let’s start with basics.

A correctly installed Heimdall tool works under Linux as reliably as Obin 3 under Windows.

Heimdall under a Linux derivative should be created as up-to-date as possible ~ Build Heimdall

Check your stock Android 10 for your SM-G960F* to make sure hardware and firmware match.

See you.

Hi @SuzieQ and thanks for your help ,

I’ve just build the latest version of Heimdall myself (instead of using the version from the arch linux repo) and the same error occurs:

Uploading ODM
ERROR: Failed to send file part packet!
ERROR: ODM upload failed!

Ending session…
ERROR: Failed to send end session packet!
Releasing device interface…

I am not sure what you mean by your last sentence, is it something I should check on the device itself?

So I sort of fixed my issue by reinstalling /e/ through the easy installer. That however got me 8.1.0 and not Q as expected, but at least I am able to use my device.

Probably won’t try this again anytime soon but who knows. I would still be curious to know if you had an idea of why it was not working for me.

@pierrel, that is anything but satisfactory.
Stock Android 10 on the S9 is already first class. However, CustomROMs like LineageOS (support now discontinued), iodè 10 and /e/ OS ‘Q’ Android 10 are the better choice for me. A return to /e/ OS 'O’reo is absolutely out of the question for me. That /e/ after all these weeks is still not able to let the /e/asy installer install a /e/OS ‘Q’ ROM is more than poor.

The same situation was with /e/ asy installer and Gigaset GS290 until a few days ago. The problem was fixed after weeks. Without me knowing, it can be assumed that the S9 /S9+ installation problem will also be fixed at some point. Until then, you must manage to upgrade your S9 to Stcok Android 10.

Only when a stock Android 10 is functional on your S9 will it be possible to install a CustomROM ‘10’ aka /e/ OS ‘Q’. For the sake of testing, I’m already running an experimental LineagsIS 18.1 (Android 11) and a GSI AOSP 11, which shows what’s possible and what we’ll still have a lot of fun with our S9 / S9+.

Still, it is the way it is - because the /e/ team doesn’t change anything. As a Windows and Odin user, I’ve not yet encountered your ERROR: Failed to send end session packet!, but brief research shows that this ERROR in connection with Heimdall goes back to the 2014 years.

1 Like