Samsung Galaxy S9 "only official released binaries are allowed to be flashed(RECOVERY)"

Hello, I used the Easy installer. I followed the instructions, but I encountered a problem. I got “only official released binaries are allowed to be flashed(RECOVERY)”, when phone was in recovery mode. The phone is currently running official Samsung Android 10. I do not have any Carrier lock (Which Americans suffer under). (I have uploaded the log by pressing the button in Easy installer)

Please look at the picture

What should I do now? I tried to find a solution, but there isn’t any, which I think would solve the issue. Note, that I have officially supported phone. How do you bypass the damn Samsung roadblocks?

Edit - the issue has been resolved. The problem was, that Samsung has this thing ( and in order to turn off that thing you have to connect to the net. After that " Prenormal KG/RMM State" will be turned off and everything will work. I experienced problems at the beginning because I didn’t connect to the web right after I enabled OEM unlocking.

1 Like

Are you sure that the bootloader is unlocked ?

/[HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully

It should be, but how do I check that?


If the ‘OEM unlock’ option is available in the developer options ,…
… the device can be allowed to be unlocked.

I plan on getting my S9 soon, and loading e, I am in the states and patiently await the opening of the site for purchase to the US, the people have no where to turn I am doing presentations now about privacy and future alternatives, if they will listen. Will this model be supported for the near future? Thank you /e foundation for all your work, the world needs you!! Viv la France!


Hi @luka,
sending parcels from EU to the USA involves bureaucratic work. The US customs authorities require a customs declaration of contents. Not every shipper wants to deal with this.

Smartphones with permanently installed batteries are treated as dangerous goods. Quite a few shipping logistics companies even prohibit the shipment of dangerous goods in foreign parcels. A commercial company will think twice before taking on this risk.

In short: Shipping from in France to the USA or even outside the barrier-free European Union (EU) is therefore unlikely.

HI SusieQ,

Understood, but why is it unlikely? very interesting sounds a little bit political as well Surely batteries in phones can’t be the prohibitive factor. I would like to research more in this area. So it is on the US end that is the problem?

Often times US blocks superior products as protectionist policies. very sad.

Thank You.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

That’s my personal assessment, after getting to know the /e/cosystem better.

By the way: My nickname SuzieQ is taken from the song of the same name by Creedence Clearwater Revival (abbreviated as CCR), a US rock band from Berkeley, California.

Hi @luka there are two types of phones that eShop sells …New and Refurbished …The ‘New’ here would refer to the Fairphone and Gigaset phones and the refurbished phones make up the rest. The Refurbished phones are A quality phones we source from our vendors. The quantity depends on the availability of a particular model in large numbers. Support will be available as long as the /e/ builds on a particular device are stable and the device is able to get some level of vendor and hardware support. You can write to for more information on this.

Thank very much Manoj! I want to help people here in the US while I am here, which suffer from such privacy issues. S9 are affordable for most, it is the poor who have little money and little knowledge of such thing whom I also wish to help. I will keep watch.

Please don’t forget Viva india !
where live a large part of the /e/foundation employees …

Ahh, I did not know YES!

Viva India!! and all your hard work!!

Thank you all my friends!

I am having this same issue on an S9+. I can’t get TWRP to flash because I am getting the same error (both via easy installer and via USB cable). Debugging is allowed and OEM unlock is enabled. I am at a loss.

I’m sorry I am not quite clear where you are stuck! :slight_smile:

Is Prenormal KG/RMM State your issue?

What did you make of the solution offered, in an “edit” by the original poster in post #1?

Thanks aibd. When in boot mode the KG says “Checking” and the RMM is “Prenormal” (so yes I think this is the problem). I keep getting “only official released binaries are allowed to be flashed(RECOVERY)” when trying to flash TWRP via ODIN, by command prompt and Easy Installer. I have tried all 3. I have tried via Windows, MacOS and Linux… I am stuck.

And to the edit in post 1, the phone is connected to the internet. I can’t figure it out. Everything shows the bootloader is unlocked but I can’t get into it. The phone is a SM-G965F/DS so the bootloader should be able to be unlocked.

It is another, further, level of Samsung’s “security”. The article offers different solutions and might need reading more than once. :smile:

And here’s another angle:

1 Like

Here is the exact issue I am having. I can’t event get TWRP on the phone. If you read the comments at the end of the article this is the exact issue I am having. Does anyone know of a fix? It seems that Samsung, Google, or Knox have released an update or patch that causes this and it won’t allow me access to the bootloader on this S9+ SM-G965F/DS.

Is there any possibility you still have any sort of lock, (even screen lock or PIN) or account, especially Google account, still exists within the phone?

In general you must remove all traces of ownership, especially by a third (or fourth) party before you Factory Reset.

Can you be sure you are doing exactly as required for “a Samsung first boot into TWRP”

A. Is there any possibility you still have any sort of lock, (even screen lock or PIN) or account, especially Google account, still exists within the phone?

A. I don’t believe this is possible. The phone was in a brand new sealed box when I received it. Before I opened the box I had the IMEI checked and it came back clean, the phone was a genuine new phone. When I first turned it on I did not create any PINs and I opted to NOT login to a Google account or Samsung account. So I am unsure what would be tripping KNOX to flag the RMM as “Prenormal”.

B. In general you must remove all traces of ownership, especially by a third (or fourth) party before you Factory Reset.

B. See answer in " 1." above. I never set up any PINs or passwords on this new phone (maybe this tripped Knox by not doing so?)

C. Can you be sure you are doing exactly as required for “a Samsung first boot into TWRP”

C. I can’t get this far along in the process because KNOX (RMM set to “Prenormal”) blocks TWRP from being flashed to the bootloader. The process begins (via ODIN, Command Prompt, and Easy Installer) but then fails at the very end. Because of this it is impossible for me to get to the Boot Recovery step.

Here is what It does when installing by Terminal (Linux):point_down:. I will post the line code from Odin and Easy Installer later.

Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
Protocol initialisation successful.

Beginning session…

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device’s PIT file…
PIT file download successful.

Uploading RECOVERY
RECOVERY upload successful

Ending session…
ERROR: Failed to receive session end confirmation!
Releasing device interface…

*:point_up_2:The phone does NOT shut down between " RECOVERY upload successful" > “Ending session…” It just stays in download mode.

So that is the error!

Well documented, thank you :smiley:
Uploading RECOVERY
RECOVERY upload successful

Please could you post an image of Download mode screen at this time?

It could still point to “timing” of the response to “TWRP installed” and boot into TWRP and not letting Samsung overwrite your new TWRP with the Samsung Recovery. Compare with "First TWRP link above. :slight_smile:

It just stays in download mode

How? Surely the [Vol - + Home + Power] eventually (12 seconds) stops Download mode to a black screen?