Galaxy S9 'starlte' + /e/OS 'Q' dev AOSP Android 10

Your anger and disappointment I clearly perceived. That’s why I’ve been covertly cynical in echoing it.

I had also expected the /e/OS ‘Q’ upgrade to be more up to date. The Android security patch status 5 November 2020 gives me the impression that the upgrade was pushed because of the great pressure of expectation. Well, at least the S9 / S9+ is now at ‘Q’ level and thus suitable for significantly more new users than with the 8-Oreo release.

My new test system is up and running: Numerous pre-installed apps are disabled for now, especially & openweathermapprovider and, because weather apps generally have a reputation for being chatty. For me, chatting all day is enough :))


Use the open-source Android firewall NetGuard Pro version (paid version), because only the Pro version unlocks those functions that are essential for monitoring and controlling outgoing (app) data connections even without root rights.

The update from microG to microG (with the option ‘Exposure Notifications’ OFF, which I like) was successful with my tried and tested method.

Well little Miss @SuzieQ, down the rabbit hole I go. :slight_smile:

I just downloaded and installed NetGuard Pro. I tried TrackerControl via F-Droid, but it was a bit wonky for me. Anything I should be aware of?

Hi, I got /e/OS ‘Q’ up an running on my S9 and I’m liking it so far. However, I can’t get Netflix / Prime Video etc. to stream content. It worked on the /e/ Oreo build but not on Q. After some looking around it seems to be a DRM issue, but I can’t find much more info on it and no solution so far.

Is anyone else having this issue? Or know a fix?
Any help / suggestions would be appreciated.

If you knew what my natural height was, you would be careful not to call me ‘little miss’ … :))

I don’t understand what that means “a bit wonky”.

I apologize. This was meant as a term of endearment, no offense was meant!

It refers to something that is supposed to work, should work but doesn’t work as expected and there’s no specific reason or explanation why- a gremlin, a ghost in the machine…

For example, even when TC was set to “off”, ProtonMail would complain that it could not connect and /e/ services (mail, contacts, etc.) would fail with an I/O error.

I didn’t misunderstand your wording. I still enjoy listening to SuzieQ in the long version from 1968 by CCR.

Well, apps like Netguard and TrackerControl are tricky tools. Take your time to learn how to use them.

Hello SuzieQ,

Thanks a lot for sharing your experience!
Why did you choose the older firmware release of April 2020? Is a newer one problematic?
Maybe you can give me a hint :slight_smile: . Thank you!

Hello @whoknows,
the Aril 2020 firmware was present on the S9. I deliberately did not update it to test the behaviour of the S9 when I install AOSP 10 like LOS 17.1 and /e/OS ‘Q’.

I was inspired to do this test by the note on the LineageOS Wiki website »Warning: Before following these instructions please ensure that the device is on the latest Android 10 firmware.» I took it very seriously and literally “latest Android 10 firmware”. The buzzword ‘latest’ was the definitive reason to ask me: what happens if I use the stock Android firmware from April instead of December 2020 as a baseline. Well, absolutely nothing ‘problematic’ happens. LOS 17.1 and /e/OS ‘Q’ could be installed completely stress-free.

1 Like

A new release for AOSP Android 9 but not for AOSP Android 10? Why would TeamWin do such a thing? Please let the following TeamWin statement roll off your tongue:

TWRP 3.5.0 is out now for most currently supported devices.

For this release we are breaking down new support for devices based on android trees and device compatibility. For Pie and earlier devices, they will be built out of the android-9.0 branch. For devices that are released with Android Version 10, they will be supported under the android-10 branch.

Please give us a link to that statement.

My interpretation is this: There are two versions of TWRP 3.5.0_9.

TWRP 3.5.0_9 for ‘9-Pie’ and earlier devices they will be built from the android-9.0 branch.
TWRP 3.5.0_9 for ‘10-Q’ they will be created from the android-10.0 branch.

Warning: The Samsung Galaxy S9 is no longer maintained. is not joyful ews. So is S9+ 'star2lte’. It is likely that the Galaxy S9 / S9+ will sooner or later suffer the same fate as the S7 / S7 Edge … :((

But - Galaxy S9 / S9+ are Project Treble supported device and with /e/ GSI ROM 10 and custom 11 both devices can be used as degoogled smartphones for quite some time.

Hi @TomK, on the Galaxy S9 / S9+ with AOSP Android 10, encryption is automatically enabled. After installing and restarting LineageOS 17.1 and /e/ OS ‘Q’, the message ‘Encrypting’ with the ‘android robo’ briefly appears.


When installing TWRP 3.5.0_9-0 on the Galaxy S9+ ‘star2lte’, I eliminated this encryption via ‘Disable Force Encryption’. I can now enable/disable encryption independently in the S9+. Take back control …

Your points 1 to 5 would have to be tested individually to be able to give concrete answers.

My S9+ ‘star2lte’ is currently running the GSI /e/ OS ‘Q’ ROM for testing purposes, is unencrypted and I can access the Internal storage and microSD card with no restrictions with PC-and-USB-Cabel.

Just wondering if there are step-by-step instructions on installing for a newbie? Or will this be eventually rolled out to the easy installer?
That said, would actually like to know how to install the Samsung firmware on my S9+ after installing e/OS/

For my better understanding: You want to go from /e/OS back to Samsung Stock Android 10?

as i see you are on DTD7 baseband … which may mean that you are not using the “latest” version of samsung rom … this point to a version from 04/2020 … and “bit 9”

do you have experience with later “bit” …latest would be “Bit D”

the reason for asking is, that it is not possible to downgrade from a higher bit …

Correctly noted, @ak.13
I wrote in the introduction “Samsung Firmware Android 10, build date April 2020” and wanted to see if this has any (negative) impact (Please take a look at Posting #28).

Experience with (later “bit” …) aka December 2020 release I’ve with my Galaxy S9+ ‘star2lte’.

Yeah, Samsung has added quite a few layers of security and additional rollback lock into its updates over time. That was an additional reason not to update the above April 2020 build to December 2020.

Hi SuzieQ,
Yes and No.

No because I think I misunderstood sections of this thread to be that I could install the Samsung firmware after installing /e/OS. Therefore I would be able to get Samsung apps like Dex, smart shift, and Find working.

Yes because I see now that the Samsung firmware flash is to get from the current /e/OS to e/OS Q. Unless the /e/OS installer application will be able do that upgrade once /e/OS Q is ready for production roll out.

Samsung apps like Dex is proprietary software through and through and only works with original Samsung Stock Android. My DEX Station now only serves as an S9 cradle and charger … :(( … :)))

Was finally able to upgrade to /e/OS Q. It took about 5hrs, but most of that was me making newbie errors and switching to Windows 10 and Odin because I didn’t fully understand how heimdall-frontend works in Linux.

The pain and bulk of the 5hrs really came from trying to install TWRP once I had flashed stock Android 10. For some reason, the command line:

fastboot flash recovery twrpimagename.img

would always return “waiting for device” so I ended up using Odin to flash TWRP and rooting the S9+ with Magisk Root and Disable_Dm-Verity_ForceEncrypt. The first attempt saw me trip the 7-day ‘OEM Unlocking’ lockout because I hit reboot instead of the back. Then fumbled around in TWRP till I found out how to set TWRP to accept the adb sideload command from the computer and wiping the cache in TWRP for /e/OS Q to boot properly.

Anyway happy I went through all that if for nothing more than the learning and pleased with how /e/OS Q performs relative to the Oreo I was on before.

Thanks again