Gallery app deletes pictures with a swipe up/down?!?

I found out quite by accident that Gallery apparently deletes pictures if you’re viewing a “timeline” and you swipe a picture up or down instead of scrolling sideways through them? No warning, no confirmation, no undo?

This is not very user friendly. I lost some pictures I actually wanted to keep.

Someone is not thinking about UX…

Hello everybody,
today I wanted to erase a picture from the gallery:
I was viewing the picture in full screen and pressed the trashcan symbol.
I have done that many times before since I am using e since August last year.
But to my surprise not only the one picture I was viewing was erased, but almost all pictures I took today…
Can anybody tell me whether there is a way to restore erased pictures?

Hi @mvdwehl pl can you raise this suggestion here on Gitlab . It can be added to improve the gallery.

1 Like

Only if the pictures were stored on a microSD card instead of the internal memory, there is a small chance to reconstruct pictures. Otherwise they are lost.

Tip: Simple Gallery Pro from F-Droid Store

Simple Gallery Pro is a highly customizable offline gallery. Organize & edit your photos, recover deleted files with the recycle bin, protect & hide files and view a huge variety of different photo & video formats including RAW, SVG and much more.

1 Like

If the picture is being synchronized with /e/ Cloud, you may find it in “Deleted files” (bottom left in /e/ Cloud web interface).

1 Like

Thanks for the replies, both for my benefit and for other users who have had similar problems.

My original post was a little irritated, because I lost a nice picture. But the sun will rise again, and I’ll take another picture of a beautiful dawn sky.

The real point was the bad UX (User eXperience for those who haven’t encountered the jargon). Gallery is the default app in /e/ for browsing pictures. It should be easy and intuitive to use. All of the /e/ apps should make /e/ a joy to use. I did not feel joy last night.

The /e/ UX should encourage experimentation and discovery without letting the user fall into traps. “Swipe up/down to remove a picture from a timeline” isn’t a bad idea; but “delete a picture with no warning and no way to recover it” is a terrible thing. Swiping up or down could ask for a confirmation; or pop up a toast (I think that’s the right term for a notification like this) that the picture has been moved to a discard collection (which can eventually be emptied manually); or add it to a set of tiny thumbnails of pictures that no longer belong to a timeline; or something else.

I appreciate @Manoj’s gentle reminder to enter issues on Gitlab. I’ll get over there and do that. I’m a software developer (although my code usually has more to do with poking values in device control registers to operate the hardware than providing user interface), so maybe I need to start digging into some /e/ source code.

Can you say exactly what steps you were doing when the deletion happened. I cannot reproduce that and no one else has thrown in a “me too” yet.

By default the Gallery starts in Timeline mode. From that mode I viewed a number of images, swiping up and down among them. The only thing happening is my swiping mostly being interpreted as a side swipe. No deletions at all.
Given that the gallery app is essentially the same as the one included in a majority of custom ROMs (package name the behavior should be the same across the board. I have never seen or heard of deleting when swiping up/down.

Was curious so I checked/compared on other ROMs I run.
/e/OS 0.9 Pie, Gallery (, v1.1.40030.
Candy7 Nougat, Snapdragon Gallery (, v1.1.40030.
AOSiP Oreo, Gallery (, v1.1.40030.
crDroidAndroid Nougat, Gallery (, v1.1.40030.
/e/OS 0.9 Nougat, Gallery (, v1.1.40030.

[ Gallery has essentially gone unchanged, hence the same version number through three Androids ]

Did a lot of swiping. No deletions. I just can’t see where there’s a UX problem. Don’t forget, /e/ didn’t create the Gallery app.

I’ve never used the film-strip view before, in all these years, so I tried that. From there one can swipe up/down to delete files. You can undo each swipe also ( Heh, my thumb was obscuring the Undo button I didn’t know was there. So I permanently “lost” a few test images).
Anyhoo, since you said “timeline” and not film strip, I’m not sure what’s what.

When I wrote my original post, I thought I had been in Timeline mode. I went back to reproduce this so I could enter an issue in Gitlab, and found I had to be in Album mode. (You called it film-strip view, I’m old enough to remember film, is that an official term for it somewhere?)

Now I see there is an Undo button - but as you found too, it’s easy to miss it (especially if your eyes are looking at the pictures, and you just swiped up - the button is at the bottom). It’s also very ephemeral, and disappears if you touch anywhere else on the screen.

I’m an unsophisticated smartphone user - I’ve been avoiding the Goolag all these years. That fleeting Undo was sure easy for me to miss. Maybe for some people with more experience, this is like “duh, don’t step off the curb without looking both ways, and don’t touch anything but the Undo button after accidentally deleting something.”

The issue in Gitlab, with detailed instructions on how I reproduced it:

I’ll update it later with comments about the ephemeral Undo button.

I looked briefly at the source code repository and saw a lot of things that hadn’t been touched in seven years (!), and AOSP copyright notices. I also saw somewhere that this app was forked from LineageOS. Is it really “forked” in the sense of now maintained complete separately (does /e/ have its own copy?), or does it track changes and updates in AOSP?

1 Like

Ah, I see now. I mentioned that I’ve never used this “film strip” or “film roll” mode before. Only now discovered it when I was searching for your issue out on the web. I used to use QuickPic on all of my ROMs until it couldn’t be trusted anymore (up to v4.5.2) so never spent much time in Gallery.

Timeline, Album, and Videos all behave the same way. Swiping up/down will not delete anything. This film roll mode, where swipe deletions happen, is available in all three sections by pinching in on an image.

I agree, it would be mice to have a change in the delete & undo areas. When swiping out an image get a confirmation dialog with a don’t-ask-again option for those who are sure.
Not sure about the Undo but it definitely needs to be located in a more visible area. Gallery is not the only app where my hovering thumb was covering something important located at the bottom right.