Gigaset 290 (GS290-not preinstalled /e/) Bricked

Gigaset GS290 ( 2020 )
Fedora 33 ( with an unstable /etc/yum/repo )

Unfortunenately I justed experience that my Gigaset 290 endet up being bricked ( When the phone is useless like a brick ). After using the Easy-installer in Fedora 33 which worked like a charm and no complications.

I ask some experienced users for help here. The only problem I can remember is that it had Android version 9 installed. Even that I tried to update the smartphone to the newest System OS.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Did Easy Installer give no warning that you must upgrade to Android 10 before installing /e/ q, which itself is Android 10?

Please be very careful not to spam the phone with different solutions. Let’s see if we can get any help from the log. Use this page to help you find it.

Please can you give your most accurate description of the state of the phone.

Post script edit This search currently shows 15 results for bricked GS290, please do more reading and feel free to ask before commiting.

Bon chance



1 Like

No warning or any indications showing that something were wrong. Not either on the smartphone display which I very carefull but excitet as a little child watched the whole process even it was very small white letters. The Easy installer and every step I followed corectly and as GUI view it looked like everything was going to end up good with an /e/-OS. But as told I waited for the logo to show up before finishing the proces. But surprisesingly it all turned blach and bricked on the phone.

The problem is that I can not get in contact with the device from the Terminal using:


[TemplePusher@jonas-bloch-riisgaard ~]$ adb devices

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    List of devices attached

[TemplePusher@jonas-bloch-riisgaard ~]$ adb logcat -d logcat.txt

  • waiting for device -’’’

Hi @anon21640558 thank you for that description.

Is it possible for you to provide the Easy Installer log?


adb devices

to try to connect to the device harmlessly is a good idea, as you say, you have no easy method to connect at the moment. Please can I urge you to be patient and avoid spamming the phone with “new ideas” while you keep reading to find the solution.

You will have read the threads here about bricked GS290. Please wait for good information!

Please can you check whether you have any control over the device. In a darkened room if you press the power button for say 12 to 15 seconds is there any reaction?

Does the device react to it’s charger in any way?

GS290 has no way (known by me) to force stop which could possibly help. Back in the day we would disconnect the battery to achieve this. This is not an option.

One way to get a force stop is simply to run down the battery to zero. This may take a long time, but consider not recharging the device so that you can understand if this might be a solution for you.

However, never undertake rescue jobs in a low state of battery charge. This is a dilema I will return to.

Bon chance

PS The GS290 manual states that they provide a charging cable with the device. We see many cases where the cable is the problem. I have a dedicated charging cable, and a quality data cable which I use only for data transfer.

1 Like

> Please can you check whether you have any control over the device. In a darkened room if you press the power button for say 12 to 15 seconds is there any reaction?
Unfortunately no reaction or sign of life. It was connected to the labtop. I now disconnect so it doesn’t load. I’m using the cable which came with the phone. Is it a loading and data cable ?
Tried to connect to the power supply as well. nothing happens. The phone is completly bricked.

Yes, I will wait to the right solution comes up though. First of all I need to come in contact with the ROM.

Thank you for all your replying. It is really clear and learnfull for me and the forum.

Hi Jonas,
maybe it is foolish to ask. But why don´t you try the installation with a different Linux? I used openSuse for the initial installation of /e/ on various GS290 (with Android or Ubuntu Touch as origin OS) and later on with the easy installer without any problems. I´m neighter skilled with Linux nor Android.
If you want you can send me a PM and we can have a look togehter.

1 Like

Linux and e is a very new world for me. I suddenly ended up with a lot of “homework” becourse there is so much to read about and do.

I am very glad that you want to help me. How did your install the e/-OS at your GS290. With Easy installer or ?

Hi Jonas,

ok. I made:

  • revert installation from Ubuntu Touch to Android and later on the /e/ installation with ADB (0.14 dev)
  • installation on a brand new GS 290 with ADB (version 0.14 dev)
  • revert Installation from /e/ to Android and later on the /e/ installation with easy installer (because the update function was not working (and I was annoyed because of the unlocked boot loader) .

Is this what you are asking for?

Why do I care? I asked initially for /e/ on GS 290 so I´m feeling somehow guilty to see you in the mudd additionally I wrote some of the documentation w.r.t to revert from non-Android to Android as initial step to install /e/.

How would I suggest to process? Call via / teamviewer or you send me your dead device with DHL (the latter I would prefere).

Just to be clear, there is no guarantee that we see success at the end.



Thank you very much for your support. It is really appriciated.

First of all I have to digest all the impressions and keep track of all tasks to do in right order and when to do what.

Do not fill guilty. Things goes wrong with purpose. There was a lot of warning before t I did the bricking. And we all have different systems and OS on our hardware.

But I would be pleased to contact you after the weekend perhaps. Becourse I really should learn this and unbrick as a learnfull assignment to which is very important to keep focus on solving.