Gigaset - GS290 - gs290 - Documentation Suggestions

I am not 100% sure, but as far as I remember, this also did not work with openSuse 15.2 for me.

have you tried :

chmod +x flash_tool
sudo useradd austrasier dialout
newgrp – dialout

1 Like

I have opensuse 15.2 here and I do have the useradd executable in the package shadow.

But nevertheless, what the failing command is supposed to do: add your user to the group dialout. That should be doable with

sudo usermod -a -G dialout austrasier
newgrp - dialout
1 Like
chmod +x flash_tool

I did the chmod command and it worked.

 sudo useradd austrasier dialout

Interesting. useradd seems to be the right command. adduser ist not installed on openSuse, but useradd is installed, but only root can use it. This command fails, because the syntax of useradd is wrong. It shows the help page of useradd, which explains its syntax. What is supposed to be done by this useradd command? My user already exists. Is it about adding my existing user to the group dialout? Then maybe another command would be better?

 newgrp – dialout

newgrp prompts me for a password, but I don’t know which password is correct. Both my user password and the super user password fail. Which password am I supposed to type in here?
edit: now after running the command “usermod -a -G dialout austrasier” from Ingo_FP_Angel the newgrp command works without prompting for a password

Now I wanted to start SP Flash Tool from command line, but it fails with

flash_tool: cannot connect to X server 

This error only occurs, when I do the newgrp command before starting flash tool.

When you add a user to a new group that only becomes active on next login.
newgrp is supposed to do that without actually loggin out an in again. It seems it has some problem on it’s own.
It’s probably easiest to log out and back in immediately afterwards.

1 Like

I rebooted my PC. I started SP Flash Tool again. I press Download, plug in the device, and nothing happens. But when I read the output in the command line, the problem seems to be, that the device can not be found. When I start SP Flash Tool and click “Download”, i get the following output in console:

No protocol specified
QObject::moveToThread: Cannot move objects with a parent
support_dl_cert_to_storage: 0
Connecting to BROM...
Scanning USB port...
Search usb, timeout set as 3600000 ms

When I then plug in the device, the following output is written:










When I then press “Stop” (because nothing happens anyway), the following output is written:

SearchUSBPortPool failed!
Failed to find USB port
Connect BROM failed: S_TIMEOUT(1042)
User stopped.

When I then close SP Flash Tool, the following output is written:

comboTimeout index(3) saved.
Speicherzugriffsfehler (Speicherabzug geschrieben)

It’s a rather wild guess, but maybe it has to do with missing udev rules that allow access to USB devices for a non-root user. I remember that from fiddling around with Ubuntu Touch some years ago.

See “Missing udev-rules” on Install Ubuntu Touch - UBports documentation

And it seems opensuse has a package for that (haven’t tested it myself, though).

1 Like

I tried to install the opensuse package android-udev-rules. Installation failed in the first try because of some repository meta data issues. Then I tried it again, and it worked in the second try. Don’t ask me why it failed and then worked, but now this package is installed on my system.

I rebooted my PC. Then I tried it again with SP Flash Tool and it was working! Yeah! But then I pressed “Stop” because I have an important question: The Ubuntu Touch install guide, that Ingo_FP_Angel linked in the previous post, says:

If you select DOWNLOAD ONLY rather than FIRMWARE UPGRADE, you will end up with a useless brick rather than a fancy Ubuntu Touch device. Be sure to select FIRMWARE UPGRADE.
Also, after selecting the *Android_scatter.txt, the drop-down menu choice is reset to DOWNLOAD ONLY. Be sure to select it after selecting the file.

Why says the /e/OS guide I linked in my first post to choose “Download only” and the Ubuntu Touch Guide warns about setting “Download only”? I dont want to brick my device.

Sorry for that, this issue is publicly denonced for months, and the documentation is still unclear ?..

@smu44 please explain…

I ran SP Flash Tool again and I did “Download only” and it worked. I now have the Gigaset Stock Android running on my phone.

1 Like

Now the Gigaset Android Stock Android is running on my phone, but there is one problem: No Sim Cards are detected. I tried turning on and off and putting sim cards out and in but still no sim card is detected.
Should I ignore this and just start installing /e/OS?
Or should I run SP Flash Tool again and do “Firmware upgrade”?

By the way, the package “android-udev-rules” was not needed. After adding my user to the group dialout, I made the mistake to plug in the device when the device was switched on, but the device has to be switched off.

In the documentation

The part

chmod +x flash_tool
sudo adduser <username> dialout
newgrp – dialout

should be changed to

chmod +x flash_tool
sudo usermod -a -G dialout <username>
*and then reboot your PC*

because the command adduser does not exist openSUSE and the command newgrp had the problem,
that SP Flash Tool could not start because of problems with connection to the X server.

As already mentioned I now have Gigaset-Stock-Android running on my phone and have the problem, that no sim cards are detected. What should I do now?

I wouldn’t reboot. Just exit the current desktop session, much faster and has the same effect.

Hi, at the time of writing the documentation (one year back from now) the steps were fully correct.
I followed them several times with different GS290 devices.
Please consider that things have changed with OpenSuse Leap15.3. compared to 15.1 and 15.2.

Just for curiosity. Did you try to install /e/ with the easyinstaller or why do you have choosen the manual installation procedere?

Hi, at the time of writing the documentation (one year back from now) the steps were fully correct.
I followed them several times with different GS290 devices.
Please consider that things have changed with OpenSuse Leap15.3. compared to 15.1 and 15.2.

I have a notebook that is still running openSUSE 15.2, and I just checked it: adduser ist not installed, neither for normal user, nor for super user. So if this worked for you, you installed adduser on your system, but this is not a standard installation.

Just for curiosity. Did you try to install /e/ with the easyinstaller or why do you have choosen the manual installation procedere?

easy-installer for Linux only exists as snap AFAIK. I never managed to run snaps on openSUSE. I tried it again today with this guide

The installation worked, but it doesn’t run snaps. I only get error messages when i try to run the easy-installer-snap. I would prefer it, if the easy-installer for Linux would not be a snap but an AppImage.

I had the problem, that no sim card was detected. So I tried to do the “Firmware Upgrade” from SP Flash Tool. The device is bricked now. I did this on my own risk. If I want to do the “Download only” from SP Flash Tool, I get the following error (see picture). If someone has an idea, how this error can be solved, I would be very pleased.

Use the search bar, you are not the first one in this case…

I suggest trying to unbrick using Windows : /e/ installé avec easy installer sur GS290... le téléphone ne démarre plus - #17 by smu44

Windows 7 ISO download : (trial period should give you enough time).

I think that VirtualBox or VMware Workstation Player should work, as long as you give the VM access to USB ports (VirtualBox) or access to USB ports (VMware).

When done, you could resume openSUSE trial :slight_smile:

Alternatively, if you live in E.U., you can contact me privately.

1 Like

The need for a signed image is reported in this bug report

It would be useful to know exactly what assistance was provided in that case by Gigaset as mentioned in the closing post.

(While the hint and one answer in the bug report mentions the signed image a further clue is in disable verified boot.)

My GS290 is functional again. I contacted Gigaset Support. I showed them the link posted by aibd, which ends with “Gigaset helped us to recover the 2 devices, good news!” and told them, that they already solved my problem two months ago, maybe they can do the same for me. So I sent it in to Gigaset support and they did the software repair for me, btw I have to pay for this service but I think this is fair.

So now my GS290 is working again. So now back to the documentation:

Why is the part with OEM unlock twice in the documentation?
Under the headline “Before installation” the point 5 is “Unlock your device” and then
there is the big headline " OEM Unlock your device" with the same content we already had at point 5 of the previous headline.

Under the headline “Install /e/” the point 5 is " Press volume up on the smartphone"
but when I do “adb reboot bootloader”, the phone is just in fastboot - pressing volume up
doesn’t have any effect.

I tried to do the first fastboot flash command

fastboot flash --disable-verity --disable-verification boot boot.img

but I am getting the following error

terminating with uncaught exception of type sdt::out_of_range: basic_string
1 Like